Bug 158840 - [PATCH] comms/gammu: plist is broken if shells/bash is installed
Summary: [PATCH] comms/gammu: plist is broken if shells/bash is installed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Boris Samorodov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-12 17:50 UTC by R.Mahmatkhanov
Modified: 2011-07-30 20:32 UTC (History)
0 users

See Also:


Attachments
file.diff (461 bytes, patch)
2011-07-12 17:50 UTC, R.Mahmatkhanov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description R.Mahmatkhanov 2011-07-12 17:50:11 UTC
If bash is installed, comms/gammu installs this file:
/etc/bash_completion.d/gammu and leaves it upon deinstall.

So the problem is (in case of bash installed):

  - gammu installs files to /etc
  - plist is broken in case of bash installed. 

The first issue can be fixed with patch attached, but the second one
needs some cmake or ports foo to install this completion script only
if bash is installed/requested. 


Maintainer already notified and i filed this pr by his request as 
reminder.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2011-07-12 17:50:29 UTC
Responsible Changed
From-To: freebsd-ports-bugs->bsam

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2011-07-30 20:27:42 UTC
bsam        2011-07-30 19:27:29 UTC

  FreeBSD ports repository

  Modified files:
    comms/gammu          Makefile 
  Added files:
    comms/gammu/files    extra-patch-contrib_CMakeLists.txt 
  Log:
  Create an OPTION to install a bash completion script (off by default).
  Do not install the script when this option is disabled. I.e. even
  if bash is installed one should define the option "on" (or define
  the environment option WITH_BASH) to install the script.
  
  PR:             ports/158840 (based on)
  Submitted by:   Ruslan Mahmatkhanov <cvs-src@yandex.ru>
  
  Revision  Changes    Path
  1.62      +13 -0     ports/comms/gammu/Makefile
  1.1       +11 -0     ports/comms/gammu/files/extra-patch-contrib_CMakeLists.txt (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Boris Samorodov freebsd_committer 2011-07-30 20:32:22 UTC
State Changed
From-To: open->closed

Committed, thanks!