Bug 159964 - [PATCH] mail/qmail Add smtpauthuser and SRS support
[PATCH] mail/qmail Add smtpauthuser and SRS support
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Chris Rees
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-21 11:50 UTC by nbari
Modified: 2011-09-09 18:30 UTC (History)
1 user (show)

See Also:


Attachments
FreeBSD-qmail-port-patch.diff (2.90 KB, patch)
2011-08-21 11:50 UTC, nbari
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description nbari 2011-08-21 11:50:07 UTC
2 patches for qmail-ldap

SMTPAUTHUSER && SRS support

The idea is to prevent SPAM, controlling or limiting the number of emails that an account/email could send.
Before a user is available to send email, It must be authorized, using an email/password, this normally is know as SMTP AUTH, this patch sets an environment var called SMTPAUTHUSER containing the email used on the the authentication process.
A user can send email using his own email address or on behalf others, but either the way he does it the SMTPAUTHUSER ENV var will never change rather the 'From' field.
One you have the ENV var, is up to you how to use it, you can use a custom qmail-ldap scheme to set limits per user, or you can use a global limit with out need to modify the ldap.

http://code.google.com/p/qmail-ldap-smtpauthuser/wiki/HowTo


SRS support

Enable support to SRS (Sender Rewriting Scheme) on qmail-ldap 

this patch depends on mail/libsrs2

http://www.qmail-ldap.org/wiki/index.php/SPF_and_SRS
Comment 1 Edwin Groothuis freebsd_committer 2011-08-21 11:50:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->garga

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Chris Rees freebsd_committer 2011-08-21 11:56:22 UTC
State Changed
From-To: open->closed

Duplicate of ports/159965
Comment 3 Chris Rees freebsd_committer 2011-08-21 16:49:43 UTC
State Changed
From-To: closed->open

Reopen after linimon closed ports/159965 for the same reason
Comment 4 nbari 2011-09-08 17:04:27 UTC
Hi, any status ?
Comment 5 Chris Rees freebsd_committer 2011-09-08 19:51:15 UTC
Responsible Changed
From-To: garga->crees

I'll take it.
Comment 6 Chris Rees freebsd_committer 2011-09-09 18:28:44 UTC
State Changed
From-To: open->closed

Committed. Thanks!
Comment 7 dfilter freebsd_committer 2011-09-09 18:28:44 UTC
crees       2011-09-09 17:28:30 UTC

  FreeBSD ports repository

  Modified files:
    mail/qmail           Makefile distinfo 
  Log:
  - Add SMTPAUTHUSER and SRS support
  - While here, use WANT_QMAIL rather than hideous relative include
  
  PR:             ports/159964
  Submitted by:   Nicolas de Bari Embriz <nbari@dalmp.com>
  Approved by:    garga (carte blanche via email)
  
  Revision  Changes    Path
  1.155     +28 -5     ports/mail/qmail/Makefile
  1.80      +6 -0      ports/mail/qmail/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"