Bug 160023 - editors/libreoffice: LibreOffice Calc 3.3.3_2 crashes on "Format Cells"
editors/libreoffice: LibreOffice Calc 3.3.3_2 crashes on "Format Cells"
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: office
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-23 13:20 UTC by travis.hunter
Modified: 2011-10-07 06:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description travis.hunter 2011-08-23 13:20:01 UTC
I hope I'm submitting this in the right category, if not please move it or tell me where I should post it. Anyway...

I compile editors/libreoffice from the ports collection, version 3.3.3 rev. 2 with config options: CUPS, GNOME, JAVA

As a dependency, jdk16 is pulled in. Compiled with options: WEB, POLICY, TZUPDATE
The portrevision is: 25

Now when using Calc and trying to "format cells", say, to place a border around specific cells, Calc crashes. The format cells dialog never comes up.

Fix: 

Uninstall jdk16 rev. 20 and install openjdk6 ver. b23, rev. 1

I do not know if this particular revision is the only one that will work, I suspect others will as well, but I have not tested them. This is version that was in ports at the time I installed it. In my case there was no need to recompile LibreOffice; Calc "Format Cells" now opens with the dialog and can properly apply formatting.
How-To-Repeat: Compile LibreOffice 3.3.3_2 from ports with above options. jdk may need to be compiled with those options as well, but I did not try to compile it with different options (long compile time). Then open Calc and try to format some cells.
Comment 1 Mark Linimon freebsd_committer 2011-08-25 00:43:56 UTC
Responsible Changed
From-To: freebsd-java->office

Fix synopsis and assign.
Comment 2 dfilter freebsd_committer 2011-09-05 12:45:47 UTC
bapt        2011-09-05 11:45:31 UTC

  FreeBSD ports repository

  Modified files:
    editors/libreoffice  Makefile distinfo 
    editors/libreoffice/files 
                              patch-clone__filters__oox__source__token__makefile.mk 
                              patch-clone_ure_sal_inc_sal_main.h 
                              patch-configure.in 
                              patch-solenv__inc__unxfbsd.mk 
  Added files:
    editors/libreoffice/files 
                              patch-clone__components__automation__source__testtool__objtest.cxx 
                              patch-clone_libs-gui__tools__inc__solar.h 
                              patch-set_soenv_in 
  Removed files:
    editors/libreoffice/files patch-solenv__inc__unx.mk 
  Log:
  - update to 3.4.3
  - New options:
    * SYSTRAY to activate the system try icons (quick start)
    * GTK (which to be able to build a completly gtk free version of libreoffice please notice that dependencies can bring back gtk, for example libgsf if not built with the following knob: WITHOUT_GCONF)
    * the GNOME option automatically activate the GTK one
    * PYUNO do enable/disable the build of the python bindings for the UNO framework
  
  - Disable system notification while building
  - Remove the wiki-publisher extensions, it forces the build to have 3 apache-commons distfiles bundles and one of them the httpclient was failing with some locales activated
  - Use pax instead or tar cf | tar xf, it is way faster to install
  - Fix reading/writting MS Office documents
  - Fix random segfaults: cell rendering options in calc, languages setting in global options
  - Largely reduce built time
  - Unbundle more things
  - Be able to work with packaged hunspell, thesaurus and hyphenation as well as the usual extensions
  - Now cups is mandatory (configure script is bugguy without cups)
  - remove broken
  
  PR:             ports/157357 ports/156038 ports/158945 ports/159287 ports/160023
                  ports/160318
  Submitted by:   Hartmann, O. <ohartman@zedat.fu-berlin.de> (ports/157357),
                  Kuan-Chung Chiu <buganini@gmail.com> (ports/156038),
                  Dmitry Pryanishnikov <lynx.ripe@gmail.com> (ports/158945),
                  Adrien <pmn@bakarika.net> (ports/159287),
                  Travis Hunter <travis.hunter@gmail.com> (ports/160023),
                  gcooper@ (ports/160318)
  With hat:       office@
  
  Revision  Changes    Path
  1.25      +124 -64   ports/editors/libreoffice/Makefile
  1.7       +46 -50    ports/editors/libreoffice/distinfo
  1.1       +14 -0     ports/editors/libreoffice/files/patch-clone__components__automation__source__testtool__objtest.cxx (new)
  1.2       +3 -3      ports/editors/libreoffice/files/patch-clone__filters__oox__source__token__makefile.mk
  1.1       +15 -0     ports/editors/libreoffice/files/patch-clone_libs-gui__tools__inc__solar.h (new)
  1.2       +5 -5      ports/editors/libreoffice/files/patch-clone_ure_sal_inc_sal_main.h
  1.2       +79 -3     ports/editors/libreoffice/files/patch-configure.in
  1.1       +26 -0     ports/editors/libreoffice/files/patch-set_soenv_in (new)
  1.2       +0 -17     ports/editors/libreoffice/files/patch-solenv__inc__unx.mk (dead)
  1.2       +22 -18    ports/editors/libreoffice/files/patch-solenv__inc__unxfbsd.mk
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Baptiste Daroussin freebsd_committer 2011-09-05 12:48:16 UTC
State Changed
From-To: open->closed

Should be fixed in libreoffice 3.4.3.
Comment 4 Wayne Sierke 2011-10-06 05:39:16 UTC
I recently installed libreoffice-3.4.3_1 to replace openoffice and the
OP problem still occurs for me. That is, libreoffice Calc will crash by
attempting to use "Format Cells..." whether by right-click/context menu,
via "Format->Cells..." menu, or shortcut key "Ctrl+1".

# make showconfig
===> The following configuration options are available for
libreoffice-3.4.3_1:
     WEBDAV=off "Support webdav protocol"
     KDE4=off "With Qt4/KDE4 vclplug support"
     GTK=on "With GTK vclplug support"
     GNOME=on "Better integration in gnome environnement"
     JAVA=off "Add Java support (XML Filters, macros)"
     PYUNO=off "Allow to script libreoffice in python"
     SYSTRAY=off "Enable systemtry quickstarter"
     MMEDIA=off "Enable multimedia backend for impress"
     SDK=off "Build with SDK"
     DEBUG=off "Build with debug symbols and verbose output"
===> Use 'make config' to modify these settings
# uname -rms
FreeBSD 8.2-RELEASE i386
Comment 5 Baptiste Daroussin freebsd_committer 2011-10-07 06:47:23 UTC
On Thu, Oct 06, 2011 at 05:00:29AM +0000, Wayne Sierke wrote:
> The following reply was made to PR ports/160023; it has been noted by GNATS.
> 
> From: Wayne Sierke <ws@au.dyndns.ws>
> To: bug-followup <bug-followup@freebsd.org>
> Cc:  
> Subject: Re: ports/160023: editors/libreoffice: LibreOffice Calc 3.3.3_2
>  crashes on "Format Cells"
> Date: Thu, 06 Oct 2011 15:09:16 +1030
> 
>  I recently installed libreoffice-3.4.3_1 to replace openoffice and the
>  OP problem still occurs for me. That is, libreoffice Calc will crash by
>  attempting to use "Format Cells..." whether by right-click/context menu,
>  via "Format->Cells..." menu, or shortcut key "Ctrl+1".
>  
>  # make showconfig
>  ===> The following configuration options are available for
>  libreoffice-3.4.3_1:
>       WEBDAV=off "Support webdav protocol"
>       KDE4=off "With Qt4/KDE4 vclplug support"
>       GTK=on "With GTK vclplug support"
>       GNOME=on "Better integration in gnome environnement"
>       JAVA=off "Add Java support (XML Filters, macros)"
>       PYUNO=off "Allow to script libreoffice in python"
>       SYSTRAY=off "Enable systemtry quickstarter"
>       MMEDIA=off "Enable multimedia backend for impress"
>       SDK=off "Build with SDK"
>       DEBUG=off "Build with debug symbols and verbose output"
>  ===> Use 'make config' to modify these settings
>  # uname -rms
>  FreeBSD 8.2-RELEASE i386
>  
>  


Yes apparently the problem is back in recent build, but I haven't yes figure out
why.