Bug 160399 - Man page for re(4) missing jumbo frames info
Summary: Man page for re(4) missing jumbo frames info
Status: Open
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-02 16:30 UTC by amvandemore
Modified: 2018-04-11 20:28 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description amvandemore 2011-09-02 16:30:14 UTC
share/man/man4/re.4 doesn't accurately reflect all the realtek nics which work with jumbo frames.

For example, my nic is:

re0@pci0:3:0:0: class=0x020000 card=0x75811462 chip=0x816810ec rev=0x03 hdr=0x00
    vendor     = 'Realtek Semiconductor'
    device     = 'Gigabit Ethernet NIC(NDIS 6.0) (RTL8168/8111/8111c)'
    class      = network
    subclass   = ethernet

Which works perfectly well with these settings:

re0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 6000
        options=3898<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
        ether 00:24:21:e3:e7:50
        inet 192.168.25.10 netmask 0xffffff00 broadcast 192.168.25.255
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active

This wasn't always the case since when I first got this system jumbo frames and FreeBSD didn't work.

http://lists.freebsd.org/pipermail/freebsd-net/2010-June/025506.html

The missing functionality appears to have been added since then.

How-To-Repeat: View the re(4) man page vs what the re driver is capable of.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:58:58 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped