Bug 160936 - Can't install editors/libreoffice
Summary: Can't install editors/libreoffice
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-23 09:20 UTC by Pavel Timofeev
Modified: 2011-11-04 17:58 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Timofeev 2011-09-23 09:20:12 UTC
[root@timbsd /usr/ports/editors/libreoffice]# date
Fri Sep 23 12:17:28 MSD 2011

[root@timbsd /usr/ports/editors/libreoffice]# portsnap fetch update
..
No updates needed.
Ports tree is already up to date.

[root@timbsd /usr/ports/editors/libreoffice]# make showconfig
===> The following configuration options are available for libreoffice-3.4.3_1:
     WEBDAV=on "Support webdav protocol"
     KDE4=off "With Qt4/KDE4 vclplug support"
     GTK=on "With GTK vclplug support"
     GNOME=off "Better integration in gnome environnement"
     JAVA=on "Add Java support (XML Filters, macros)"
     PYUNO=on "Allow to script libreoffice in python"
     SYSTRAY=off "Enable systemtry quickstarter"
     MMEDIA=on "Enable multimedia backend for impress"
     SDK=off "Build with SDK"
     DEBUG=off "Build with debug symbols and verbose output"
===> Use 'make config' to modify these settings


[root@timbsd ~]# portmaster /usr/ports/editors/libreoffice
..
----------------------------------------------------------
- start unit test #1 on library ../../../unxfbsd.pro/lib/libosl_Security.so
----------------------------------------------------------
: &&     LD_LIBRARY_PATH=/usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.3.2/clone/ure/sal/unxfbsd.pro/lib:/usr/ports                                              /editors/libreoffice/work/libreoffice-bootstrap-3.4.3.2/solver/340/unxfbsd.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}   ../../.                                              ./unxfbsd.pro/bin/cppunittester ../../../unxfbsd.pro/lib/libosl_Security.so
#Initializing ...
#
#logonUser function need root/Administrator account to test.
#You can test by login with root/Administrator, and excute:
#testshl2 -forward "username password" ../../../wntmsci9/bin/Security.dll
#      where username and password are forwarded account info.
#if no text forwarded, this function will be skipped.
#
#Retrived system information is below:
Computer Name:              Not retrived
Current User Name:          root
Current User Home Directory:file:///root
Current Config Directory:   file:///root
Current UserID:             0
Current User is:            Administrator.
#
#Initialization Done.
osl_Security.cxx:216:Assertion
Test name: osl_Security::getHomeDir::getHomeDir_001
assertion failed
- Expression: ( sal_True == strHomeDirectory.equals( strHome ) ) && ( sal_True
== bRes )
- #test comment#: getHomeDir and compare it with the info we get at the beginni
ng.

Failures !!!
Run: 10   Failure total: 1   Failures: 1   Errors: 0
dmake:  Error code 1, while making 'test1'

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.3.2/sal/qa/osl/security

 it seems that the error is inside 'sal', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

rm -Rf /usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.3.2/sal/unxfbsd.pro # optional module 'clean'
/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.3.2
source ./FreeBSDX86Env.Set.sh
cd sal
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake: *** [all] Error 1
*** Error code 1

Stop in /usr/ports/editors/libreoffice.
*** Error code 1

Stop in /usr/ports/editors/libreoffice.

===>>> make failed for editors/libreoffice
===>>> Aborting update


===>>> You can restart from the point of failure with this command line:
       portmaster <flags> editors/libreoffice
Comment 1 Edwin Groothuis freebsd_committer 2011-09-23 09:20:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 baptiste.daroussin 2011-10-01 07:35:07 UTC
Do not build the package in sudo nor su
please use su -

For some weird reasons libreoffice does test if the home directory of
the user building it and the $HOME environment variable
which means that it would fail in case of sudo or su.

regards,
Bapt
Comment 3 Pavel Timofeev 2011-10-02 06:44:36 UTC
Thank you. It helped

2011/10/1 Baptiste Daroussin <baptiste.daroussin@gmail.com>

> Do not build the package in sudo nor su
> please use su -
>
> For some weird reasons libreoffice does test if the home directory of
> the user building it and the $HOME environment variable
> which means that it would fail in case of sudo or su.
>
> regards,
> Bapt
>
Comment 4 Baptiste Daroussin freebsd_committer 2011-11-04 17:58:50 UTC
State Changed
From-To: open->closed

Apprently it is fixed