Bug 161539 - New port: audio/gmusicbrowser - Jukebox for large amount of music files
Summary: New port: audio/gmusicbrowser - Jukebox for large amount of music files
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Eitan Adler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-13 10:30 UTC by lichray
Modified: 2011-12-25 20:03 UTC (History)
0 users

See Also:


Attachments
gmusicbrowser.shar (3.84 KB, text/plain)
2011-10-13 10:30 UTC, lichray
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lichray 2011-10-13 10:30:15 UTC
	
	gmusicbrowser is an open-source jukebox for large collections of mp3/ogg/flac/mpc/ape files, written in perl.
	http://gmusicbrowser.org/

	Among the optional dependences,
	1. mpg123/ogg123 need to work with alsa; a patch which uses OSS is desired.
	2. Gtk2-TrayIcon is deprecated and unneeded.
	3. Gtk2-Notify is not available on FreeBSD yet. I may try to port it someday.

	Note that you may find that the "file" dialog hangs the software. This is caused by p5-Gtk2, which should require the Perl be built with threads.

Fix: No build is required and the distributed Makefile is not used. I install everything accordingly with the INSTALL_* macros.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2011-12-25 18:28:39 UTC
Responsible Changed
From-To: freebsd-ports-bugs->eadler

I'll take it.
Comment 2 dfilter service freebsd_committer 2011-12-25 19:50:43 UTC
eadler      2011-12-25 19:50:34 UTC

  FreeBSD ports repository

  Modified files:
    audio                Makefile 
  Added files:
    audio/gmusicbrowser  Makefile distinfo pkg-descr pkg-plist 
  Log:
  Jukebox for large collections of mp3/ogg/flac/mpc files
  Uses gstreamer, mpg123/ogg123  or mplayer for playback
  
  Main features :
  - customizable window layouts
  - artist/album lock : easily restrict playlist to current artist/album
  - easy access to related songs (same artist/album/title)
  - simple mass-tagging and mass-renaming
  - support multiple genres for each song
  - customizable labels can be set for each song
  - filters with unlimited nesting of conditions
  - customizable weighted random mode
  
  WWW:    http://gmusicbrowser.org/
  
  PR:             ports/161539
  Submitted by:   Zhihao Yuan <lichray@gmail.com>
  
  Revision  Changes    Path
  1.1201    +1 -0      ports/audio/Makefile
  1.1       +74 -0     ports/audio/gmusicbrowser/Makefile (new)
  1.1       +2 -0      ports/audio/gmusicbrowser/distinfo (new)
  1.1       +14 -0     ports/audio/gmusicbrowser/pkg-descr (new)
  1.1       +3 -0      ports/audio/gmusicbrowser/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2011-12-25 20:03:42 UTC
State Changed
From-To: open->closed

Committed. Thanks!