Bug 161779 - Invalid rc.d file generated by the PostgreSQL 9.0 port
Invalid rc.d file generated by the PostgreSQL 9.0 port
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD ports mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-18 19:10 UTC by blackmore
Modified: 2011-10-19 19:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description blackmore 2011-10-18 19:10:15 UTC
The following port databases/postgresql90-server generates invalid rc.d file (/usr/local/etc/rc.d/postgresql)

containing the following line(35): postgresql_user=${postgresql_user:-"%%PG_USER%%"}


The following error occurs when trying to start the server:
 
[root@hostname.org ~]# /usr/local/etc/rc.d/postgresql start
su: unknown login: %%PG_USER%%

Fix: 

postgresql_user=${postgresql_user:-"pgsql"}
How-To-Repeat: Install / upgrade the port
Comment 1 Chris Rees freebsd_committer 2011-10-19 18:41:24 UTC
State Changed
From-To: open->closed

Duplicate of ports/161771
Comment 2 dfilter freebsd_committer 2011-10-19 19:21:39 UTC
crees       2011-10-19 18:21:25 UTC

  FreeBSD ports repository

  Modified files:
    databases/postgresql82-server Makefile 
    databases/postgresql83-server Makefile 
    databases/postgresql84-server Makefile 
    databases/postgresql90-server Makefile 
    databases/postgresql91-server Makefile 
  Log:
  Fix SUB_LIST issue by deconditionalising it.
  
  Temporary fix, but will stop the flurry of incoming PRs related.
  
  PR:             ports/161779 ports/161774 ports/161791 ports/161771 ports/161769
  Submitted by:   Many people, original fix suggested by Jason Helfman (jhelfman@e-e.com)
  Approved by:    portmgr (pav)
  
  Revision  Changes    Path
  1.202     +4 -3      ports/databases/postgresql82-server/Makefile
  1.215     +4 -3      ports/databases/postgresql83-server/Makefile
  1.233     +4 -3      ports/databases/postgresql84-server/Makefile
  1.228     +4 -3      ports/databases/postgresql90-server/Makefile
  1.229     +4 -3      ports/databases/postgresql91-server/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"