Bug 161816 - databases/postgresql82-server: Extra include of bsd.port.pre.mk is breaking build
databases/postgresql82-server: Extra include of bsd.port.pre.mk is breaking b...
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Chris Rees
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-19 18:50 UTC by Keith Gaughan
Modified: 2011-10-20 22:14 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Gaughan 2011-10-19 18:50:08 UTC
Attempting to build either databases/postgresql82-server or its slave databases/postgresql82-client will fail with the following error:

postgresql-client-8.2.22: Makefile error: you cannot include bsd.port[.pre].mk twice

Fix: 

The duplicate include is at line 93 of the port, just before where the options for the server are specified. The one further down at line 113 is ok.

The problem goes away once line 93 is removed.
How-To-Repeat: Attempt to build either the port or its slave.
Comment 1 Edwin Groothuis freebsd_committer 2011-10-19 18:50:21 UTC
Responsible Changed
From-To: freebsd-ports-bugs->girgen

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Keith Gaughan 2011-10-20 11:37:44 UTC
The PR ports/161824 is a duplicate of this issue, with a patch attached, and
suggests the same fix.

-- 
Cíat Ó Gáibhtheacháin - k@stereochro.me - http://stereochro.me/ - CF9F6473
My candle burns at both ends; / It will not last the night. /
But ah my foes and oh my friends, / It gives a lovely light.
    -- Edna St. Vincent Millay
Comment 3 Chris Rees freebsd_committer 2011-10-20 21:52:18 UTC
Responsible Changed
From-To: girgen->crees

I'm dealing with this problem right now.
Comment 4 dfilter freebsd_committer 2011-10-20 22:07:37 UTC
crees       2011-10-20 21:07:29 UTC

  FreeBSD ports repository

  Modified files:
    databases/postgresql82-server Makefile pkg-plist-server 
    databases/postgresql83-server Makefile pkg-plist-server 
    databases/postgresql84-server Makefile pkg-plist-server 
    databases/postgresql90-server Makefile pkg-plist-server 
    databases/postgresql91-server Makefile pkg-plist-server 
  Log:
  - Fix packaging issue (missed %%PG_USER%% in pkg-plist-server)
  - Remove extra bsd.port.pre.mk include from postgresql82-server
  
  PR:             ports/161816 ports/161824 ports/161821
  Submitted by:   Jason Helfman (jhelfman@e-e.com)
  Approved by:    portmgr (pav)
  
  Revision  Changes    Path
  1.204     +1 -2      ports/databases/postgresql82-server/Makefile
  1.22      +1 -0      ports/databases/postgresql82-server/pkg-plist-server
  1.217     +1 -0      ports/databases/postgresql83-server/Makefile
  1.29      +1 -0      ports/databases/postgresql83-server/pkg-plist-server
  1.235     +1 -0      ports/databases/postgresql84-server/Makefile
  1.35      +1 -0      ports/databases/postgresql84-server/pkg-plist-server
  1.230     +1 -0      ports/databases/postgresql90-server/Makefile
  1.35      +1 -0      ports/databases/postgresql90-server/pkg-plist-server
  1.231     +1 -0      ports/databases/postgresql91-server/Makefile
  1.38      +1 -0      ports/databases/postgresql91-server/pkg-plist-server
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Chris Rees freebsd_committer 2011-10-20 22:14:35 UTC
State Changed
From-To: open->closed

Fixed. Thanks!