Bug 162017 - [patch] lang/sbcl: mark BROKEN on freebsd 9/10 (THREADS option)
Summary: [patch] lang/sbcl: mark BROKEN on freebsd 9/10 (THREADS option)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Brendan Fabeny
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-26 02:20 UTC by Nali Toja
Modified: 2011-12-09 13:00 UTC (History)
0 users

See Also:


Attachments
broken.diff (650 bytes, patch)
2011-10-26 02:20 UTC, Nali Toja
no flags Details | Diff
tests.diff (965 bytes, patch)
2011-10-26 02:30 UTC, Nali Toja
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nali Toja 2011-10-26 02:20:07 UTC
sb-thread is going to be broken on the upcoming 9.0-RELEASE. It doesn't
work with more than one thread, e.g. with editors/slime by default

  ;; excerpt from swank-sbcl.lisp
  (defimplementation preferred-communication-style ()
    (cond
      ;; fixme: when SBCL/win32 gains better select() support, remove
      ;; this.
      ((member :sb-thread *features*) :spawn)
      ((member :win32 *features*) nil)
      (t :fd-handler)))

cf. http://docs.freebsd.org/cgi/mid.cgi?86mxd7qdzk.fsf (call for help)
Comment 1 Nali Toja 2011-10-26 02:30:49 UTC
And to make it easier to test re-enable sb-thread tests disabled by ports/154050. 
Comment 2 Brendan Fabeny freebsd_committer 2011-11-19 10:30:29 UTC
Responsible Changed
From-To: freebsd-ports-bugs->bf

I'll take it.
Comment 3 Jan Beich freebsd_committer 2011-11-19 18:28:08 UTC
This seems to be fixed in git master, making BROKEN and all hunks in
files/patch-disable-failing-tests unnecessary for both pre- and post-
r216641 libthr.so.
Comment 4 dfilter service freebsd_committer 2011-11-21 00:42:01 UTC
bf          2011-11-21 00:39:56 UTC

  FreeBSD ports repository

  Modified files:
    lang/sbcl            Makefile 
    lang/sbcl/files      patch-disable-failing-tests 
  Log:
  -fix builds on FreeBSD 9,10 [1]
  -temporarily mark WITH_THREADS as BROKEN on 9,10 [2]
  -fix NOPORTDOCS; add a regression-test alias for the test
   target; delay the patch clean-up to ease debugging; remove
   some lines dealing with unsupported versions of FreeBSD
  
  PR:             161502 [1], 162017 [2]
  Submitted by:   N. Toja [1,2]
  Feature safe:   yes
  
  Revision  Changes    Path
  1.93      +18 -19    ports/lang/sbcl/Makefile
  1.4       +2 -11     ports/lang/sbcl/files/patch-disable-failing-tests
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Brendan Fabeny freebsd_committer 2011-11-21 00:51:55 UTC
State Changed
From-To: open->closed

Committed, with minor changes. Thanks!
Comment 6 dfilter service freebsd_committer 2011-12-09 12:54:53 UTC
bf          2011-12-09 12:54:45 UTC

  FreeBSD ports repository

  Modified files:
    lang/sbcl            Makefile distinfo pkg-plist 
    lang/sbcl/files      customize-target-features.lisp 
    math/fricas          Makefile 
    math/maxima          Makefile pkg-message 
    math/open-axiom      Makefile 
    x11-wm/stumpwm       Makefile 
    x11-wm/cl-stumpwm    Makefile 
  Removed files:
    lang/sbcl/files      patch-contrib_sb-posix_posix-tests.lisp 
  Log:
  update lang/sbcl to 1.0.54, and adjust dependent ports (this allows sbcl to
  be build WITH_THREADS on recent versions of FreeBSD once again) [1]; rename
  *.core files in sbcl and math/maxima so that they are not removed by
  disk-cleaning scripts [2]; make it possible to use the makesum target in sbcl
  WITH_SBCL; fix maxima build WITH_CMUCL, and place a default memory cap of
  1GiB on amd64; reduce default output from a few targets in maxima, and defer
  patch cleaning to the pre-build target to make debugging easier
  
  PR:             162017 [1], 162680 [2]
  Approved by:    pav (portmgr)
  Feature safe:   yes
  
  Revision  Changes    Path
  1.96      +8 -14     ports/lang/sbcl/Makefile
  1.67      +2 -6      ports/lang/sbcl/distinfo
  1.3       +0 -1      ports/lang/sbcl/files/customize-target-features.lisp
  1.3       +0 -20     ports/lang/sbcl/files/patch-contrib_sb-posix_posix-tests.lisp (dead)
  1.48      +3 -1      ports/lang/sbcl/pkg-plist
  1.14      +1 -1      ports/math/fricas/Makefile
  1.73      +25 -13    ports/math/maxima/Makefile
  1.2       +5 -7      ports/math/maxima/pkg-message
  1.10      +1 -0      ports/math/open-axiom/Makefile
  1.13      +1 -1      ports/x11-wm/cl-stumpwm/Makefile
  1.11      +1 -1      ports/x11-wm/stumpwm/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"