Bug 162121 - [patch] remove dependency on gcc 4.6 from audio/audacity-devel
[patch] remove dependency on gcc 4.6 from audio/audacity-devel
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Eitan Adler
Depends on:
  Show dependency treegraph
Reported: 2011-10-28 23:30 UTC by 4720
Modified: 2011-12-04 21:41 UTC (History)
0 users

See Also:

file.diff (442 bytes, patch)
2011-10-28 23:30 UTC, 4720
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description 4720 2011-10-28 23:30:10 UTC
audio/audacity-devel depends on gcc 4.6 or later, but is unnecessary. the USE_GCC line was set to 4.2+ to fix build on freebsd 7. ( http://www.freebsd.org/cgi/query-pr.cgi?pr=116118 ) during later years of port upgrades, it has increased to 4.6+. audacity-devel compiles and runs normally with the gcc 4.2.2.

Fix: attached patch changes USE_GCC=4.6+ back to 4.2+ to eliminate a large and unneeded dependency for systems with gcc 4.2 in base.

Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2011-10-28 23:30:20 UTC
Responsible Changed
From-To: freebsd-ports-bugs->eadler

eadler@ wants his PRs (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2011-10-28 23:30:25 UTC
Maintainer of audio/audacity-devel,

Please note that PR ports/162121 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:

Edwin Groothuis via the GNATS Auto Assign Tool
Comment 3 Edwin Groothuis freebsd_committer 2011-10-28 23:30:28 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 4 dfilter freebsd_committer 2011-12-04 20:46:09 UTC
eadler      2011-12-04 20:46:00 UTC

  FreeBSD ports repository

  Modified files:
    audio/audacity-devel Makefile pkg-plist 
  - Fix the packing list (dirrm to dirrmtry)
  - Audacity no longer requires new gcc to build (added in ports/116118)
  PR:             ports/116118
  PR:             ports/162121
  PR              ports/162119
  Submitted by:   "4720@hushmail.com" <4720@hushmail.com>
  Reviewed by:    olgeni@
  Approved by:    maintainer timeout (6 weeks)
  Feature safe:   yes
  Revision  Changes    Path
  1.56      +0 -1      ports/audio/audacity-devel/Makefile
  1.17      +24 -24    ports/audio/audacity-devel/pkg-plist
cvs-all@freebsd.org mailing list
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Eitan Adler freebsd_committer 2011-12-04 21:41:16 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!