Bug 162556 - Can't install editors/libreoffice. Again
Summary: Can't install editors/libreoffice. Again
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-14 06:30 UTC by timp87
Modified: 2012-01-17 20:59 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description timp87 2011-11-14 06:30:17 UTC
/usr/local/include/boost/unordered/unordered_map.hpp:406:   instantiated from 'T& boost::unordered_map<K, T, H, P, A>::operator[](const K&) [with K = rtl::OUString, T = com::sun::star::uno::Reference<com::sun::star::script::XScriptListener>, H = rtl::OUStringHash, P = std::equal_to<rtl::OUString>, A = std::allocator<std::pair<const rtl::OUString, com::sun::star::uno::Reference<com::sun::star::script::XScriptListener> > >]'
/usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2/clone/libs-core/scripting/source/dlgprov/dlgevtatt.cxx:175:   instantiated from here
/usr/local/include/boost/unordered/detail/table.hpp:478: warning: declaration of 'end' shadows a member of 'this'
/usr/local/include/boost/unordered/detail/table.hpp:441:   instantiated from 'bool boost::unordered_detail::hash_table<T>::reserve_for_insert(size_t) [with T = boost::unordered_detail::map<rtl::OUString, rtl::OUStringHash, std::equal_to<rtl::OUString>, std::allocator<std::pair<const rtl::OUString, com::sun::star::uno::Reference<com::sun::star::script::XScriptListener> > > >]'
/usr/local/include/boost/unordered/detail/unique.hpp:209:   instantiated from 'typename boost::unordered_detail::hash_unique_table<T>::value_type& boost::unordered_detail::hash_unique_table<T>::operator[](const typename T::key_type&) [with T = boost::unordered_detail::map<rtl::OUString, rtl::OUStringHash, std::equal_to<rtl::OUString>, std::allocator<std::pair<const rtl::OUString, com::sun::star::uno::Reference<com::sun::star::script::XScriptListener> > > >]'
/usr/local/include/boost/unordered/unordered_map.hpp:406:   instantiated from 'T& boost::unordered_map<K, T, H, P, A>::operator[](const K&) [with K = rtl::OUString, T = com::sun::star::uno::Reference<com::sun::star::script::XScriptListener>, H = rtl::OUStringHash, P = std::equal_to<rtl::OUString>, A = std::allocator<std::pair<const rtl::OUString, com::sun::star::uno::Reference<com::sun::star::script::XScriptListener> > >]'
/usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2/clone/libs-core/scripting/source/dlgprov/dlgevtatt.cxx:175:   instantiated from here
/usr/local/include/boost/unordered/detail/table.hpp:487: warning: declaration of 'bucket' shadows a member of 'this'
Making:    dlgprov.lib
Making:    dlgprovfb.uno.so
: &&     LD_LIBRARY_PATH=/usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2/solver/340/unxfbsd.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}} xsltproc --nonet --stringparam uri \
        'vnd.sun.star.expand:$OOO_BASE_DIR/program/dlgprovfb.uno.so' -o ../../unxfbsd.pro/misc/dlgprov.component \
        /usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2/solenv/bin/createcomponent.xslt dlgprov.component
Entering /usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2/scripting/util

Compiling: scripting/unxfbsd.pro/misc/scriptframe_version.c
Making:    scriptframe.lib
Making:    libscriptframe.so
: &&     LD_LIBRARY_PATH=/usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2/solver/340/unxfbsd.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}} xsltproc --nonet --stringparam uri \
        'vnd.sun.star.expand:$OOO_BASE_DIR/program/libscriptframe.so' -o ../unxfbsd.pro/misc/scriptframe.component \
        /usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2/solenv/bin/createcomponent.xslt scriptframe.component
Entering /usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2/scripting/util/provider/javascript

Script Provider for JavaScript build disabled.
scripting deliver
deliver -- version: 275594
Module 'scripting' delivered successfully. 33 files copied, 0 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2/unoxml/prj

 it seems that the error is inside 'unoxml', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

rm -Rf /usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2/unoxml/unxfbsd.pro # optional module 'clean'
/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-bootstrap-3.4.4.2
source ./FreeBSDX86Env.Set.sh
cd unoxml
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake: *** [all] Error 1
*** Error code 1
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2011-11-14 19:08:13 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer(s).
Comment 2 timp87 2012-01-17 06:20:48 UTC
Close it please. Problem is gone.
Current ports libreoffice-3.4.5 installs fine.
Comment 3 Baptiste Daroussin freebsd_committer 2012-01-17 20:59:13 UTC
State Changed
From-To: open->closed

Closed has it seems to be fixed, thanks for reporting