Bug 162559 - regression in ospfd after upgrade net/quagga to 0.99.20_2
regression in ospfd after upgrade net/quagga to 0.99.20_2
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Sergey Matveychuk
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-14 11:00 UTC by hizel
Modified: 2013-06-14 15:20 UTC (History)
0 users

See Also:


Attachments
quagga.txt (431 bytes, text/plain)
2011-11-14 11:58 UTC, boris
no flags Details
quagga.txt (1.24 KB, text/plain)
2011-11-14 13:27 UTC, boris
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description hizel 2011-11-14 11:00:22 UTC
after upgrade quagga to 0.99.20_2 in ospf.log:

2011/11/14 14:43:19 OSPF: ospf_recv_packet read length mismatch: ip_len is 64, but recvmsg returned 84                                                                                                                                         
2011/11/14 14:43:27 OSPF: ospf_recv_packet read length mismatch: ip_len is 76, but recvmsg returned 96
2011/11/14 14:43:28 OSPF: ospf_recv_packet read length mismatch: ip_len is 76, but recvmsg returned 96                                                                                                                                         
2011/11/14 14:43:28 OSPF: ospf_recv_packet read length mismatch: ip_len is 64, but recvmsg returned 84
2011/11/14 14:43:29 OSPF: ospf_recv_packet read length mismatch: ip_len is 64, but recvmsg returned 84                                                                                                                                         
2011/11/14 14:43:29 OSPF: ospf_recv_packet read length mismatch: ip_len is 64, but recvmsg returned 84
2011/11/14 14:43:37 OSPF: ospf_recv_packet read length mismatch: ip_len is 76, but recvmsg returned 96                                                                                                                                         
2011/11/14 14:43:38 OSPF: ospf_recv_packet read length mismatch: ip_len is 76, but recvmsg returned 96
2011/11/14 14:43:38 OSPF: ospf_recv_packet read length mismatch: ip_len is 64, but recvmsg returned 84                                                                                                                                         
2011/11/14 14:43:39 OSPF: ospf_recv_packet read length mismatch: ip_len is 64, but recvmsg returned 84
2011/11/14 14:43:39 OSPF: ospf_recv_packet read length mismatch: ip_len is 64, but recvmsg returned 84                                                                                                                                         
2011/11/14 14:43:39 OSPF: ospf_recv_packet read length mismatch: ip_len is 100, but recvmsg returned 120
2011/11/14 14:43:39 OSPF: ospf_recv_packet read length mismatch: ip_len is 100, but recvmsg returned 120

Fix: 

remove net/quagga/files/patch-ospfd__ospf_packet.c solve my problem
How-To-Repeat: upgrade quagga to 0.99.20_2 with options:
Comment 1 Edwin Groothuis freebsd_committer 2011-11-14 11:00:31 UTC
Maintainer of net/quagga,

Please note that PR ports/162559 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/162559

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2011-11-14 11:00:33 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 boris 2011-11-14 11:58:48 UTC
Hello!

     Would You please check this patch?

-- 
Regards,
Boris

Comment 4 hizel 2011-11-14 13:07:44 UTC
On Mon, 14 Nov 2011 15:58:48 +0400, Boris Kovalenko <boris@tagnet.ru>  
wrote:

> Hello!
>
>      Would You please check this patch?
>

Hello!

patch work for me

--- ospfd/ospf_packet.c.orig    2011-09-29 18:59:32.000000000 +0600
+++ ospfd/ospf_packet.c 2011-11-12 12:02:58.000000000 +0600
@@ -2116,7 +2116,7 @@

    ip_len = iph->ip_len;

-#if !defined(GNU_LINUX) && (OpenBSD < 200311)
+#if !defined(GNU_LINUX) && (OpenBSD < 200311) && (__FreeBSD_version <=  
900045)
    /*
     * Kernel network code touches incoming IP header parameters,
     * before protocol specific processing.


thank you!

-- 
e-mail: hizel@vyborg.ru
jid: hizel@vyborg.ru
Comment 5 boris 2011-11-14 13:27:48 UTC
Yes, it's really my regression. Since FreeBSD 9 has iph->len rolled 
back, only FreeBSD 10 should be checked.

-- 
Regards,
Boris

Comment 6 hizel 2011-11-16 08:19:46 UTC
On Mon, 14 Nov 2011 17:27:48 +0400, Boris Kovalenko <boris@tagnet.ru>  
wrote:

> Yes, it's really my regression. Since FreeBSD 9 has iph->len rolled
> back, only FreeBSD 10 should be checked.
>

Please commit this patch!
I also checked in 8.2-RELESE. In quagga-0.99.20_2 ospfd broken,  
quagga-0.99.20_3 works ok

-- 
e-mail: hizel@vyborg.ru
jid: hizel@vyborg.ru
Comment 7 Sergey Matveychuk freebsd_committer 2011-11-17 12:50:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->sem

Take it.
Comment 8 dfilter freebsd_committer 2011-11-17 13:02:21 UTC
sem         2011-11-17 13:02:07 UTC

  FreeBSD ports repository

  Modified files:
    net/quagga           Makefile 
    net/quagga/files     patch-ospfd__ospf_packet.c 
  Log:
  - Fix regression in ospfd after upgrade to 0.99.20_2
  
  PR:             ports/162559
  Submitted by:   Ildar Hizbulin <hizel_at_vyborg.ru>
  Fixed by:       maintainer
  Feature safe:   Yes
  
  Revision  Changes    Path
  1.116     +1 -1      ports/net/quagga/Makefile
  1.2       +1 -1      ports/net/quagga/files/patch-ospfd__ospf_packet.c
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 9 Sergey Matveychuk freebsd_committer 2011-11-17 13:02:40 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!
Comment 10 emz 2013-06-14 15:17:58 UTC
This appeared again on fresh 10.x.
For some reason this compiler condition isn't blocking FreeBSD 10.x from
adding this line, so it should be corrected.

I deleted the whole block and got quagga's OSPF working. Until this I
was getting same error messages as the author of the original pr.