Bug 163020 - [geli] [patch] enable the Camellia-XTS on GEOM ELI
Summary: [geli] [patch] enable the Camellia-XTS on GEOM ELI
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.0-CURRENT
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-geom (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-02 15:50 UTC by Yoshisato Yanagisawa
Modified: 2020-01-28 17:53 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yoshisato Yanagisawa 2011-12-02 15:50:03 UTC
I made a patch to enable Camellia-XTS on GEOM ELI (geli), which based on
AES-XTS.  Since XTS is considered much stronger disk encryption mechanism,
I also would like to provide XTS mode for Camellia in addition to Camellia-CBC.
Will you import this patch to the base if you can?

The patch is available from:
http://www.pcc-software.org/~osho/freebsd/geli-camellia-xts-current.diff
this is consist of followings:
  + software cryptodev for camellia-xts mode,
  + geom eli for camellia-xts mode,
  + regression test for camellia-xts mode,
  + and small geli(9) manual fix.

Also, the regression test result is available from:
http://www.pcc-software.org/~osho/freebsd/geli-camellia-xts-current-test.log
I saw some notes but the test result says success.

Maintainer is cc'd.

Thank you in advance,
Yoshisato.

Fix: 

n/a
How-To-Repeat: 	n/a
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2011-12-03 23:43:30 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-geom

Over to maintainer(s).
Comment 2 Yoshisato Yanagisawa 2012-01-29 03:07:25 UTC
I tried to apply the same patch to the latest FreeBSD current, and
confirm it still works.  I can apply the patch and all the test has passed.
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2012-01-30 07:22:51 UTC
State Changed
From-To: open->analyzed

Submitter notes this patch is still valid for -current.
Comment 4 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:48:14 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 5 Conrad Meyer freebsd_committer 2020-01-28 17:53:24 UTC
Sorry, collecting additional cryptographic algorithms doesn't improve user safety and there's no reason to use Camellia in preference to existing, well-studied AES modes.