Bug 163510 - FreeBSD Port emulators/fceux Patch
Summary: FreeBSD Port emulators/fceux Patch
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Michael Scheidell
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-21 18:40 UTC by A.J. Kehoe IV
Modified: 2012-01-13 14:50 UTC (History)
0 users

See Also:


Attachments
file.diff (747 bytes, patch)
2011-12-21 18:40 UTC, A.J. Kehoe IV
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description A.J. Kehoe IV 2011-12-21 18:40:06 UTC
The maintainer (davide.italiano@gmail.com) asked me to send a PR because he doesn't have time for this at the moment.

I discovered that the FreeBSD port emulators/fceux doesn't reinstall as intended.

-----BEGIN QUOTE-----
# make deinstall
===>  Deinstalling for emulators/fceux
===>   Deinstalling fceux-2.1.4a
# make reinstall
===>  Installing for fceux-2.1.4a
===>   fceux-2.1.4a depends on shared library: SDL-1.2.11 - found
===>   fceux-2.1.4a depends on shared library: lua-5.1.1 - found
===>   Generating temporary packing list
===>  Checking if emulators/fceux already installed
install  -s -o root -g wheel -m 555 /usr/ports/emulators/fceux/work/fceu2.1.4a/src/fceux /usr/local/bin
install  -o root -g wheel -m 444 /usr/ports/emulators/fceux/work/fceu2.1.4a/documentation/fceux.6 /usr/local/man/man6
install: /usr/ports/emulators/fceux/work/fceu2.1.4a/documentation/fceux.6: No such file or directory
*** Error code 71

Stop in /usr/ports/emulators/fceux.
*** Error code 1

Stop in /usr/ports/emulators/fceux.
-----END QUOTE-----

Fix: In the "do-install" part of the Makefile, fceux.6 is deleted from the work directory's "documentation" folder.  Simply removing this "rm" line would break the package list, so I decided to move fceux.6 out of the work directory's "documentation" folder during the "post-extract" phase.

I also noticed that the "post-extract" part of the Makefile doesn't work as intended.  The first line starts with spaces instead of a tab, which isn't accepted.

I've attached a patch for the Makefile.

Patch attached with submission follows:
How-To-Repeat: cd /usr/ports/emulators/fceux
make install
make deinstall
make reinstall
Comment 1 Edwin Groothuis freebsd_committer 2011-12-21 18:40:15 UTC
Maintainer of emulators/fceux,

Please note that PR ports/163510 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/163510

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2011-12-21 18:40:16 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Michael Scheidell freebsd_committer 2012-01-11 13:36:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->scheidell

I'll take it
Comment 4 Michael Scheidell freebsd_committer 2012-01-12 13:38:33 UTC
Maintainer:

port compiles just fine, no leftovers,

<http://lorie.secnap.net/tb/logs/8-scheidell_AMD64/fceux-2.1.4a_1.log>

commit this?
-- 
Michael Scheidell, CTO
o: 561-999-5000
d: 561-948-2259
 >*| *SECNAP Network Security Corporation

    * Best Mobile Solutions Product of 2011
    * Best Intrusion Prevention Product
    * Hot Company Finalist 2011
    * Best Email Security Product
    * Certified SNORT Integrator
Comment 5 Michael Scheidell freebsd_committer 2012-01-13 14:21:01 UTC
State Changed
From-To: closed->feedback

To reopen, correct audit log.
Comment 6 Michael Scheidell freebsd_committer 2012-01-13 14:40:24 UTC
State Changed
From-To: feedback->closed

Committed, thanks
Comment 7 dfilter service freebsd_committer 2012-01-13 14:40:26 UTC
scheidell    2012-01-13 14:40:17 UTC

  FreeBSD ports repository

  Modified files:
    emulators/fceux      Makefile 
  Log:
  - Didn't reinstall documentation/fceux.6 as intended.
  - maintainer asked submitter to submit the patch due to maintainer's schedule
  
  PR:             ports/163510
  Submitted by:   A.J. Kehoe IV (Nanoman)" <ibxht163@nanoman.ca>
  Approved by:    maintainer (timeout, 22 days), gabor (mentor, implicit)
  
  Revision  Changes    Path
  1.41      +4 -3      ports/emulators/fceux/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"