Bug 164127 - www/webalizer WITH_GEODB requires WITH_BDB
Summary: www/webalizer WITH_GEODB requires WITH_BDB
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 17:30 UTC by Adam Weinberger
Modified: 2012-09-16 17:38 UTC (History)
0 users

See Also:


Attachments
webalizer.patch (732 bytes, patch)
2012-01-14 17:30 UTC, Adam Weinberger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Weinberger freebsd_committer 2012-01-14 17:30:13 UTC
www/webalizer with WITH_GEODB will install fine, but it requires bdb support to actually
read the GeoDB.dat file. WITH_GEODB needs to explicitly bring in bdb.

How-To-Repeat: 
WITH_GEODB=yes
[root@apnoea /usr/ports/www/webalizer/work/webalizer-2.23-05]$ ./webalizer
Webalizer V2.23-05 (FreeBSD 8.2-STABLE i386) English
Using logfile /var/log/httpd-access.log (clf)
Error opening file: /usr/local/share/geolizer/GeoDB.dat
GeoDB lookups disabled

WITH_GEODB=yes WITH_BDB=yes
[root@apnoea /usr/ports/www/webalizer/work/webalizer-2.23-05]$ ./webalizer
Webalizer V2.23-05 (FreeBSD 8.2-STABLE i386) English
Using logfile /var/log/httpd-access.log (clf)
Using Webalizer GeoDB 20120101-1
Comment 1 Edwin Groothuis freebsd_committer 2012-01-14 17:30:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->dinoex

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Dirk Meyer freebsd_committer 2012-01-31 05:06:05 UTC
State Changed
From-To: open->feedback


I can not reproduce your problem. 

If build without "WITH_BDB", 
the bdb_186 from libc will be used. 

The error you reported: 
"Error opening file: /usr/local/share/geolizer/GeoDB.dat" 

WHile tells that the database was not installed. 

When you change options, 
please run "make clean" before rebuilding. 

And tell me if you still have a problem.
Comment 3 adamw 2012-01-31 16:31:58 UTC
Heh, no I swear I have run make clean :-P That error does ***NOT*** mean
that the database was not installed, it means that it was unable to open it.

I'm trying this on multiple boxes and I get the same results.

Please try this on a clean system yourself, on 8-STABLE, 9-STABLE (haven't
tested it on -CURRENT). Here are the steps with which I can reproduce the
problem, every single time

# touch /tmp/accesslog

# cd /usr/ports/www/webalizer && make clean && make WITH_GEODB=yes install
clean
# cp /usr/local/etc/webalizer.conf-dist /usr/local/etc/webalizer.conf
# mkdir -p /var/lib/httpd/htdocs

# echo "LogFile   /tmp/accesslog"
# echo "GeoDB   yes" >> /usr/local/etc/webalizer.conf
# echo "GeoDBDatabase   /usr/local/share/geolizer/GeoDB.dat" >>
/usr/local/etc/webalizer.conf

# webalizer
[root@freebsd-vm /usr/ports/www/webalizer]$ webalizer
Webalizer V2.23-05 (FreeBSD 8.2-STABLE i386) English
Using logfile /tmp/accesslog (clf)
Error opening file: /usr/local/share/geolizer/GeoDB.dat
GeoDB lookups disabled
Creating output in current directory
[...]

# cd /usr/ports/www/webalizer && make deinstall && make clean && make
WITH_GEODB=yes WITH_BDB=yes install clean
# webalizer
[root@freebsd-vm /usr/ports/www/webalizer]$ webalizer
Webalizer V2.23-05 (FreeBSD 8.2-STABLE i386) English
Using logfile /tmp/accesslog (clf)
Using Webalizer GeoDB 20120101-1
Creating output in current directory
[...]


I have tried this on multiple 8-STABLE and 9-STABLE boxes. Please try this
yourself.
# Adam
Comment 4 Dirk Meyer freebsd_committer 2012-03-19 17:27:00 UTC
State Changed
From-To: feedback->analyzed

there are different compiled databases. 
The default needs a newer bdb. 
I will think of a solution.
Comment 5 adamw 2012-05-28 23:36:40 UTC
Have you been able to make any movement on this?

WITH_GEODB simply needs to set WITH_BDB=yes.

It's an incredibly easy fix, and GeoDB support is completely broken without
it. Can one of us please commit this change?

# Adam


-- 
Adam Weinberger
adamw@adamw.org
http://www.adamw.org
Comment 6 adamw 2012-06-07 17:00:22 UTC
This ticket has been open for quite some time now, approaching 6 months. I
plan on committing this fix very shortly, probably this evening, unless you
indicate to me that you're opposed to it. We are currently in a feedback
state as you are contemplating other approaches, however the service simply
remains unusuable without it. While you are considering options let's just
buy you as much time as you need, by making the service work properly in
the interim.

Again, the issue is simply that GeoDB requires db to work, so WITH_DB
should be enabled when WITH_GEODB is specified.
Comment 7 dfilter service freebsd_committer 2012-06-08 02:14:04 UTC
adamw       2012-06-08 01:13:51 UTC

  FreeBSD ports repository

  Modified files:
    www/webalizer        Makefile 
  Log:
  The GeoDB is Berkeley DB-based, and requires bdb support at runtime.
  
  PORTREVISION bumped to bring in the extra dependency.
  
  PR:                     ports/164127
  
  Revision  Changes    Path
  1.91      +4 -1      ports/www/webalizer/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 8 dirk.meyer 2012-06-08 07:37:45 UTC
Hallo Adam Weinberger,

>  This ticket has been open for quite some time now, approaching 6 months. I
>  plan on committing this fix very shortly, probably this evening, unless you
>  indicate to me that you're opposed to it. We are currently in a feedback
>  state as you are contemplating other approaches, however the service simply
>  remains unusuable without it. While you are considering options let's just
>  buy you as much time as you need, by making the service work properly in
>  the interim.

The commited patch does not Fix the problem in the PR.

You can verify this with:
make -V CFLAGS WITH_GEODB=1

Please wait for the correct solution.

kind regards Dirk

- Dirk Meyer, Im Grund 4, 34317 Habichtswald, Germany
- [dirk.meyer@dinoex.sub.org],[dirk.meyer@guug.de],[dinoex@FreeBSD.org]
http://people.freebsd.org/~dinoex/errorlogs/
Comment 9 dfilter service freebsd_committer 2012-06-08 09:48:13 UTC
dinoex      2012-06-08 08:47:56 UTC

  FreeBSD ports repository

  Modified files:
    www/webalizer        Makefile 
  Log:
  - revert last commit.
  Code had no effect. If it has effect it would breal all existing dns caches
  PR:             164127
  
  Revision  Changes    Path
  1.92      +1 -4      ports/www/webalizer/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 10 Dirk Meyer freebsd_committer 2012-09-16 17:37:19 UTC
State Changed
From-To: analyzed->closed


Defaults have been changed