Bug 164287 - x11-toolkits/vte based applications failing to recognize pseudo-terminals on 9.x
Summary: x11-toolkits/vte based applications failing to recognize pseudo-terminals on 9.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 18:00 UTC by Douglas Carmichael
Modified: 2012-04-16 07:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Douglas Carmichael 2012-01-18 18:00:25 UTC
To whom it may concern:

When I use terminal applications that utilize the vte widget (x11-toolkits/vte), the pseudo-terminals that they spawn are not recognized by the system. 
For example, when the 'finger' or 'w' commands are used, terminal windows created by said applications do not show in their output.

However, on 8.2, they do.

Fix: 

n/a
How-To-Repeat: Use a terminal application (Xfce terminal, gnome-terminal) that uses vte.
Comment 1 Edwin Groothuis freebsd_committer 2012-01-18 18:00:34 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Michael Johnson freebsd_committer 2012-01-21 05:08:47 UTC
State Changed
From-To: open->feedback

I am unable to reproduce this, can you reply with 'echo $TERM' and just curious, are you using vte built on 8.2?
Comment 3 Douglas Carmichael 2012-01-21 05:57:01 UTC
$TERM is "xterm".. and vte is freshly built on 9.0.
Comment 4 mezz.freebsd 2012-03-16 03:03:12 UTC
I can't reproduce it here too on FreeBSD 9.0-STABLE.

Cheers,
Mezz


-- 
mezz.freebsd@gmail.com - mezz@FreeBSD.org
FreeBSD GNOME Team
http://www.FreeBSD.org/gnome/ - gnome@FreeBSD.org
Comment 5 Douglas Carmichael 2012-03-16 20:05:13 UTC
I tried installing a new FreeBSD 9.0-RELEASE VM, then installing Xorg, =
and then installing Terminal (x11/Terminal), and the problem recurred.

--Douglas

On Mar 15, 2012, at 10:03 PM, Jeremy Messenger wrote:

> I can't reproduce it here too on FreeBSD 9.0-STABLE.
>=20
> Cheers,
> Mezz
>=20
>=20
> --=20
> mezz.freebsd@gmail.com - mezz@FreeBSD.org
> FreeBSD GNOME Team
> http://www.FreeBSD.org/gnome/ - gnome@FreeBSD.org
>=20
Comment 6 mezz.freebsd 2012-03-17 18:23:12 UTC
On Fri, Mar 16, 2012 at 3:05 PM, Douglas Carmichael
<dcarmich@dcarmichael.net> wrote:
> I tried installing a new FreeBSD 9.0-RELEASE VM, then installing Xorg, and then installing Terminal (x11/Terminal), and the problem recurred.

Ah I see, If it works fine with gnome-terminal and other terminals but
not x11/Terminal. Does it means that it's a bug in x11/Terminal or
just vte? Umm... one of us will have to figure it out.

Cheers,
Mezz


> --Douglas
>
> On Mar 15, 2012, at 10:03 PM, Jeremy Messenger wrote:
>
>> I can't reproduce it here too on FreeBSD 9.0-STABLE.
>>
>> Cheers,
>> Mezz


-- 
mezz.freebsd@gmail.com - mezz@FreeBSD.org
FreeBSD GNOME Team
http://www.FreeBSD.org/gnome/ - gnome@FreeBSD.org
Comment 7 Douglas Carmichael 2012-03-17 19:07:14 UTC
Jeremy:

I just tried gnome-terminal (turning on the login shell and log to =
records options), and the bug appeared there, too.

On Mar 17, 2012, at 1:23 PM, Jeremy Messenger wrote:

> On Fri, Mar 16, 2012 at 3:05 PM, Douglas Carmichael
> <dcarmich@dcarmichael.net> wrote:
>> I tried installing a new FreeBSD 9.0-RELEASE VM, then installing =
Xorg, and then installing Terminal (x11/Terminal), and the problem =
recurred.
>=20
> Ah I see, If it works fine with gnome-terminal and other terminals but
> not x11/Terminal. Does it means that it's a bug in x11/Terminal or
> just vte? Umm... one of us will have to figure it out.
>=20
> Cheers,
> Mezz
>=20
>=20
>> --Douglas
>>=20
>> On Mar 15, 2012, at 10:03 PM, Jeremy Messenger wrote:
>>=20
>>> I can't reproduce it here too on FreeBSD 9.0-STABLE.
>>>=20
>>> Cheers,
>>> Mezz
>=20
>=20
> --=20
> mezz.freebsd@gmail.com - mezz@FreeBSD.org
> FreeBSD GNOME Team
> http://www.FreeBSD.org/gnome/ - gnome@FreeBSD.org
>=20
Comment 8 mezz.freebsd 2012-03-25 03:18:07 UTC
On Sat, Mar 17, 2012 at 2:07 PM, Douglas Carmichael
<dcarmich@dcarmichael.net> wrote:
> Jeremy:
>
> I just tried gnome-terminal (turning on the login shell and log to records options), and the bug appeared there, too.

marcus has patch available to fix this. It will be committed after the
unfreeze when 8.3 is released.

Cheers,
Mezz


> On Mar 17, 2012, at 1:23 PM, Jeremy Messenger wrote:
>
>> On Fri, Mar 16, 2012 at 3:05 PM, Douglas Carmichael
>> <dcarmich@dcarmichael.net> wrote:
>>> I tried installing a new FreeBSD 9.0-RELEASE VM, then installing Xorg, and then installing Terminal (x11/Terminal), and the problem recurred.
>>
>> Ah I see, If it works fine with gnome-terminal and other terminals but
>> not x11/Terminal. Does it means that it's a bug in x11/Terminal or
>> just vte? Umm... one of us will have to figure it out.
>>
>> Cheers,
>> Mezz
>>
>>
>>> --Douglas
>>>
>>> On Mar 15, 2012, at 10:03 PM, Jeremy Messenger wrote:
>>>
>>>> I can't reproduce it here too on FreeBSD 9.0-STABLE.
>>>>
>>>> Cheers,
>>>> Mezz
>>
>>
>> --
>> mezz.freebsd@gmail.com - mezz@FreeBSD.org
>> FreeBSD GNOME Team
>> http://www.FreeBSD.org/gnome/ - gnome@FreeBSD.org


-- 
mezz.freebsd@gmail.com - mezz@FreeBSD.org
FreeBSD GNOME Team
http://www.FreeBSD.org/gnome/ - gnome@FreeBSD.org
Comment 9 Douglas Carmichael 2012-03-25 05:41:04 UTC
Jeremy:

Would the patch be available in the MarcusCom repository?

--Douglas

On Mar 24, 2012, at 9:18 PM, Jeremy Messenger wrote:

> On Sat, Mar 17, 2012 at 2:07 PM, Douglas Carmichael
> <dcarmich@dcarmichael.net> wrote:
>> Jeremy:
>>=20
>> I just tried gnome-terminal (turning on the login shell and log to =
records options), and the bug appeared there, too.
>=20
> marcus has patch available to fix this. It will be committed after the
> unfreeze when 8.3 is released.
>=20
> Cheers,
> Mezz
>=20
>=20
>> On Mar 17, 2012, at 1:23 PM, Jeremy Messenger wrote:
>>=20
>>> On Fri, Mar 16, 2012 at 3:05 PM, Douglas Carmichael
>>> <dcarmich@dcarmichael.net> wrote:
>>>> I tried installing a new FreeBSD 9.0-RELEASE VM, then installing =
Xorg, and then installing Terminal (x11/Terminal), and the problem =
recurred.
>>>=20
>>> Ah I see, If it works fine with gnome-terminal and other terminals =
but
>>> not x11/Terminal. Does it means that it's a bug in x11/Terminal or
>>> just vte? Umm... one of us will have to figure it out.
>>>=20
>>> Cheers,
>>> Mezz
>>>=20
>>>=20
>>>> --Douglas
>>>>=20
>>>> On Mar 15, 2012, at 10:03 PM, Jeremy Messenger wrote:
>>>>=20
>>>>> I can't reproduce it here too on FreeBSD 9.0-STABLE.
>>>>>=20
>>>>> Cheers,
>>>>> Mezz
>>>=20
>>>=20
>>> --
>>> mezz.freebsd@gmail.com - mezz@FreeBSD.org
>>> FreeBSD GNOME Team
>>> http://www.FreeBSD.org/gnome/ - gnome@FreeBSD.org
>=20
>=20
> --=20
> mezz.freebsd@gmail.com - mezz@FreeBSD.org
> FreeBSD GNOME Team
> http://www.FreeBSD.org/gnome/ - gnome@FreeBSD.org
>=20
Comment 10 Joe Marcus Clarke freebsd_committer 2012-04-16 07:42:40 UTC
State Changed
From-To: feedback->closed

Fixed.  Thanks for reporting.
Comment 11 dfilter service freebsd_committer 2012-04-16 07:42:44 UTC
marcus      2012-04-16 06:42:35 UTC

  FreeBSD ports repository

  Modified files:
    x11-toolkits/vte     Makefile 
  Added files:
    x11-toolkits/vte/files patch-gnome-pty-helper_config.h.in 
                           patch-gnome-pty-helper_configure 
                           patch-gnome-pty-helper_gnome-utmp.c 
  Log:
  Fix wtmp interaction on 9.X and higher.
  
  PR:             164287
  
  Revision  Changes    Path
  1.101     +1 -1      ports/x11-toolkits/vte/Makefile
  1.1       +12 -0     ports/x11-toolkits/vte/files/patch-gnome-pty-helper_config.h.in (new)
  1.5       +11 -0     ports/x11-toolkits/vte/files/patch-gnome-pty-helper_configure (new)
  1.3       +11 -0     ports/x11-toolkits/vte/files/patch-gnome-pty-helper_gnome-utmp.c (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"