Bug 164370 - [zfs] zfs destroy for snapshot fails on i386 and sparc64
Summary: [zfs] zfs destroy for snapshot fails on i386 and sparc64
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.0-STABLE
Hardware: i386 Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 11:30 UTC by Dmitry Afanasiev
Modified: 2020-10-27 20:13 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Afanasiev 2012-01-22 11:30:12 UTC
zfs destroy without -R options fails for any snapshot on _i386_ systems.
I have no this problem on my amd64 and sparc64 systems with same source code level.

How-To-Repeat: # zpool create tank `mdconfig -a -t swap -s 64m`
# zfs snapshot tank@snap
# zfs destroy -v tank@snap
will destroy tank@snap
will reclaim 0
# echo $?
1
# zfs destroy -rv tank@snap
will destroy tank@snap
will reclaim 0
# echo $?
1
# zfs destroy -Rv tank@snap
will destroy tank@snap
will reclaim 0
# echo $?
0
Comment 1 Dmitry Afanasiev 2012-01-22 13:30:20 UTC
Oops. I'm confused.
Problem exists on sparc64 too.
Only amd64 systems not affected by this issue.
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2012-01-22 18:34:49 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-fs

Over to maintainer(s).
Comment 3 md401 2012-06-12 20:22:13 UTC
I have this problem on my amd64 system, so it's not as simple as
i386/sparc vs amd64.
Comment 4 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:58:48 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 5 Ed Maste freebsd_committer 2019-07-22 13:29:21 UTC
I cannot reproduce this on:
FreeBSD volta 13.0-CURRENT FreeBSD 13.0-CURRENT r348071+1124d0472db5(wipbsd.20190326) GENERIC  amd64

Can someone retest on i386 or sparc64?
Comment 6 Dmitry Afanasiev 2019-07-22 13:56:16 UTC
(In reply to Ed Maste from comment #5)
amd64 was NOT affected by this issue.
sparc64 also was NOT affected.

Only i386 was affected. But I currently have no freebsd/i386 left...
Comment 7 Ed Maste freebsd_committer 2019-07-22 14:08:50 UTC
Comment #1 suggested sparc64 was affected and comment #3 amd64. In any case I've changed the Hardware field on this PR to i386, and hopefully someone with i386 hardware can test.
Comment 8 Ed Maste freebsd_committer 2020-10-27 20:13:12 UTC
We have switched to OpenZFS in FreeBSD, this may be fixed there and submitter has no i386 any longer.