Bug 164742 - games/kdegames4: games are not working properly
Summary: games/kdegames4: games are not working properly
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-03 18:30 UTC by Roelof Wobben
Modified: 2012-03-13 10:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roelof Wobben 2012-02-03 18:30:10 UTC
Every time I start up a kde game I see the window but nothing else.
When starting up for example knetwalk in a terminal I see this output : 

./knetwalk
knetwalk(20299)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
knetwalk(20299)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
X Error: BadAccess (attempt to access private resource denied) 10
  Extension:    139 (MIT-SHM)
  Minor opcode: 1 (X_ShmAttach)
  Resource id:  0x117
X Error: BadShmSeg (invalid shared segment parameter) 145
  Extension:    139 (MIT-SHM)
  Minor opcode: 5 (X_ShmCreatePixmap)
  Resource id:  0x121
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2e0001e
X Error: BadPixmap (invalid Pixmap parameter) 4
  Major opcode: 54 (X_FreePixmap)
  Resource id:  0x2e0001e
X Error: BadShmSeg (invalid shared segment parameter) 145
  Extension:    139 (MIT-SHM)
  Minor opcode: 2 (X_ShmDetach)
  Resource id:  0x2e0001e

Fix: 

I don't have a fix because I did not know what the problem is.
How-To-Repeat: start up for example knetwalk from prompt or by using the kde menu.
Comment 1 Alberto Villa freebsd_committer 2012-02-16 18:42:03 UTC
State Changed
From-To: open->closed

Fix is setting sysctl kern.ipc.shm_allow_removed=1, as posted on the forums. We'll add a note to pkg-message. 


Comment 2 Alberto Villa freebsd_committer 2012-02-16 18:42:03 UTC
Responsible Changed
From-To: freebsd-ports-bugs->kde

Fix is setting sysctl kern.ipc.shm_allow_removed=1, as posted on the forums. We'll add a note to pkg-message.
Comment 3 dfilter service freebsd_committer 2012-03-13 10:03:50 UTC
avilla      2012-03-13 10:03:32 UTC

  FreeBSD ports repository

  Modified files:
    x11-toolkits/qt4-gui Makefile 
  Added files:
    x11-toolkits/qt4-gui/files 
                               patch-src__gui__image__qnativeimage.cpp 
  Log:
  - Fix MIT-SHM problem.
  - Bump PORTREVISION.
  
  Qt raster graphics system engine tries to attach to shared memory
  segments marked for removal, which is forbidden by POSIX (shmctl(2)).
  Backport a fix to invert order of operations.
  The issue was triggered by Marble and KDE-Games, which resulted in
  blank windows.
  
  PR:             164742
  Approved by:    portmgr via miwi
  Obtained from:  Qt Project
  Feature safe:   yes
  
  Revision  Changes    Path
  1.39      +1 -0      ports/x11-toolkits/qt4-gui/Makefile
  1.1       +23 -0     ports/x11-toolkits/qt4-gui/files/patch-src__gui__image__qnativeimage.cpp (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 dfilter service freebsd_committer 2012-03-13 10:11:49 UTC
avilla      2012-03-13 10:11:40 UTC

  FreeBSD ports repository

  Modified files:
    .                    UPDATING 
  Log:
  - Add note on qt4-gui MIT-SHM issue: kern.ipc.shm_allow_removed=1 is
    not needed anymore.
  
  PR:             164742
  Feature safe:   yes
  
  Revision  Changes    Path
  1.1215    +9 -1      ports/UPDATING
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"