Bug 165223 - [exp-run] update ruby 1.8.7 to p358 and update ruby 1.9.0 to p125
[exp-run] update ruby 1.8.7 to p358 and update ruby 1.9.0 to p125
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Steve Wills
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-17 04:10 UTC by steve
Modified: 2012-02-25 15:30 UTC (History)
0 users

See Also:


Attachments
file.diff (5.58 KB, patch)
2012-02-17 04:10 UTC, steve
no flags Details | Diff
ruby_updates.diff (6.21 KB, patch)
2012-02-17 04:11 UTC, Steve Wills
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description steve 2012-02-17 04:10:09 UTC
Attached patch updates ruby 1.8.7 to p358 and ruby 1.9.0 to p125 (both released the same day)

Would like exp-run to ensure nothing too serious breaks. Thanks!

Fix: see patch:
Comment 1 Steve Wills freebsd_committer 2012-02-17 04:11:17 UTC
Sorry, slight issue with that patch, see updated patch attached.

Thanks,
Steve
Comment 2 Steve Wills freebsd_committer 2012-02-17 04:14:26 UTC
Responsible Changed
From-To: freebsd-ports-bugs->portmgr

over to portmgr
Comment 3 pgollucci 2012-02-17 17:02:23 UTC
For 1.9.3 port

 LIB_DEPENDS=   ffi.5:${PORTSDIR}/devel/libffi \
-               yaml-0.2:${PORTSDIR}/textproc/libyaml
+               yaml-0.2:${PORTSDIR}/textproc/libyaml \
+               execinfo.1:${PORTSDIR}/devel/libexecinfo


As well.


-- 
------------------------------------------------------------------------
1024D/DB9B8C1C B90B FBC3 A3A1 C71A 8E70  3F8C 75B8 8FFB DB9B 8C1C
Philip M. Gollucci (pgollucci@p6m7g8.com) c: 703.336.9354
Member,                           Apache Software Foundation
Committer,                        FreeBSD Foundation
Consultant,                       P6M7G8 Inc.
Director Operations,              Ridecharge Inc.

Work like you don't need the money,
love like you'll never get hurt,
and dance like nobody's watching.
Comment 4 Steve Wills freebsd_committer 2012-02-17 17:08:57 UTC
Sorry, I think that's in there. Am I missing something? Or did you mean
the 1.8.7 port?

Steve
Comment 5 Mark Linimon freebsd_committer 2012-02-20 05:23:18 UTC
State Changed
From-To: open->analyzed
Comment 6 Mark Linimon freebsd_committer 2012-02-20 05:23:18 UTC
Responsible Changed
From-To: portmgr->linimon
Comment 7 gogolok 2012-02-20 16:34:00 UTC
Works so far fine under my development environment (FreeBSD 10.0-CURRENT).
Comment 8 steve 2012-02-24 15:32:03 UTC
Hi,

What's the status of the exp-run?

Thanks,
Steve
Comment 9 linimon 2012-02-24 17:32:43 UTC
On Fri, Feb 24, 2012 at 03:40:12PM +0000, Steve Wills wrote:
>  What's the status of the exp-run?

http://pointyhat-west.isc.freebsd.org/errorlogs/amd64-errorlogs/e.8-exp.20120222052937.pointyhat-west/

I need to -restart it to get the rest of the 'truncated distfiles' out
of there.

The only true regression so far seems to be:

http://pointyhat-west.isc.freebsd.org/errorlogs/amd64-errorlogs/e.8-exp.20120222052937.pointyhat-west/ruby18-lv-0.12.log

mcl
Comment 10 Mark Linimon freebsd_committer 2012-02-25 00:35:56 UTC
Responsible Changed
From-To: linimon->swills

All of the ruby-related truncated_distfiles errors have gone away, so 
ruby18-lv-0.12 seems to be the only regression in this run.  Feel free 
to commit.
Comment 11 dfilter freebsd_committer 2012-02-25 15:25:59 UTC
swills      2012-02-25 15:25:49 UTC

  FreeBSD ports repository

  Modified files:
    Mk                   bsd.ruby.mk 
    lang/ruby18          distinfo 
    lang/ruby19          Makefile distinfo pkg-plist 
    lang/ruby19/files    patch-configure.in patch-cont.c 
  Log:
  - Update lang/ruby18 to p385
  - Update lang/ruby19 to p125
  
  Changes:
  
  http://www.ruby-forum.com/topic/3663807#1047121
  http://www.ruby-lang.org/en/news/2012/02/16/ruby-1-9-3-p125-is-released/
  
  PR:             ports/165223
  Submitted by:   swills (myself)
  Reviewed by:    pgollucci
  Approved by:    portmgr
  
  Revision  Changes    Path
  1.217     +3 -3      ports/Mk/bsd.ruby.mk
  1.76      +2 -2      ports/lang/ruby18/distinfo
  1.17      +2 -1      ports/lang/ruby19/Makefile
  1.12      +2 -2      ports/lang/ruby19/distinfo
  1.3       +11 -11    ports/lang/ruby19/files/patch-configure.in
  1.2       +4 -4      ports/lang/ruby19/files/patch-cont.c
  1.13      +0 -1      ports/lang/ruby19/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 12 Steve Wills freebsd_committer 2012-02-25 15:26:24 UTC
State Changed
From-To: analyzed->closed

Committed.