Bug 165434 - [boot] Install fail Error 19
Summary: [boot] Install fail Error 19
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: i386 (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-i386 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-24 02:10 UTC by Colin Wass
Modified: 2018-06-01 08:45 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Wass 2012-02-24 02:10:10 UTC
I just received the DVD from FreeBSD Mall, and attempted to install.
The boot process fails with a number of USB errors then the final message:

Mounting from cd9660:/dev/iso9660/FREEBSD_I386 failed with error 19

The key elements from the USB errors:

usb_alloc_device: set address 2 failed usb_error_timeout
ugen0.2: unknown @ usbus0
uhub_reattach_port could not allocate new device

The motherboard is ASUS P5N-E SLI
The processor is Intel core 2 quad 2.4 GHZ

I'm not sure if it's relevant, but when the boot process fails, I see
uhub0 and uhub1.  When I boot in safe mode, it starts up fine but only
uhub1 is shown in dmesg.

It's very difficult to capture debug information given the FreeBSD machine
doesn't boot except in safe mode.

How-To-Repeat: Installation on similar motherboard.
Comment 1 Colin Wass 2012-02-25 01:44:27 UTC
I've isolated this problem to APIC.

Therefore, booting with hint.apic.0.disabled=1 allows the system to boot 
successfully.

I'll test a custom kernel with

options SMP_TIMER_NC


and let you know.

Cheers,
Colin
Comment 2 Stanley 2016-05-25 13:58:02 UTC
Same with 10.2 10.3 11.0 and PCBSD 10.3 since it's using BTX CD Loader
PCBSD 10.1, 10.2 was okey, FreeBSD 10.2 and newer not.
Thank's for hint but.. shouldn't it be default!
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:46:34 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 4 Stanley 2018-06-01 08:45:27 UTC
@Eitan Adler
Here is workaround i found somewhere.
It worked 100% all BSD's BTX Loader based: FreeBSD 10.2-3, FreeNAS 10.2, PCBSD 
Used, and posted here:
https://forums.freebsd.org/threads/10-2-v9-both-fail-boot-mount-failed-with-error-code-19.52791/#post-320932

"On the BTX loader menu Select 3: Escape to loader prompt. Write those 2 lines:
set kern.cam.boot_delay="30000"
boot
and hit Enter!"

But somehow can't run FreeBSD 11 neither TrueOS 18 for different reasons, from what i remember installed FreeBSD 11 on VirtualBox but workaround for newer system wasn't working (checked back for older worked), switched DVD controler from IDE to SATA in VBox and this helped for ISO like guy wrote in topic.

This is still an issue.