Bug 166167 - [patch] mail/mailman Port reinstall Patch
Summary: [patch] mail/mailman Port reinstall Patch
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-16 00:50 UTC by A.J. Kehoe IV
Modified: 2012-03-26 14:20 UTC (History)
0 users

See Also:


Attachments
file.diff (496 bytes, patch)
2012-03-16 00:50 UTC, A.J. Kehoe IV
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description A.J. Kehoe IV 2012-03-16 00:50:01 UTC
The FreeBSD port mail/mailman does not reinstall as intended.  During the "post-install" phase, files are moved out of the work directory instead of copied.  This causes "make reinstall" to fail.

Fix: In the "post-install" part of the Makefile, replace "MV" with "CP" and add the "-R" option.

Patch attached with submission follows:
How-To-Repeat: cd /usr/ports/mail/mailman
make install
make deinstall
make reinstall
Comment 1 dfilter service freebsd_committer 2012-03-26 14:10:18 UTC
wxs         2012-03-26 13:10:01 UTC

  FreeBSD ports repository

  Modified files:
    mail/mailman         Makefile 
  Log:
  Fix reinstall target by not moving files. Instead copy them.
  
  PR:             ports/166167
  Submitted by:   "A.J. Kehoe IV (Nanoman)" <hg3hNqHo@nanoman.ca>
  Feature safe:   yes
  
  Revision  Changes    Path
  1.96      +1 -1      ports/mail/mailman/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 2 Wesley Shields freebsd_committer 2012-03-26 14:10:22 UTC
State Changed
From-To: open->closed

Committed. Thanks!