Bug 166230 - games/gemrb: update to 0.7.0
Summary: games/gemrb: update to 0.7.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Alex Kozlov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-18 20:50 UTC by nukama
Modified: 2012-03-19 20:20 UTC (History)
0 users

See Also:


Attachments
patch.txt (167.52 KB, text/plain; charset=us-ascii)
2012-03-19 18:49 UTC, Alex Kozlov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description nukama 2012-03-18 20:50:10 UTC
- update to 0.7.0 from 0.6.2_2
- https://redports.org/export/2677/Nukama/Attic/patches/games-gemrb-0.7.0.patch

V0.7.0 (2011-12-30)
New features

    one can play through the whole Baldur's Gate saga
    custom TTF fonts support
    arbitrarily sortable casting list
    ios configuration interface, xcode project
    more pst spawn ini flags, individual critical hit animations

Improved features

    resting, comment timing, actions
    drop caps, keybindings, sdl 1.3 input
    bugfixes, cleanups

V0.6.6 (2011-10-03)
New features

    aura pollution and cleansing, casting interruption
    formation rotation
    bounty encounters
    npclevel.2da support
    initial mac bundle support
    fatigue
    backstab on condition (like in ToBEx)

Improved features

    effects, triggers, actions
    keyboard shortcuts (F1-F12), touchscreen ui, scrolling
    hitpoint gain, thieving skill boni
    combat, spellcasting, iwd sounds
    PST inventory, PST spells
    bugfixes

Applied patches

manpage typo fixes from c-korn #3377098
pst spell learning fix from Viktor Novotný
touchscreen fix from Beholder

V0.6.5 (2011-07-24)
New features

    quickspell support
    keymap.ini handling
    yet more unhardcoded PST projectiles
    area comments, party npc interactions
    ios port and enhanced touchscreen support

Improved features

    performance
    squirrels and other small game don't die instantly
    stores and stacking
    effects, triggers, actions, dialogs
    secret door detection, turning undead
    bugfixes and internal cleanups

Applied patches

ios support patches from Brad Allred
android and touchscreen patches from Beholder

V0.6.4 (2011-03-27)
New features

    PST maze and (un)hardcoded projectiles
    full wild, dead, miscast and vocal magic support
    subspell selection (spell immunity, nahal's reckless dweomer)
    Autodetect GameType if it is set to 'auto' or commented out
    compatibility with the bg2 demo
    VVC lightspot support

Improved features

    travel regions, projectiles, dialog startup
    bink player has no/less artifacts, good sound quality
    combat, effects, actions, triggers, banters
    bugfixes

Applied patches

a set of patches for Android support from Beholder
arm compilation fixes by ShadowJack
patch from Thomas Klausner fixing building with libpng 1.5
patch by Hana Dusíková to support static linking on mac

V0.6.3 (2010-11-21)
New features

    IWD:HoW is now completable!
    casting sounds and footsteps
    autodetection of secret doors, detect illusions
    basic bardsong support and selective magic resistance (bg2-style)
    proper store economics, ergonomics and dragging
    custom blood color (creature-dependant)
    new actions, iwd effects and triggers
    Importing a SoA game into ToB

Improved features

    actor selection and action bar (for summons and illusions too!)
    door bashing and traps
    loading screens, ambushes, worldmap
    sparkles, panic and other effects
    actions, dialogs, object matching
    personal items support (swap/equip/remove)
    bugfixes

Applied patches

iwd regression fix from Eggert Jón Magnússon
Comment 1 Edwin Groothuis freebsd_committer 2012-03-18 20:50:18 UTC
Maintainer of games/gemrb,

Please note that PR ports/166230 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/166230

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2012-03-18 20:50:20 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Timothy Beyer 2012-03-19 10:36:56 UTC
At Sun, 18 Mar 2012 20:50:18 UT,
Edwin Groothuis wrote:
> 
> Maintainer of games/gemrb,
> 
> Please note that PR ports/166230 has just been submitted.
> 
> If it contains a patch for an upgrade, an enhancement or a bug fix
> you agree on, reply to this email stating that you approve the patch
> and a committer will take care of it.
> 
> The full text of the PR can be found at:
>     http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/166230
> 
> -- 
> Edwin Groothuis via the GNATS Auto Assign Tool
> edwin@FreeBSD.org
> 

I approve of this patch.

Best Regards,
Timothy Beyer
Comment 4 Alex Kozlov freebsd_committer 2012-03-19 11:10:32 UTC
Responsible Changed
From-To: freebsd-ports-bugs->ak

I'll take it.
Comment 5 Alex Kozlov freebsd_committer 2012-03-19 13:47:24 UTC
State Changed
From-To: feedback->open

Maintainer has approved.
Comment 6 Alex Kozlov freebsd_committer 2012-03-19 18:49:09 UTC
Hi

I want to propose next modifications to this update:
- add ttf to USE_SDL 
- s/MANPREFIX/MAN6PREFIX/ in CMAKE_ARGS
- simplification of extra-patch-noportdocs-CMakeLists.txt
  (no functional changes)
- removal of patch-CMakeLists.txt
- no pkg-message rewraping


--
Adios
Comment 7 Alex Kozlov freebsd_committer 2012-03-19 18:52:10 UTC
State Changed
From-To: open->feedback

Ask for maintainer approval.
Comment 8 Timothy Beyer 2012-03-19 19:24:03 UTC
At Mon, 19 Mar 2012 20:49:09 +0200,
Alex Kozlov wrote:
> 
> [1  <text/plain; us-ascii (7bit)>]
> Hi
> 
> I want to propose next modifications to this update:
> - add ttf to USE_SDL 
> - s/MANPREFIX/MAN6PREFIX/ in CMAKE_ARGS
> - simplification of extra-patch-noportdocs-CMakeLists.txt
>   (no functional changes)
> - removal of patch-CMakeLists.txt
> - no pkg-message rewraping
> 
> 
> --
> Adios

Those changes all sound good to me.  Anything that simplifies the maintenance
is great.  I'm not sure if the original versions of GemRB that I ported
included chitin.key, which was the reason for the pkg-message.

Regards,
Tim
Comment 9 Alex Kozlov freebsd_committer 2012-03-19 19:36:25 UTC
On Mon, Mar 19, 2012 at 12:24:03PM -0700, Timothy Beyer wrote:
> At Mon, 19 Mar 2012 20:49:09 +0200,
> Alex Kozlov wrote:
>> I want to propose next modifications to this update:
>> - add ttf to USE_SDL 
>> - s/MANPREFIX/MAN6PREFIX/ in CMAKE_ARGS
>> - simplification of extra-patch-noportdocs-CMakeLists.txt
>>   (no functional changes)
>> - removal of patch-CMakeLists.txt
>> - no pkg-message rewraping
> Those changes all sound good to me.  Anything that simplifies the maintenance
> is great.
Thanks.

> I'm not sure if the original versions of GemRB that I ported included 
> chitin.key, which was the reason for the pkg-message.
chitin.key is a part of game resources, so it's certainly needed.


--
Adios
Comment 10 Alex Kozlov freebsd_committer 2012-03-19 19:55:16 UTC
State Changed
From-To: feedback->open

Maintainer has approved.
Comment 11 dfilter service freebsd_committer 2012-03-19 20:15:18 UTC
ak          2012-03-19 20:14:56 UTC

  FreeBSD ports repository

  Modified files:
    games/gemrb          Makefile distinfo pkg-descr pkg-plist 
    games/gemrb/files    extra-patch-noportdocs-CMakeLists.txt 
                         extra-patch-noportdocs-gemrb-CMakeLists.txt 
  Removed files:
    games/gemrb/files    patch-CMakeLists.txt 
  Log:
  - Update to 0.7.0
  - add NO_INSTALL_MANPAGES
  
  PR:     166230
  Submitted by:   Hakisho Nukama <nukama@gmail.com>
  Approved by:    maintainer, itetcu (mentor)
  Feature safe:   yes
  
  Revision  Changes     Path
  1.17      +11 -10     ports/games/gemrb/Makefile
  1.9       +2 -2       ports/games/gemrb/distinfo
  1.2       +6 -39      ports/games/gemrb/files/extra-patch-noportdocs-CMakeLists.txt
  1.2       +4 -4       ports/games/gemrb/files/extra-patch-noportdocs-gemrb-CMakeLists.txt
  1.2       +0 -21      ports/games/gemrb/files/patch-CMakeLists.txt (dead)
  1.3       +1 -1       ports/games/gemrb/pkg-descr
  1.8       +1202 -882  ports/games/gemrb/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 12 Alex Kozlov freebsd_committer 2012-03-19 20:17:45 UTC
State Changed
From-To: open->closed

Committed, with minor changes. Thanks!