Bug 166744 - [UPDATE] graphics/openjpeg to 1.5.0
Summary: [UPDATE] graphics/openjpeg to 1.5.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-08 01:50 UTC by lichray
Modified: 2012-06-03 13:50 UTC (History)
1 user (show)

See Also:


Attachments
openjpeg-1.5.0.patch (20.95 KB, patch)
2012-04-08 01:50 UTC, lichray
no flags Details | Diff
openjpeg-1.5.0-1.patch (22.41 KB, patch)
2012-04-09 11:33 UTC, lichray
no flags Details | Diff
patch-source_blender_imbuf_intern_jp2.c (400 bytes, text/x-csrc; charset=US-ASCII)
2012-04-09 11:33 UTC, lichray
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lichray 2012-04-08 01:50:10 UTC
	
	openjpeg is upgraded to 1.5.0. This version is based on 1.4.x, which is a bugfix version of the 1.3.x in the ports tree.
	https://code.google.com/p/openjpeg/wiki/WhatsNew?tm=6
	
	The library itself is backward compatible (tested with mupdf, poppler, mtpaint, etc.), but in order to promote the coming openjpeg2, its SO version is decreased from 2 to 1. So we need to bump revision of all of the ports (and change LIB_DEPENDS from openjpeg.2 to openjpeg.1) depends on openjpeg.

	In the patch, I changed the maintainer to myself, since the build system is moved to CMake, and all of the old patches are deprecated. If the original maintainer does not want to pass the maintainership, please change it back before committing.
Comment 1 Edwin Groothuis freebsd_committer 2012-04-08 02:14:32 UTC
Responsible Changed
From-To: freebsd-ports-bugs->dinoex

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Dirk Meyer freebsd_committer 2012-04-09 08:50:21 UTC
State Changed
From-To: open->suspended

this will effect lots of ports.  
This can not be done before the freeze is lifted.
Comment 3 lichray 2012-04-09 11:33:56 UTC
I have tested all of the ports depend on openjpeg. Here is the step to
make changes to them:

0. Apply the updated patch openjpeg-1.5.0-1.patch;
1. For gdcm, mtpaint, poppler, gmerlin-avdecoder, opencinematools,
ffmpeg, ffmpeg-devel, change 'openjpeg.2' to 'openjpeg.1' in Makefile
and bump port revision;
2. For mplayer, do the same thing in Makefile.options;
3. For blender, do the same thing and add the
patch-source_blender_imbuf_intern_jp2.c to files/;
4. For mupdf, do the same thing OR commit ports/166745;
5. For xpaint, do nothing or just bump port revision.

-- 
Zhihao Yuan, nickname lichray
The best way to predict the future is to invent it.
___________________________________________________
4BSD -- http://4bsd.biz/
Comment 4 lichray 2012-04-19 20:07:59 UTC
8.3 is released, and I've submitted the solutions. How about take a
look at this? Thanks.

-- 
Zhihao Yuan, nickname lichray
The best way to predict the future is to invent it.
___________________________________________________
4BSD -- http://4bsd.biz/
Comment 5 lichray 2012-05-15 01:04:30 UTC
Hi, dinoex@:

It's already one month after 8.3 being relased. If you still takes no
action on this PR, I'm going to let portmgr to handle this. Thanks.

-- 
Zhihao Yuan, nickname lichray
The best way to predict the future is to invent it.
___________________________________________________
4BSD -- http://4bsd.biz/
Comment 6 dirk.meyer 2012-05-15 18:14:04 UTC
I wrote you:

> Zhihao Yuan schrieb:,
> 
> >  8.3 is released, and I've submitted the solutions. How about take a
> >  look at this? Thanks.
> 
> 1)
> Someone has to create a patch with the version bump and changes for all 126 ports
> unsing openjpeg.
> 
> 2)
> This patch hast to be tested.
> 
> 3)
> Then the update can be commited.
> 
> 
> 4)
> Problem: You reduced the shlib version.
> The Linker will always link to the higher shlib version.
> So any applaication will link against the old version if installed.
> 
> Please update your patch to avoid this problem, or wait.
> 
> kind regards Dirk
> 
> - Dirk Meyer, Im Grund 4, 34317 Habichtswald, Germany
> - [dirk.meyer@dinoex.sub.org],[dirk.meyer@guug.de],[dinoex@FreeBSD.org]
> http://people.freebsd.org/~dinoex/errorlogs/

Please update your patch to avoid this problem, or wait.
Comment 7 lichray 2012-05-17 09:54:01 UTC
> 1)
> Someone has to create a patch with the version bump and changes for all 126 ports
> unsing openjpeg.

There are only 11 ports ACTUALLY compile against openjpeg. All of the
others depends on ffmpeg{-devel}, and poppler.

>
> 2)
> This patch hast to be tested.

Tested. I have listed how to make the changes instead of creating a big patch.

>
> 3)
> Then the update can be commited.
>
>
> 4)
> Problem: You reduced the shlib version.
> The Linker will always link to the higher shlib version.
> So any applaication will link against the old version if installed.

It's not a problem. Upgrade ffmpeg{-devel}, and poppler so that other
ports will link to the lower version.

-- 
Zhihao Yuan, nickname lichray
The best way to predict the future is to invent it.
___________________________________________________
4BSD -- http://4bsd.biz/
Comment 8 Dirk Meyer freebsd_committer 2012-05-25 05:39:10 UTC
State Changed
From-To: suspended->feedback



> > 1) 
> > Someone has to create a patch with the version bump and changes for all 126 ports 
> > unsing openjpeg. 
> There are only 11 ports ACTUALLY compile against openjpeg. All of the 
>  others depends on ffmpeg{-devel}, and poppler. 

But all 126 packages need a PORTREVISION bump if the sharead lib version changes. 

> > 2) 
> > This patch hast to be tested. 
> Tested. I have listed how to make the changes instead of creating a big patch. 

Thanks, dis you build all 126 ports s using it? 

> > 4) 
> > Problem: You reduced the shlib version. 
> > The Linker will always link to the higher shlib version. 
> > So any applaication will link against the old version if installed. 
> It's not a problem. Upgrade ffmpeg{-devel}, and poppler so that other 
> ports will link to the lower version.   

Please test again,, there is no know optiontion to force ld 
to link to a lover version of  a shared lib, 
when a higher version is still present. 

Please verify your applications with "ldd" 

This Problem ist a showstopper for yoru patch, sorry.
Comment 9 lichray 2012-06-02 06:39:36 UTC
> But all 126 packages need a PORTREVISION bump if the sharead lib version changes.

Let me make this more clear... unless a port explicitly links to a
lib, there is no need to rebuild the port; ld-elf.so is not stupid.

For example:

wesnoth -> SDL -> png, so only SDL needs to be build, wesnoth continues to work.
I know you updated png today, and I played with many ports without
rebuilding them.

> Please test again,, there is no know optiontion to force ld

ld only do the link-time work, and ld-elf.so really decide which lib to use.

> to link to a lover version of a shared lib,
> when a higher version is still present.

After openjpeg being upgraded, these is only one openjpeg shlib
presents, so it'll be OK.

Anyway, you can go ahead and bump 100+ ports' revision if you want. I
can wait, along with my suspended mupdf-1.0 PR.

-- 
Zhihao Yuan, nickname lichray
The best way to predict the future is to invent it.
___________________________________________________
4BSD -- http://4bsd.biz/
Comment 10 dfilter service freebsd_committer 2012-06-03 13:43:17 UTC
dinoex      2012-06-03 12:43:04 UTC

  FreeBSD ports repository

  Modified files:
    graphics/openjpeg    Makefile distinfo pkg-descr 
    graphics/openjpeg/files patch-opj_malloc.h 
  Added files:
    graphics/openjpeg    pkg-plist 
    graphics/openjpeg/files patch-CMakeLists.txt 
                            patch-libopenjpeg-CMakeLists.txt 
  Removed files:
    graphics/openjpeg/files patch-Makefile patch-jpwl-Makefile 
                            patch-jpwl.c patch-jpwl.h 
                            patch-jpwl_lib.c patch-mj2_Makefile 
  Log:
  - update to 1.5.0
  - new MASTER_SITE
  PR:             166744
  Suggested by:   Zhihao Yuan
  
  Revision  Changes    Path
  1.20      +10 -35    ports/graphics/openjpeg/Makefile
  1.6       +2 -2      ports/graphics/openjpeg/distinfo
  1.1       +38 -0     ports/graphics/openjpeg/files/patch-CMakeLists.txt (new)
  1.8       +0 -38     ports/graphics/openjpeg/files/patch-Makefile (dead)
  1.2       +0 -35     ports/graphics/openjpeg/files/patch-jpwl-Makefile (dead)
  1.2       +0 -149    ports/graphics/openjpeg/files/patch-jpwl.c (dead)
  1.2       +0 -11     ports/graphics/openjpeg/files/patch-jpwl.h (dead)
  1.2       +0 -29     ports/graphics/openjpeg/files/patch-jpwl_lib.c (dead)
  1.1       +11 -0     ports/graphics/openjpeg/files/patch-libopenjpeg-CMakeLists.txt (new)
  1.2       +0 -28     ports/graphics/openjpeg/files/patch-mj2_Makefile (dead)
  1.2       +12 -18    ports/graphics/openjpeg/files/patch-opj_malloc.h
  1.3       +1 -1      ports/graphics/openjpeg/pkg-descr
  1.1       +16 -0     ports/graphics/openjpeg/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 11 Dirk Meyer freebsd_committer 2012-06-03 13:48:30 UTC
State Changed
From-To: feedback->closed


update committed in different way, thanks. 

Sorry but the way you suggested wil break installations.