Bug 166894 - [rl] Realtek RTL8100 keeps droping link
Summary: [rl] Realtek RTL8100 keeps droping link
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-12 22:50 UTC by Dean Catcher
Modified: 2017-12-31 22:32 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Catcher 2012-04-12 22:50:11 UTC
See this thread: http://forums.freebsd.org/showthread.php?t=31167

On GENERIC kernel, 9.0 i386, the rl0 card 

a) isn't detected for install (boot off CD)

b) after install, it is detected and works, but link keeps bouncing.

Card info:

rl0@pci0:1:6:0: class=0x020000 card=0x7148109f chip=0x813910ec rev=0x10 hdr=0x00
    vendor     = 'Realtek Semiconductor Co., Ltd.'
    device     = 'RTL-8139/8139C/8139C+'
    class      = network
    subclass   = ethernet
    cap 01[50] = powerspec 2  supports D0 D1 D2 D3  current D0


in messages (when sending data though nic):

rl0: link state changed to DOWN
rl0: link state changed to UP
rl0: link state changed to DOWN
rl0: link state changed to UP
rl0: link state changed to DOWN
rl0: link state changed to UP
rl0: link state changed to DOWN
rl0: link state changed to UP

Fix: 

unknown.  Temporarily using different nic.
How-To-Repeat: Install 9.0 and send data over the rl0 link.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2012-04-16 04:59:18 UTC
Responsible Changed
From-To: freebsd-i386->freebsd-net

Over to maintainer(s).
Comment 2 Pyun YongHyeon freebsd_committer 2012-04-23 02:34:58 UTC
State Changed
From-To: open->feedback

Try set the following loader tunable in /boot/loader.conf and let 
me know whether that change makes any difference. 

dev.rl.0.twister_enable="1" 



Comment 3 Pyun YongHyeon freebsd_committer 2012-04-23 02:34:58 UTC
Responsible Changed
From-To: freebsd-net->yongari

Grab.
Comment 4 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:59 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped