Bug 166996 - java/openjdk6 should depend on archivers/unzip
java/openjdk6 should depend on archivers/unzip
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD Java mailing list
Depends on:
  Show dependency treegraph
Reported: 2012-04-16 16:30 UTC by bas
Modified: 2012-05-30 23:00 UTC (History)
0 users

See Also:

smime.p7s (4.69 KB, application/pkcs7-signature)
2012-04-29 20:27 UTC, geoff
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bas 2012-04-16 16:30:11 UTC
java/openjdk6 should have archivers/unzip as a build dependency. It doesn't compile properly without it due to /usr/local/bin/unzip not being there.


Install archivers/unzip.
How-To-Repeat: Run make inside java/openjdk6 without archivers/unzip previously installed.
Comment 1 Edwin Groothuis freebsd_committer 2012-04-16 17:35:32 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-java

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 jgh@FreeBSD.org freebsd_committer 2012-04-19 16:12:54 UTC
Responsible Changed
From-To: freebsd-java->jgh

I'll take it.
Comment 3 geoff 2012-04-29 20:27:19 UTC
I've been experiencing this issue today. The Makefile does have unzip listed as a build dependency, but 9.0 has /usr/bin/unzip which I believe is satisfying the build dependency.

Unfortunately openjdk6 seems to have a hardcoded path to unzip at /usr/local/bin/unzip.

So it looks like the hardcoded path needs to be patched out, possibly only on 9.x+ or the build dependency could be changed to ${LOCALBASE}/bin/unzip maybe? I'm not sure of the latter option though.

Comment 4 jgh@FreeBSD.org freebsd_committer 2012-05-24 22:37:47 UTC
Responsible Changed
From-To: jgh->freebsd-java

based on severity of this, and my time, putting this back to 
Comment 5 dfilter freebsd_committer 2012-05-27 04:51:28 UTC
glewis      2012-05-27 03:51:15 UTC

  FreeBSD ports repository

  Modified files:
    java/openjdk6        Makefile 
  . Specifically reference zip/unzip in ${LOCALBASE}/bin, since that is where
    the JDK build looks for them, but FreeBSD 9.x has them available in /usr/bin.
    Adjusting the JDK check is a harder fix, this will get things building
    again on 9.x quickly.
  PR:             166996
  Revision  Changes    Path
  1.64      +2 -2      ports/java/openjdk6/Makefile
cvs-all@freebsd.org mailing list
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 Greg Lewis freebsd_committer 2012-05-27 04:53:02 UTC
State Changed
From-To: open->closed

I've committed a change I think should fix this.  I don't have a 9.x system 
to check on though.  Please let me know if the problem persists.
Comment 7 jgh@FreeBSD.org freebsd_committer 2012-05-30 22:52:17 UTC
I've confirmed that this issue is now fixed by building on a clean system.

Jason Helfman
FreeBSD Committer | http://people.freebsd.org/~jgh | The Power To Serve