Bug 167140 - [exp-run] Update CMake to 2.8.8
Summary: [exp-run] Update CMake to 2.8.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-21 03:00 UTC by Raphael Kubo da Costa
Modified: 2012-05-03 03:20 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Kubo da Costa freebsd_committer 2012-04-21 03:00:17 UTC
	We (kde@) would like an exp-run in order to update devel/cmake and devel/cmake-gui to 2.8.8.
	The patch can be found in http://people.freebsd.org/~rakuco/cmake-2.8.8.diff
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2012-04-21 03:17:16 UTC
Responsible Changed
From-To: freebsd-ports-bugs->portmgr

portmgr territory.
Comment 2 Pav Lucistnik freebsd_committer 2012-04-24 09:36:11 UTC
Responsible Changed
From-To: portmgr->pav

Take for exp-run
Comment 3 Raphael Kubo da Costa freebsd_committer 2012-04-26 01:04:06 UTC
So it looks like the first exp-run has triggered a few build problems
for some ports.

I have uploaded http://people.freebsd.org/~rakuco/cmake-2.8.8_v2.diff to
hopefully address these issues. Please have another run with it.
Comment 4 Pav Lucistnik freebsd_committer 2012-04-30 22:21:32 UTC
Responsible Changed
From-To: pav->rakuco

Results forwarded in private mail (1 error)
Comment 5 Raphael Kubo da Costa freebsd_committer 2012-05-01 02:07:30 UTC
pav@FreeBSD.org writes:

> Results forwarded in private mail (1 error)

I've contacted upstream [1] to know whether this is a CMake regression
or if the port should be fixed instead.

Waiting for a response before proceeding.

[1] http://public.kitware.com/pipermail/cmake-developers/2012-April/003939.html
Comment 6 Raphael Kubo da Costa freebsd_committer 2012-05-01 15:20:34 UTC
Raphael Kubo da Costa <rakuco@FreeBSD.org> writes:

> Waiting for a response before proceeding.
>
> [1] http://public.kitware.com/pipermail/cmake-developers/2012-April/003939.html

OK, so the port is to blame. ports/167488 filed.
Comment 7 Raphael Kubo da Costa freebsd_committer 2012-05-02 21:06:11 UTC
Raphael Kubo da Costa <rakuco@FreeBSD.org> writes:

>  OK, so the port is to blame. ports/167488 filed.

Port fixed. Since this was the only failure with the last exp-run, I'll
proceed with updating CMake soon.
Comment 8 dfilter service freebsd_committer 2012-05-03 03:15:18 UTC
rakuco      2012-05-03 02:14:57 UTC

  FreeBSD ports repository

  Modified files:
    devel/cmake          Makefile distinfo pkg-plist 
    devel/cmake/files    patch-Modules_FindQt4.cmake 
                         patch-Modules_FindSDL.cmake 
    devel/cmake-gui      Makefile distinfo 
  Added files:
    devel/cmake/files    
                         patch-git_3ea850a5023060b84dcc0e6f0098c32c28b15807 
  Log:
  Update to 2.8.8.
  
  It includes an upstream patch which fixes the FindPkgConfig.cmake
  module. It will be part of 2.8.9.
  
  PR:             ports/167140
  Approved by:    portmgr (pav via exp-run)
  
  Revision  Changes    Path
  1.12      +1 -1      ports/devel/cmake-gui/Makefile
  1.9       +2 -2      ports/devel/cmake-gui/distinfo
  1.53      +2 -3      ports/devel/cmake/Makefile
  1.31      +2 -2      ports/devel/cmake/distinfo
  1.7       +21 -4     ports/devel/cmake/files/patch-Modules_FindQt4.cmake
  1.3       +12 -12    ports/devel/cmake/files/patch-Modules_FindSDL.cmake
  1.1       +56 -0     ports/devel/cmake/files/patch-git_3ea850a5023060b84dcc0e6f0098c32c28b15807 (new)
  1.31      +17 -1     ports/devel/cmake/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 9 Raphael Kubo da Costa freebsd_committer 2012-05-03 03:15:54 UTC
State Changed
From-To: open->closed

Committed. Thanks!