Bug 167309 - editors/libreoffice: Unable to configure printers on LibreOffice 3.5.2.2
Summary: editors/libreoffice: Unable to configure printers on LibreOffice 3.5.2.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-26 04:20 UTC by Bob Melson
Modified: 2014-02-26 17:45 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Melson 2012-04-26 04:20:08 UTC
After building and installing LibreOffice 3.5.2.2, there is, first, no default printer detected on system.  Following instructions on printer "installation" via the spadmin utility, I am confronted with an error screen telling me that no printers may be installed because the file system is marked read-only.  Changing permissions on <install-path>/libreoffice to 775 or 777 does not resolve the problem.

This problem exists on both AMD64 and i386 systems

This problem did not exist in previous versions.

Being unable to print kinda defeats the purpose of having a wordprocessor/office suite on system.

How-To-Repeat: Build and install LibreOffice, attempt to configure printers in non-Cups environment.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2012-04-26 04:25:26 UTC
Responsible Changed
From-To: freebsd-bugs->office

reclassify and assign.
Comment 2 baptiste.daroussin 2012-05-18 23:56:50 UTC
Did you try rebuilding removing the --without-ppds and can you confirm
that it fixes the problem for you?

regards,
Bapt
Comment 3 Bob Melson 2012-05-19 19:56:53 UTC
Bapt,

No luck.  After a series of build failures (modules vcl, tail_build
and others) which I was able to get around by following libreoffice's
instructions for "hand building" those modules, there was finally
a complete failure in tail_build.  Error message was:

Abort trap (core dumped)
File tested,Test Result,Execution Time (ms)
file:///usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/lotuswordpro/qa/cppunit/data/pass/A14.lwp,Signal
11 during cups initialization called, ignoring cups

Error: a unit test failed, please do one of:

export DEBUGCPPUNIT=TRUE            # for exception catching
export GDBCPPUNITTRACE="gdb --args" # for interactive debugging
export VALGRIND=memcheck            # for memory checking
and retry.

Note:  I did NOT do any of the last three tests.

After multiple failures, even if I was able to get past them,
it seems pretty clear that LO isn't going to build or work without
cups or the "--without_ppds" config option.

-- 
Robert G. Melson | Rio Grande MicroSolutions | El Paso, Texas
-----
The greatest tyrannies are always perpetrated
in the name of the noblest causes -- Thomas Paine
Comment 4 dfilter service freebsd_committer 2014-02-26 17:27:58 UTC
Author: jkim
Date: Wed Feb 26 17:27:51 2014
New Revision: 346218
URL: http://svnweb.freebsd.org/changeset/ports/346218
QAT: https://qat.redports.org/buildarchive/r346218/

Log:
  - Unconditionally install generic PPD files. [1]
  - Update configure options and remove defunct ones.
  
  PR:		ports/167309, ports/167441 [1]

Modified:
  head/editors/libreoffice/Makefile

Modified: head/editors/libreoffice/Makefile
==============================================================================
--- head/editors/libreoffice/Makefile	Wed Feb 26 17:24:35 2014	(r346217)
+++ head/editors/libreoffice/Makefile	Wed Feb 26 17:27:51 2014	(r346218)
@@ -2,7 +2,7 @@
 
 .include "${.CURDIR}/Makefile.common"
 
-PORTREVISION=	0
+PORTREVISION=	1
 
 COMMENT=	Full integrated office productivity suite
 
@@ -101,7 +101,6 @@ CONFIGURE_ARGS+=	--disable-dependency-tr
 			--with-os-version=${OSVERSION} \
 			--with-parallelism=${MAKE_JOBS_NUMBER} \
 			--with-solver-and-workdir-root=${WRKDIR} \
-			--with-unix-wrapper="libreoffice" \
 			--with-vendor="FreeBSD ports ${PKGVERSION}"
 
 CONFIGURE_ARGS+=	--disable-epm \
@@ -111,7 +110,6 @@ CONFIGURE_ARGS+=	--disable-epm \
 			--disable-kdeab \
 			--disable-linkoo \
 			--disable-mergelibs \
-			--disable-zenity \
 			--enable-cairo-canvas \
 			--enable-graphite \
 			--enable-python=system \
@@ -156,14 +154,13 @@ CONFIGURE_ARGS+=	--disable-epm \
 			--with-system-orcus \
 			--with-system-poppler \
 			--with-system-redland \
-			--with-system-stdlibs \
 			--with-system-ucpp \
 			--with-system-vigra \
 			--with-system-zlib \
 			--without-afms \
 			--without-fonts \
 			--without-myspell-dicts \
-			--without-system-mozilla
+			--without-system-npapi-headers
 
 OPTIONS_DEFINE=	CUPS DEBUG GNOME GTK2 GTK3 JAVA KDE4 MMEDIA PGSQL SDK \
 		SYSTRAY TEST VERBOSE WEBDAV
@@ -182,7 +179,7 @@ WEBDAV_DESC=	Enable webdav protocol
 
 .if ${PORT_OPTIONS:MCUPS}
 LIB_DEPENDS+=		libcups.so:${PORTSDIR}/print/cups-client
-CONFIGURE_ARGS+=	--enable-cups --without-ppds
+CONFIGURE_ARGS+=	--enable-cups
 .else
 CONFIGURE_ARGS+=	--disable-cups
 .endif
@@ -264,8 +261,8 @@ JAVA_VERSION=	1.6
 BUILD_DEPENDS+=	ant:${PORTSDIR}/devel/apache-ant \
 		${JAVAJARDIR}/junit.jar:${PORTSDIR}/java/junit
 
-CONFIGURE_ARGS+=	--enable-ext-report-builder \
-			--enable-ext-wiki-publisher \
+CONFIGURE_ARGS+=	--enable-ext-wiki-publisher \
+			--enable-report-builder \
 			--enable-scripting-beanshell \
 			--enable-scripting-javascript \
 			--with-ant-home=${LOCALBASE}/share/java/apache-ant/ \
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 5 Jung-uk Kim freebsd_committer 2014-02-26 17:43:57 UTC
State Changed
From-To: open->closed

It should be fixed with r346218.  Thanks!