Bug 167697 - Cannot compiling /usr/ports/editors/libreoffice-es
Summary: Cannot compiling /usr/ports/editors/libreoffice-es
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-07 23:20 UTC by Álvaro
Modified: 2012-05-19 00:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Álvaro 2012-05-07 23:20:08 UTC
Cannot compiling /usr/ports/editors/libreoffice-es port and /usr/ports/editors/libreoffice.

Tried to build with:
gcc version 4.2.1 20070831 patched [FreeBSD]
gcc version 4.6.4 20120420 (prerelease) (FreeBSD Ports Collection) 
FreeBSD clang version 3.0 (branches/release_30 142614) 20111021

All build failed...

"===>  Extracting for es-libreoffice-3.5.2
=> SHA256 Checksum OK for libreoffice/i18n/LibO_3.5.2_Linux_x86_langpack-deb_es.tar.gz.
=> SHA256 Checksum OK for libreoffice/i18n/LibO_3.5.2_Linux_x86_helppack-deb_es.tar.gz.
===>  Patching for es-libreoffice-3.5.2
===>  Configuring for es-libreoffice-3.5.2
===>  Installing for es-libreoffice-3.5.2
===>   es-libreoffice-3.5.2 depends on executable: libreoffice - not found
===>    Verifying install for libreoffice in /usr/ports/editors/libreoffice
===>  License LGPL3 MPL accepted by the user
===>  Found saved configuration for libreoffice-3.5.2_2
===>  Extracting for libreoffice-3.5.2_2
=> SHA256 Checksum OK for libreoffice/libreoffice-core-3.5.2.2.tar.xz.
=> SHA256 Checksum OK for libreoffice/libreoffice-help-3.5.2.2.tar.xz.
=> SHA256 Checksum OK for libreoffice/0ff7d225d087793c8c2c680d77aac3e7-mdds_0.5.3.tar.bz2.
=> SHA256 Checksum OK for libreoffice/f02578f5218f217a9f20e9c30e119c6a-boost_1_44_0.tar.bz2.
=> SHA256 Checksum OK for libreoffice/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip.
=> SHA256 Checksum OK for libreoffice/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip.
=> SHA256 Checksum OK for libreoffice/2a177023f9ea8ec8bd00837605c5df1b-jakarta-tomcat-5.0.30-src.tar.gz.
=> SHA256 Checksum OK for libreoffice/48d8169acc35f97e05d8dcdfd45be7f2-lucene-2.3.2.tar.gz.
=> SHA256 Checksum OK for libreoffice/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip.
=> SHA256 Checksum OK for libreoffice/ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.7-bj.zip.
=> SHA256 Checksum OK for libreoffice/eeb2c7ddf0d302fba4bfc6e97eac9624-libbase-1.1.6.zip.
=> SHA256 Checksum OK for libreoffice/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip.
=> SHA256 Checksum OK for libreoffice/39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip.
=> SHA256 Checksum OK for libreoffice/97b2d4dba862397f446b217e2b623e71-libloader-1.1.6.zip.
=> SHA256 Checksum OK for libreoffice/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip.
=> SHA256 Checksum OK for libreoffice/3c219630e4302863a9a83d0efde889db-commons-logging-1.1.1-src.tar.gz.
=> SHA256 Checksum OK for libreoffice/f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip.
=> SHA256 Checksum OK for libreoffice/3404ab6b1792ae5f16bbd603bd1e1d03-libformula-1.1.7.zip.
=> SHA256 Checksum OK for libreoffice/3bdf40c0d199af31923e900d082ca2dd-libfonts-1.1.6.zip.
=> SHA256 Checksum OK for libreoffice/ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip.
=> SHA256 Checksum OK for libreoffice/8ce2fcd72becf06c41f7201d15373ed9-librepository-1.1.6.zip.
=> SHA256 Checksum OK for libreoffice/db60e4fde8dd6d6807523deb71ee34dc-liblayout-0.2.10.zip.
=> SHA256 Checksum OK for libreoffice/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip.
===>   libreoffice-3.5.2_2 depends on file: /usr/local/bin/perl5.12.4 - found
===>  Patching for libreoffice-3.5.2_2
===>   libreoffice-3.5.2_2 depends on file: /usr/local/bin/perl5.12.4 - found
===>  Applying FreeBSD patches for libreoffice-3.5.2_2
#Visibility is broken with clang
===>   libreoffice-3.5.2_2 depends on executable: zip - found
===>   libreoffice-3.5.2_2 depends on executable: gpatch - found
===>   libreoffice-3.5.2_2 depends on executable: unzip - found
===>   libreoffice-3.5.2_2 depends on executable: bash - found
===>   libreoffice-3.5.2_2 depends on executable: dmake - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/lib/perl5/site_perl/5.12.4/Archive/Zip.pm - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/bin/gperf - found
===>   libreoffice-3.5.2_2 depends on executable: vigra-config - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/lib/libcppunit.so - found
===>   libreoffice-3.5.2_2 depends on executable: ant - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/share/java/classes/junit.jar - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/share/java/classes/xercesImpl.jar - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/share/java/classes/xalan.jar - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/share/java/classes/bsh.jar - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/bin/python2.7 - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/diablo-jdk1.6.0/bin/java - found
===>   libreoffice-3.5.2_2 depends on executable: gmake - found
===>   libreoffice-3.5.2_2 depends on executable: bison - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/libdata/pkgconfig/xaw7.pc - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/libdata/pkgconfig/xrandr.pc - found
===>   libreoffice-3.5.2_2 depends on package: gstreamer-plugins>=0.10.0 - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/bin/perl5.12.4 - found
===>   libreoffice-3.5.2_2 depends on file: /usr/local/bin/intltool-extract - found
===>   libreoffice-3.5.2_2 depends on executable: pkg-config - found
===>   libreoffice-3.5.2_2 depends on executable: update-desktop-database - found
===>   libreoffice-3.5.2_2 depends on executable: gtk-update-icon-cache - found
===>   libreoffice-3.5.2_2 depends on shared library: cairo.2 - found
===>   libreoffice-3.5.2_2 depends on shared library: xml2.5 - found
===>   libreoffice-3.5.2_2 depends on shared library: xslt.2 - found
===>   libreoffice-3.5.2_2 depends on shared library: expat.6 - found
===>   libreoffice-3.5.2_2 depends on shared library: icutu.48 - found
===>   libreoffice-3.5.2_2 depends on shared library: jpeg.11 - found
===>   libreoffice-3.5.2_2 depends on shared library: curl.6 - found
===>   libreoffice-3.5.2_2 depends on shared library: hunspell-1.3.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: mythes-1.2.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: hyphen.2 - found
===>   libreoffice-3.5.2_2 depends on shared library: poppler-glib.8 - found
===>   libreoffice-3.5.2_2 depends on shared library: wpd-0.9.9 - found
===>   libreoffice-3.5.2_2 depends on shared library: wpg-0.2.2 - found
===>   libreoffice-3.5.2_2 depends on shared library: wps-0.2.2 - found
===>   libreoffice-3.5.2_2 depends on shared library: rdf.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: exttextcat.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: lpsolve55 - found
===>   libreoffice-3.5.2_2 depends on shared library: cups.2 - found
===>   libreoffice-3.5.2_2 depends on shared library: visio-0.0.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: graphite2.2 - found
===>   libreoffice-3.5.2_2 depends on shared library: nss3.1 - found
===>   libreoffice-3.5.2_2 depends on shared library: SampleICC.2 - found
===>   libreoffice-3.5.2_2 depends on shared library: png.6 - found
===>   libreoffice-3.5.2_2 depends on shared library: cmis-0.2.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: intl - found
===>   libreoffice-3.5.2_2 depends on shared library: GL.1 - found
===>   libreoffice-3.5.2_2 depends on shared library: GLU.1 - found
===>   libreoffice-3.5.2_2 depends on shared library: pq.5 - found
===>   libreoffice-3.5.2_2 depends on shared library: db41.1 - found
===>   libreoffice-3.5.2_2 depends on shared library: atk-1.0.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: gdk_pixbuf-2.0.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: gconf-2.4 - found
===>   libreoffice-3.5.2_2 depends on shared library: glib-2.0.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: gtk-x11-2.0.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: gsf-1.114 - found
===>   libreoffice-3.5.2_2 depends on shared library: IDL-2.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: rsvg-2.2 - found
===>   libreoffice-3.5.2_2 depends on shared library: xml2.5 - found
===>   libreoffice-3.5.2_2 depends on shared library: ORBit-2.0 - found
===>   libreoffice-3.5.2_2 depends on shared library: pango-1.0.0 - found
===>  Configuring for libreoffice-3.5.2_2
configure: WARNING: unrecognized options: --with-system-xerces, --with-xerces-jar, --with-system-xml-apis, --with-xml-apis-jar, --with-system-xalan, --with-xalan-jar, --with-serializer-jar
********************************************************************
*
*   Running LibreOffice build configuration.
*
********************************************************************

checking build system type... amd64-portbld-freebsd9.0
checking host system type... amd64-portbld-freebsd9.0
checking for sed... /usr/bin/sed
checking the FreeBSD operating system release... found OSVERSION=900044
checking which thread library to use... -pthread
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for gawk... gawk
checking for gawk... /usr/local/bin/gawk
checking for bash... /usr/local/bin/bash
checking for GNU or BSD tar... gtar
configure: Automatic ccache detection ingored: CC is pre-defined
checking gcc home... /usr
checking for gcc... clang
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether clang accepts -g... yes
checking for clang option to accept ISO C89... none needed
checking for clang... /usr/bin/clang
checking the GNU C compiler version... checked (gcc 4.2.1)
checking for -Bsymbolic-functions linker support ... found 
checking whether to enable crashdump feature... yes
checking whether to turn warnings to errors... no
checking whether to do a debug build... yes
checking whether to build with additional debug utilities... yes
configure: error: --with-system-cppunit conflicts with DBG_UTIL build
===>  Script "configure" failed unexpectedly.
Please report the problem to office@FreeBSD.org [maintainer] and attach the
"/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. an `ls /var/db/pkg`).
*** Error code 1

Stop in /usr/ports/editors/libreoffice.
*** Error code 1

Stop in /usr/ports/editors/libreoffice.
*** Error code 1
"

How-To-Repeat: # cd /usr/ports/editors/libreoffice-es
# make install clean
Comment 1 Edwin Groothuis freebsd_committer 2012-05-07 23:20:19 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 baptiste.daroussin 2012-05-18 23:53:54 UTC
Debug option is know to be broken for now.

Sorry
Comment 3 Baptiste Daroussin freebsd_committer 2012-05-18 23:54:53 UTC
State Changed
From-To: open->closed

duplicate of ports/167400