Bug 168179 - update port: lang/urweb
Summary: update port: lang/urweb
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-21 00:30 UTC by Timothy Beyer
Modified: 2012-06-04 01:03 UTC (History)
1 user (show)

See Also:


Attachments
urweb.diff (829 bytes, patch)
2012-05-21 00:30 UTC, Timothy Beyer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Beyer 2012-05-21 00:30:01 UTC
- Update to version 20120519.

Fix: Apply the patch and build
How-To-Repeat: apply the patch and build
Comment 1 Ruslan Makhmatkhanov freebsd_committer 2012-05-21 21:06:57 UTC
Responsible Changed
From-To: freebsd-ports-bugs->rm

I will take it.
Comment 2 Ruslan Makhmatkhanov freebsd_committer 2012-05-30 19:37:05 UTC
State Changed
From-To: open->feedback

Hi Timothy, sorry for delay. There is a problem with this patch. It 
looks like that on deinstall lang/urweb removing some files/directories 
that belong to lang/mlton. So the clean deinstall of lang/mlton after 
lang/urweb deinstallation fails. If I install/deinstall just lang/mlton 
- it deinstalls just fine without any error messages. Would you please 
investigate? Here is the logs: http://people.freebsd.org/~rm/168179/. In 
urweb-20120519.log you may see that after lang/urweb is deinstalled 
system going to deinstall lang/mlton and there is missing directories. 
Thanks
Comment 3 Timothy Beyer 2012-06-02 03:15:09 UTC
Hi,

I investigated this issue in more detail, and it is because the mlton pkg-plist specifies some empty directories.

After building a "from-scratch" package, when I first installed it, and as you noted, it gave no errors on deinstall.

However, after using pkg_add on the previously generated package, the deinstall gave the same errors that you noted.

I believe the reason for this is because those directories, as installed by mlton itself, are empty, and the package target never includes the empty directories.  So, when installing again from that respective package, those empty directories are never installed via the pkg_add as they would be during the regular install.

This was reproduced without even having urweb installed, so I believe that this is an idiosyncrasy of mlton's build process, which could be fully resolved by using @dirrmtry on each of those respective directories in the pkg-plist of lang/mlton.

The issue is not related to the build process of lang/urweb, at least not directly.  Based on the output of genplist and a cursory glance at the urweb Makefiles, lang/urweb does not delete or change any of the files or directories of lang/mlton.

Best Regards,
Tim
Comment 4 dfilter service freebsd_committer 2012-06-04 00:29:00 UTC
rm          2012-06-03 23:28:44 UTC

  FreeBSD ports repository

  Modified files:
    lang/urweb           Makefile distinfo pkg-descr 
  Log:
  - update to 20120519
  
  PR:             168179
  Submitted by:   Timothy Beyer <beyert at cs.ucr dot edu> (maintainer)
  
  Revision  Changes    Path
  1.4       +1 -2      ports/lang/urweb/Makefile
  1.3       +2 -2      ports/lang/urweb/distinfo
  1.2       +1 -1      ports/lang/urweb/pkg-descr
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Ruslan Makhmatkhanov freebsd_committer 2012-06-04 01:03:06 UTC
State Changed
From-To: feedback->closed

Committed, thank you! Also thanks for mlton packaging issue 
investigation.