Bug 16843 - Knob for release/Makefile to prevent deleting docproj distfiles
Summary: Knob for release/Makefile to prevent deleting docproj distfiles
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 4.0-CURRENT
Hardware: Any Any
: Normal Affects Only Me
Assignee: matusita
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2000-02-20 21:10 UTC by jack
Modified: 2002-02-08 17:12 UTC (History)
0 users

See Also:


Attachments
file.diff (829 bytes, patch)
2000-02-20 21:10 UTC, jack
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jack 2000-02-20 21:10:01 UTC
    Add NODISTCLEAN variable to prevent deleting distfiles needed for docproj,
	which seem to update frequently, from being deleted so they don't have to 
	be fetched again next time.
	Default action is unchanged.
Comment 1 Johan.Karlsson 2000-08-02 16:06:08 UTC
Duplicate of PR 16842
http://www.FreeBSD.org/cgi/query-pr.cgi?pr=16842

Please close :-)
/K
-- 
Johan Karlsson              Phone : +46 (0)920 720 16 
Systemteknik, Datalogi      Fax   : +46 (0)920 721 91 
Luleå Tekniska Universitet  E-mail: Johan.Karlsson@SM.LuTH.SE
S-971 87 LULEÅ, SWEDEN
Comment 2 k 2000-08-05 09:54:28 UTC
Do not close this one, PR 16842 has been closed.

/K
Comment 3 Sheldon Hearn freebsd_committer 2000-08-07 11:00:51 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-doc

The doc folks will be interested in this one.
Comment 4 nik freebsd_committer 2001-02-11 17:30:33 UTC
Responsible Changed
From-To: freebsd-doc->jkh

This affects release/Makefile, and adds a convenience knob.  I've got no 
objection to it going in, but the release process is your baby.
Comment 5 matusita freebsd_committer 2002-01-31 00:00:41 UTC
State Changed
From-To: open->analyzed

It's similar problem of PR: 34914.  Removing distfiles/ is (supporsed to) 
required to make a ports.tgz tarball, however, in some cases, 
we do *not* want to remove it.  There is already a proposed-fix for 
PR: 34914 -- this PR also can be closed if PR: 34914 is closed. 


Comment 6 matusita freebsd_committer 2002-01-31 00:00:41 UTC
Responsible Changed
From-To: jkh->matusita

I'll take this since PR: 34914 is handled by me.  jkh was 
agreed to takeover.
Comment 7 matusita freebsd_committer 2002-01-31 01:05:59 UTC
State Changed
From-To: analyzed->feedback

I commited src/release/Makefile rev 1.655, which doesn't remove 
directory itself but exclude distfiles from ports.tgz. 

http://www.freebsd.org/cgi/cvsweb.cgi/src/release/Makefile.diff?r1=1.654&r2=1.655 

Even if there is no knob you proposed, but I hope you welcome 
this change.  How do you think about this?  If it is OK, may I 
close this PR?
Comment 8 matusita freebsd_committer 2002-02-08 17:08:06 UTC
State Changed
From-To: feedback->closed

The PR submitter already agreed (by private email) that this PR can be 
closed if MFCed.  Just a few minutes before, src/release/Makefile 
rev 1.655 is MFCed as rev 1.536.2.73, so I close this PR.  Thank you.