Bug 168551 - [umass] Issues with embedded card reader (Laptop ASUS K43SJ)
Summary: [umass] Issues with embedded card reader (Laptop ASUS K43SJ)
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: Unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-usb (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-02 07:20 UTC by Eugene Dzhurinsky
Modified: 2017-12-31 22:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Dzhurinsky 2012-06-02 07:20:10 UTC
> usbconfig list

ugen0.1: <EHCI root HUB Intel> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE
ugen1.1: <EHCI root HUB Intel> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE
ugen2.1: <XHCI root HUB 0x1b21> at usbus2, cfg=0 md=HOST spd=SUPER (5.0Gbps) pwr=SAVE
ugen0.2: <product 0x0024 vendor 0x8087> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE
ugen1.2: <product 0x0024 vendor 0x8087> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE
ugen0.3: <product 0x3304 vendor 0x13d3> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON
ugen0.4: <ASUS USB2.0 WebCam 04G6200086K1AN17J000SGH> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON
ugen0.5: <USB2.0-CRW Generic> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=O

> usbconfig -d 0.5 dump_device_desc
ugen0.5: <USB2.0-CRW Generic> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON

  bLength = 0x0012 
  bDescriptorType = 0x0001 
  bcdUSB = 0x0200 
  bDeviceClass = 0x00ff 
  bDeviceSubClass = 0x00ff 
  bDeviceProtocol = 0x00ff 
  bMaxPacketSize0 = 0x0040 
  idVendor = 0x0bda 
  idProduct = 0x0139 
  bcdDevice = 0x3960 
  iManufacturer = 0x0001  <Generic>
  iProduct = 0x0002  <USB2.0-CRW>
  iSerialNumber = 0x0003  <20100201396000000>
  bNumConfigurations = 0x0001

I added the following lines to /usr/src/sys/dev/usb/usbdevs

> product REALTEK USB201CRW   0x0139  USB20CRW Card Reader

and to /usr/src/sys/dev/usb/quirk/usb_quirk.c

>        USB_QUIRK(REALTEK, USB201CRW, 0x0000, 0xffff, UQ_MSC_NO_GETMAXLUN,
>                                UQ_MSC_FORCE_WIRE_BBB, UQ_MSC_FORCE_PROTO_SCSI),

After loading modules:

usb_quirk.ko
uhci.ko
ohci.ko
ehci.ko
xhci.ko
umass.ko

in dmesg I can see:

ugen0.5: <Generic> at usbus0
umass0: <Bulk-In, Bulk-Out, Interface> on usbus0
umass0:  SCSI over Bulk-Only; quirks = 0x0100
umass0:2:0:-1: Attached to scbus2

however when the card is plugged in - no /dev/da* entries appear.

How-To-Repeat: insert SD card into card-reader
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:30 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped