Bug 168661 - devel/boost-libs fails on make package because of missed libboost_locale
devel/boost-libs fails on make package because of missed libboost_locale
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Ruslan Makhmatkhanov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 11:20 UTC by Alexey Markov
Modified: 2012-07-13 21:17 UTC (History)
0 users

See Also:


Attachments
logs.tbz (88.71 KB, application/octet-stream)
2012-06-25 09:34 UTC, Alexey Markov
no flags Details
patch.txt (342 bytes, text/plain; format=flowed)
2012-06-25 14:08 UTC, Alexey Markov
no flags Details
boost-libs.patch (674 bytes, patch)
2012-06-25 16:14 UTC, scheidell
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Markov 2012-06-04 11:20:10 UTC
After upgrading devel/boost-libs port from 1.45 to 1.48 "make package" fails on making tarball:

tar: lib/libboost_locale.a: Cannot stat: No such file or directory
tar: lib/libboost_locale.so: Cannot stat: No such file or directory
tar: Error exit delayed from previous errors.
pkg_create: make_dist: tar command failed with code 256

In fact, libboost_locale is not built during make stage. I think, because it can't find installed iconv library:

Performing configuration checks

    - has_icu builds           : no
warning: Graph library does not contain MPI-based parallel components.
note: to enable them, add "using mpi ;" to your user-config.jam
    - iconv (libc)             : no
    - iconv (separate)         : no
    - icu                      : no
    - icu (lib64)              : no
- Boost.Locale needs either iconv or ICU library to be built.
- Boost.Locale needs either iconv or ICU library to be built.
- Boost.Locale needs either iconv or ICU library to be built.
- Boost.Locale needs either iconv or ICU library to be built.
- Boost.Locale needs either iconv or ICU library to be built.
- Boost.Locale needs either iconv or ICU library to be built.
    - ../config//has_gcc_visibility builds : yes
    - ../config//has_long_double_support builds : no
warning: skipping optional Message Passing Interface (MPI) library.
note: to enable MPI support, add "using mpi ;" to user-config.jam.
note: to suppress this message, pass "--without-mpi" to bjam.
note: otherwise, you can safely ignore this message.
- Boost.Locale needs either iconv or ICU library to be built.
- Boost.Locale needs either iconv or ICU library to be built.
- Boost.Locale needs either iconv or ICU library to be built.
- Boost.Locale needs either iconv or ICU library to be built.
- Boost.Locale needs either iconv or ICU library to be built.
- Boost.Locale needs either iconv or ICU library to be built.

How-To-Repeat: cd /usr/ports/converters/libiconv && make install clean

cd /usr/ports/devel/boost-libs
make
make package
Comment 1 Edwin Groothuis freebsd_committer 2012-06-04 13:44:38 UTC
Maintainer of devel/boost-libs,

Please note that PR ports/168661 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/168661

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2012-06-04 13:44:39 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 scheidell freebsd_committer 2012-06-24 11:01:00 UTC
Responsible Changed
From-To: freebsd-ports-bugs->scheidell

I'll take it.
Comment 4 scheidell freebsd_committer 2012-06-24 12:14:29 UTC
Alexey:
I don't see any problem, with amd64 and FreeBSD 8.3 Stable, and default 
options and nothing (much) in the make.conf file?
Can you check your make.conf file, and check /var/db/ports/*/OPTIONS, 
and see if you have any non default options for boost-libs or dependencies?

logs:
http://people.freebsd.org/~scheidell/boost-libs-1.48.0.log

can you update your ports tree? look in /usr/ports/UPDATING for anything 
you might have missed?


Also, we can only support current, released versions.  if this only 
happens on 8.2, then we won't be able to fix it.

You might ask for assistance in the freebsd-ports@ mailing list.


-- 
Michael Scheidell, CTO
 >*| * SECNAP Network Security Corporation
d: +1.561.948.2259
w: http://people.freebsd.org/~scheidell
Comment 5 Alexey Markov 2012-06-25 07:58:25 UTC
Hello, Michael!

I have tested boost-libs building on another FreeBSD 8-RELEASE-p3
server with latest ports. With default options (only ICU option on)
everything builds fine. If I uncheck ICU option (because I don't
need ICU for Boost.Regex), `make package` fails on building locale
library (because boost-libs can't find installed iconv library).

So, we have either make ICU dependence unconditional (because in fact
port can't make package without this option) or fix port that it can
find installed iconv library and build against it.

P.S. BWT, previous version of boost-libs (1.45) worked fine with iconv
library and without ICU, so I thing there is some regression in the
boost itself.

-- 
WBR, Alexey Markov.
Comment 6 Alexey Markov 2012-06-25 09:34:36 UTC
Just in case I attached two logs of port building with and without
ICU option. Maybe it will be useful...

-- 
WBR, Alexey Markov.
Comment 7 scheidell freebsd_committer 2012-06-25 12:05:10 UTC

On 6/25/12 4:34 AM, Alexey Markov wrote:
> Just in case I attached two logs of port building with and without
> ICU option. Maybe it will be useful...
>
actually, no, as a port committer, I just commit the port after testing it.

If you need help fixing the port, I suggest you email freebsd-ports@ 
mailing list.


-- 
Michael Scheidell, CTO
 >*| * SECNAP Network Security Corporation
d: +1.561.948.2259
w: http://people.freebsd.org/~scheidell
Comment 8 Alexey Markov 2012-06-25 14:08:11 UTC
Well, solution for this PR was pretty obvious... ;-)

Two-line patch attached to this message. I have tested
it on my build-box, and now boost-libs port works fine
with iconv installed from ports.

-- 
WBR, Alexey Markov.
Comment 9 scheidell freebsd_committer 2012-06-25 16:14:13 UTC
Maintainer: please test and appove the following patch
- Add USE_ICONV, required if WITHOUT_ICU
- pet portlint
- No PORTREVISION bump, since WITH_ICU is default

Build Logs
<http://lorie.secnap.net/tb/logs/9-scheidell_AMD64/boost-libs-1.48.0.log>
did NOT build WITHOUT_ICU before.

-- 
Michael Scheidell, CTO
SECNAP Network Security Corporation
http://people.freebsd.org/~scheidell

______________________________________________________________________
This email has been scanned and certified safe by SpammerTrap(r). 
For Information please see http://www.spammertrap.com/
______________________________________________________________________  
  
Comment 10 Ruslan Makhmatkhanov freebsd_committer 2012-07-10 13:05:21 UTC
Responsible Changed
From-To: scheidell->rm

Grab per discussion with scheidell@
Comment 11 dfilter freebsd_committer 2012-07-13 21:09:23 UTC
rm          2012-07-13 20:09:11 UTC

  FreeBSD ports repository

  Modified files:
    devel/boost-all      common.mk 
    devel/boost-libs     Makefile 
    devel/boost-libs/files patch-boost_asio-ioctl 
  Added files:
    devel/boost-libs/files 
                           patch-boost-interprocess-shared_memory_object.hpp 
  Log:
  - fix packaging when WITH_ICU is off [1]
  - fix applications hanging issue (deluge and qbittorrent at least) [2]
  - fix interprocess communication (upstream svn revision 76181) [3]
  - bump PORTREVISION
  
  PR:             168661 [1]
  PR:     169755 [2]
  PR:     169806 [3]
  Submitted by:   Alexey Markov <redrat at mail dot ru> [1],
                  Mario Lobo <lobo@bsd.com.br> [2],
                  Martin Matuska <mm at FreeBSD dot org> [3]
  Approved by:    maintainer timeout (1 month)
  
  Revision  Changes    Path
  1.6       +1 -0      ports/devel/boost-all/common.mk
  1.13      +4 -1      ports/devel/boost-libs/Makefile
  1.1       +37 -0     ports/devel/boost-libs/files/patch-boost-interprocess-shared_memory_object.hpp (new)
  1.3       +12 -6     ports/devel/boost-libs/files/patch-boost_asio-ioctl
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 12 Ruslan Makhmatkhanov freebsd_committer 2012-07-13 21:17:47 UTC
State Changed
From-To: feedback->closed

Committed, thank you!