Bug 168785 - calendar(1): /usr/bin/calendar does not match "Thu+1" or "Mon+1" in some months [regression]
Summary: calendar(1): /usr/bin/calendar does not match "Thu+1" or "Mon+1" in some mont...
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 9.0-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-07 04:40 UTC by wbe
Modified: 2017-12-17 07:14 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wbe 2012-06-07 04:40:05 UTC
Calendar file dates such as "Thu+1" and "Mon+1" are failing to match in two
cases: (1) the 7th of Jan-Nov, and (2) December.  However, there was
another failure that wasn't either of those cases.  I haven't tested other
days of the week or +2, +3, etc.

I chose medium priority because this probably affects a fair number of people.

Fix: 

(none provided in this message)
How-To-Repeat: 
DETAILS/EXAMPLES:

[The bug occurs whether or not the command line options below are used.
 I first noticed it today (a Wednesday) because a Thu+1 event tomorrow was
 not in calendar's output.]

EXAMPLE 1: Thu+1

~/.calendar/calendar: 
Thu+1	foo		(that's "Thu+1\tfoo\n" in C)

foreach i ( 1 2 3 4 5 6 7 8 9 10 11 12 )
&calendar -t 1.$i.2011 -W 9
&end
Jan  6* foo
Feb  3* foo
Mar  3* foo
	<----- Apr 7 absent
May  5* foo
Jun  2* foo
	<----- Jul 7 absent
Aug  4* foo
Sep  1* foo
Oct  6* foo
Nov  3* foo
	<----- Dec 1 absent

foreach i ( 1 2 3 4 5 6 7 8 9 10 11 12 )
&calendar -t 1.$i.2012 -W 9
&end
Jan  5* foo
Feb  2* foo
Mar  1* foo
Apr  5* foo
May  3* foo
	<----- Jun 7 absent
Jul  5* foo
Aug  2* foo
Sep  6* foo
Oct  4* foo
Nov  1* foo
	<----- Dec 6 absent

foreach i ( 1 2 3 4 5 6 7 8 9 10 11 12 )
&calendar -t 1.$i.2013 -W 9
&end
Jan  3* foo
	<----- Feb 7 absent
	<----- Mar 7 absent
Apr  4* foo
May  2* foo
Jun  6* foo
Jul  4* foo
Aug  1* foo
Sep  5* foo
Oct  3* foo
	<----- Nov 7 absent
	<----- Dec 5 absent

EXAMPLE 2: Mon+1

foo:
Mon+1	foo		("Mon+1\tfoo\n")

foreach i ( 1 2 3 4 5 6 7 8 9 10 11 12 )
&calendar -t 1.$i.2011 -W 9 -f foo
&end
Jan  3* foo
	<----- Feb 7 absent
	<----- Mar 7 absent
Apr  4* foo
May  2* foo
Jun  6* foo
Jul  4* foo
Aug  1* foo
Sep  5* foo
Oct  3* foo
	<----- Nov 7 absent
	<----- Dec 5 absent

foreach i ( 1 2 3 4 5 6 7 8 9 10 11 12 )
&calendar -t 1.$i.2012 -W 9 -f foo
&end
Jan  2* foo
Feb  6* foo
Mar  5* foo
Apr  2* foo
	<----- May 3 absent <------- EXCEPTION!
Jun  4* foo
Jul  2* foo
Aug  6* foo
Sep  3* foo
Oct  1* foo
Nov  5* foo
	<----- Dec 3 absent

foreach i ( 1 2 3 4 5 6 7 8 9 10 11 12 )
&calendar -t 1.$i.2013 -W 9 -f foo
&end
	<----- Jan 7 absent
Feb  4* foo
Mar  4* foo
Apr  1* foo
May  6* foo
Jun  3* foo
Jul  1* foo
Aug  5* foo
Sep  2* foo
	<----- Oct 7 absent
Nov  4* foo
	<----- Dec 2 absent

HTH,
 -WBE
Comment 1 Jaakko Heinonen freebsd_committer 2012-11-23 10:05:03 UTC
Hi,

This seems to be yet another regression in r205821. r205820 seems to
work correctly.

edwin: Please take a look at this.

-- 
Jaakko
Comment 2 Greg Lehey freebsd_committer 2016-05-21 04:49:39 UTC
This problem no longer occurs in 10-STABLE, and presumably -CURRENT.  It may be related to r279597.  Closed until proof of the contrary.
Comment 3 vali gholami 2017-12-17 07:14:53 UTC
MARKED AS SPAM