Bug 169428 - [ugen] ugen not detecting all endpoints on device [regression]
Summary: [ugen] ugen not detecting all endpoints on device [regression]
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: Unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-usb (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-25 20:10 UTC by Frank Greco
Modified: 2017-12-31 22:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Greco 2012-06-25 20:10:08 UTC
Starting with FreeBSD 4.2 I had written a C program to control a USB spectrometer (Ocean Optics USB2000). The device always appeared as ugen with two control points, e.g., ugen0.2 and ugen0.7. My program worked through FreeBSD 7 but I have not been able to get it to work with either 8 or 9. In both it appears as only one ugen device, e.g., ugen0.4. I was hoping this issue would get solved along the way, but I am now worried that when FreeBSD 7.4 is no longer supported, that I may get stuck. Any advice would be appreciated.

One of the endpoints, ugen0.2, is for transmitting commands and reading spectra. The other enpoint, ugen0.7, is for receiving current instrument settings only. I suspect, but I have not been able to demonstrate, that it's only the latter endpoint that is showing up. I don't get any response from transmitted commands, which is what would be expected from that endpoint. Everything still works fine in FreeBSD 7, so it's not the instrument.

Thanks for considering this.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2012-07-16 03:34:17 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-usb

reclassify.
Comment 2 Hans Petter Selasky 2012-07-16 14:32:28 UTC
Hi,

Can you list the configuration descriptor:

usbconfig -d X.Y dump_curr_config_desc

And also list all /dev/ugen nodes. Also note that starting from FreeBSD 8, you 
need to do some IOCTL's to set buffer sizes and such to get things working 
properly.

See:

http://svnweb.freebsd.org/base/head/usr.sbin/uathload/uathload.c?view=log

As a reference for simple BULK endpoint programming.

--HPS
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:58:46 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped