Bug 169627 - audio/lash: texi2html
Summary: audio/lash: texi2html
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Alex Kozlov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-03 09:40 UTC by Kalten
Modified: 2012-07-09 15:20 UTC (History)
0 users

See Also:


Attachments
file.diff (1.71 KB, patch)
2012-07-03 09:40 UTC, Kalten
no flags Details | Diff
patch.txt (220 bytes, text/plain; charset=us-ascii)
2012-07-06 13:49 UTC, Alex Kozlov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kalten 2012-07-03 09:40:10 UTC
When compiling audio/lash compilation fails because there is
``texi2html --number'' used, but there is no ``--number'' (any more?).

---SCHNIPP---

gmake[3]: Entering directory `/usr/ports/audio/lash/work/lash-0.5.4/docs'
if test ! -d lash-manual-html-one-page; then \
  mkdir lash-manual-html-one-page; \
fi
if test ! -d lash-manual-html-split; then \
  mkdir -lash-manual-html-split; \
fi
cd lash-manual-html-one-page && \
  texi2html --number ../../docs/lash-manual.texi
Option number is ambiguous (number-footnotes, number-sections)
Try `texi2html --help' for more information.
gmake[3]: *** [html-manual-stamp] Error 2
gmake[3]: Leaving directory `/usr/ports/audio/lash/work/lash-0.5.4/docs'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/audio/lash/work/lash-0.5.4/docs'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/audio/lash/work/lash-0.5.4'
gmake: *** [all] Error 2
*** Error code 1
---schnapp---

Fix: I have added some patch that generates two patch-files for the port,
that simply remove the ``--number'' entries from docs/Makefile.am as
well as from docs/Makefile.in as this option has been displaced by
``--number-footnotes!'' and ``--number-sections!'' which both default to
``on'' in version 5.0 of texi2html (see ``texi2html --help'')---further
more the error text did mention that ``Option number is ambiguous
(number-footnotes, number-sections)''.

Patch attached with submission follows:
How-To-Repeat: cd /usr/ports/audio/lash
make
Comment 1 Alex Kozlov freebsd_committer 2012-07-04 14:42:21 UTC
Responsible Changed
From-To: freebsd-ports-bugs->ak

I'll take it.
Comment 2 Alex Kozlov freebsd_committer 2012-07-05 21:02:55 UTC
Hi, Kalten

I can't reproduce this problem [1], can you please provide more details?

[1] https://redports.org/buildarchive/20120705184322-15905/


-- 
Alex
Comment 3 Kalten 2012-07-06 00:27:52 UTC
Hello!

> I can't reproduce this problem [1], can you please provide more
> details?
Well: it did not happen on the tinderbox[1], as that had not installed
textproc/texi2html prior to calling the »make configure« part in
audio/lash.  Because of that you can read the output
---SCHNIPP---
checking for texi2html... no
configure: WARNING: texi2html not found, manual will not be built
---schnapp---
for example in the log of 9.0-RELEASE/amd64 [2].

So: to reproduce that especial error---and I apologise for having
forgotten to mention this important fact---the textproc/texi2html port
has to be installed already when starting the build of audio/lash.

I hope, that explained everything.

Regards,
 Kalten

[1] https://redports.org/buildarchive/20120705184322-15905/
[2] https://redports.org/~ak0/20120705184322-15905-33343/lash-0.5.4_7.log
--
Comment 4 Alex Kozlov 2012-07-06 13:49:33 UTC
On Fri, Jul 06, 2012 at 01:27:52AM +0200, Kalten wrote:
> Hello!
> 
> > I can't reproduce this problem [1], can you please provide more
> > details?
> Well: it did not happen on the tinderbox[1], as that had not installed
> textproc/texi2html prior to calling the »make configure« part in
> audio/lash.  Because of that you can read the output
> ---SCHNIPP---
> checking for texi2html... no
> configure: WARNING: texi2html not found, manual will not be built
> ---schnapp---
> for example in the log of 9.0-RELEASE/amd64 [2].
> 
> So: to reproduce that especial error---and I apologise for having
> forgotten to mention this important fact---the textproc/texi2html port
> has to be installed already when starting the build of audio/lash.
> 
> I hope, that explained everything.
Is it not better then to completely disable building of docs(see patch)?
The audio/lash port doesn't install them anyway.

Also, can you please explain .if exists devel/readline condition?
If readline important, why it's not mandatory, if readline optional,
why not use option framework for it?


-- 
Alex
Comment 5 Kalten 2012-07-06 16:25:07 UTC
Hello!

> Is it not better then to completely disable building of docs(see
> patch)?  The audio/lash port doesn't install them anyway.
Well: you could implement the installation of the docs (maybe some
optional knob to let the user decide whether he wants them to be
installed) and if it is chosen, automatically depend on texi2html ;-)

But a good point, even if the documentations are not to be installed,
is, that one can build the port and have a look in its work-directory,
whether there happens to be some never installed documentation.

> Also, can you please explain .if exists devel/readline condition?  If
> readline important, why it's not mandatory, if readline optional, why
> not use option framework for it?
Your thoughts about that sound very reasonable: but it has not been I
who has written that Makefile---and I am too busy right now to
investigate the matter further. :-(

Regards,
 Kalten
--
Comment 6 dfilter service freebsd_committer 2012-07-09 15:16:34 UTC
ak          2012-07-09 14:16:18 UTC

  FreeBSD ports repository

  Modified files:
    audio/lash           Makefile 
  Log:
  - Install manual
  - Fix texi2hml usage
  - Remove ABI version numbers in LIB_DEPENDS
  - Remove leftovers of 5.x support
  
  PR:     ports/169627
  Submitted by:   Kalten <kalten@gmx.at>
  
  Revision  Changes    Path
  1.20      +20 -8     ports/audio/lash/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Alex Kozlov freebsd_committer 2012-07-09 15:17:59 UTC
State Changed
From-To: open->closed

Committed. Thanks!