Bug 169659 - [patch] devel/doxygen fix build in tinderbox
[patch] devel/doxygen fix build in tinderbox
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Chris Rees
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 13:00 UTC by spam
Modified: 2012-12-04 08:50 UTC (History)
0 users

See Also:


Attachments
file.diff (419 bytes, patch)
2012-07-05 13:00 UTC, spam
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description spam 2012-07-05 13:00:25 UTC
The doxygen falls to build in tinderbox on FreeBSD9-STABLE/CURRENT because one of the examples has waiting for IO: http://pointyhat.freebsd.org/errorlogs/amd64-errorlogs/e.10.20120628171716/doxygen-1.8.0_1.log

Fix: Apply the patch.

Patch attached with submission follows:
How-To-Repeat: Build doxygen in tinderbox on FreeBSD9-STABLE/CURRENT.
Comment 1 Edwin Groothuis freebsd_committer 2012-07-05 13:00:37 UTC
Responsible Changed
From-To: freebsd-ports-bugs->eadler

eadler@ wants his PRs (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2012-07-05 13:00:41 UTC
Maintainer of devel/doxygen,

Please note that PR ports/169659 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/169659

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Edwin Groothuis freebsd_committer 2012-07-05 13:00:43 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 4 Naram Qashat 2012-07-05 15:34:20 UTC
On 07/05/12 08:00, Edwin Groothuis wrote:
> Maintainer of devel/doxygen,
>
> Please note that PR ports/169659 has just been submitted.
>
> If it contains a patch for an upgrade, an enhancement or a bug fix
> you agree on, reply to this email stating that you approve the patch
> and a committer will take care of it.
>
> The full text of the PR can be found at:
>      http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/169659
>
This patch is acceptable.

Thanks,
Naram Qashat
Comment 5 utisoft 2012-07-05 16:20:03 UTC
I'd prefer to fix the reason for the test hanging, which is the fault of
some change in HEAD.

Something is broken!

Chris
Comment 6 Chris Rees freebsd_committer 2012-07-05 20:18:46 UTC
Responsible Changed
From-To: eadler->crees

I'll take it.
Comment 7 spam 2012-07-05 20:57:59 UTC
On Thu, Jul 05, 2012 at 04:20:03PM +0100, Chris Rees wrote:
> I'd prefer to fix the reason for the test hanging, which is the fault of
> some change in HEAD.
>
> Something is broken!
I agree that the cause must be fixed. But I think that workaround should
be committed until it's done. Not in the last place because I was able to
reproduce this problem on RELENG_9:
http://people.freebsd.org/~ak/tb/logs/doxygen-1.8.0_1.log


-- 
Alex
Comment 8 Chris Rees freebsd_committer 2012-07-07 16:30:38 UTC
State Changed
From-To: feedback->analyzed

I've committed the workaround for now, and I'll try to find what's wrong 
with -CURRENT and 9-STABLE
Comment 9 dfilter freebsd_committer 2012-07-07 16:30:38 UTC
crees       2012-07-07 15:30:24 UTC

  FreeBSD ports repository

  Added files:
    devel/doxygen/files  patch-examples-Makefile.in 
  Log:
  Disable tests until fix is in place for I/O errors
  
  PR:             ports/169659
  Submitted by:   ak
  Approved by:    Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)
  
  Revision  Changes    Path
  1.1       +16 -0     ports/devel/doxygen/files/patch-examples-Makefile.in (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 10 Chris Rees freebsd_committer 2012-12-02 12:33:39 UTC
State Changed
From-To: analyzed->closed

After huge numbers of tests, I've come to the conclusion that the 
failure is due to a newer world run on an old kernel, as is usually the 
case with -HEAD on Tinderbox.  The conclusion I draw from this is that 
we should run the latest FreeBSD on machines we use for testing if we're 
going to useuse Tinderbox.
Comment 11 spam 2012-12-04 08:48:08 UTC
Hi, Chris

> After huge numbers of tests, I've come to the conclusion that the
> failure is due to a newer world run on an old kernel, as is usually the
> case with -HEAD on Tinderbox.  The conclusion I draw from this is that
> we should run the latest FreeBSD on machines we use for testing if we're
> going to useuse Tinderbox.
It's quite plausible. I got this error with RELENG_9/RELENG_9 kernel/world
combination though.


-- 
Alex