Bug 169702 - [patch] graphics/linux-f10-tiff: fix packing list
[patch] graphics/linux-f10-tiff: fix packing list
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: emulation
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-07 20:20 UTC by tijl
Modified: 2012-07-31 15:10 UTC (History)
0 users

See Also:


Attachments
linux-f10-tiff.patch (362 bytes, patch)
2012-07-07 20:20 UTC, tijl
no flags Details | Diff
pkg-plist.diff.txt (7.96 KB, text/plain; charset=UTF-8)
2012-07-30 16:52 UTC, bsam
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description tijl 2012-07-07 20:20:08 UTC
The Makefile sets PLIST incorrectly resulting in an empty packing list.

Also, the Makefile sets DESCR to use the pkg-descr from graphics/tiff,
but the port has its own pkg-descr. Either the latter can be removed
or the Makefile shouldn't set DESCR.
Comment 1 Edwin Groothuis freebsd_committer 2012-07-07 20:20:18 UTC
Responsible Changed
From-To: freebsd-ports-bugs->emulation

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 bsam 2012-07-30 12:39:56 UTC
While agree with DESCR part, I'm not sure about PLIST one
since I can't reproduce it. Can you provide some more
details?
-- 
WBR, Boris Samorodov (bsam)
FreeBSD Committer, http://www.FreeBSD.org The Power To Serve
Comment 3 tijl 2012-07-30 12:56:28 UTC
On 30-07-2012 13:39, Boris Samorodov wrote:
> While agree with DESCR part, I'm not sure about PLIST one
> since I can't reproduce it. Can you provide some more
> details?

I'll take a closer look later, but maybe it's because I have
"WRKDIRPREFIX=/usr/obj" in /etc/make.conf. Also, in bsd.port.mk
the default value of PLIST is ${PKGDIR}/pkg-plist.
Comment 4 tijl 2012-07-30 14:42:14 UTC
On 30-07-2012 14:18, Boris Samorodov wrote:
> 30.07.2012 16:00, Tijl Coosemans пиÑеÑ:
>>   On 30-07-2012 13:39, Boris Samorodov wrote:
>>   > While agree with DESCR part, I'm not sure about PLIST one
>>   > since I can't reproduce it. Can you provide some more
>>   > details?
>>
>>   I'll take a closer look later, but maybe it's because I have
>>   "WRKDIRPREFIX=/usr/obj" in /etc/make.conf.
> 
> That imho should not be the case.

It's because of WRKDIRPREFIX in combination with portmaster.

>> Also, in bsd.port.mk
>>   the default value of PLIST is ${PKGDIR}/pkg-plist.
> 
> This is really more accurate. Seems that this should be
> done for all ports using a non-standard PLIST.

Yes, here are some others:

# grep -R '^PLIST=' * | grep -v -E '(WRKDIR|CURDIR|PKGDIR|MASTERDIR|FILESDIR|WRKSRC|NONEXISTENT)'
audio/linux-esound/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
audio/linux-f10-libaudiofile/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
audio/linux-libaudiofile/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
cad/salome/Makefile.ext:PLIST=		../salome${PKGNAMESUFFIX}/pkg-plist
devel/linux-libglade/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
devel/linux-libglade2/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
games/qix/Makefile:PLIST=		pkg-plist.x11
graphics/linux-f10-imlib/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
graphics/linux-f10-tiff/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
graphics/linux-imlib/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
graphics/linux-tiff/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
graphics/linux-ungif/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
japanese/namazu2/Makefile:PLIST=		"@comment this plist is intentionally left empty"
security/ossec-hids-client/Makefile:PLIST=	pkg-plist.client
security/sinfp/Makefile:PLIST=		""
textproc/linux-libxml/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
textproc/linux-libxml2/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
x11-toolkits/linux-f10-gtk/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
x11-toolkits/linux-f10-qt33/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
x11-toolkits/linux-gtk/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
x11-toolkits/linux-qt33/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
Comment 5 Jan Beich freebsd_committer 2012-07-30 15:28:21 UTC
Tijl Coosemans <tijl@coosemans.org> writes:

> -PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> +PLIST=		${PKGDIR}/pkg-plist.${LINUX_RPM_ARCH}

From a commit that added PKGDIR:

  * Fix pkg-plist handling for ports that set a non-standard
    PREFIX. ports/74691

It gives a hint as to how to reproduce:

  $ make install deinstall PREFIX=/tmp/aaa PKG_DBDIR=/tmp/pkg
  $ find /tmp/aaa/ ! -type d
  /tmp/aaa/usr/bin/raw2tiff
  /tmp/aaa/usr/bin/tiffset
  /tmp/aaa/usr/bin/rgb2ycbcr
  /tmp/aaa/usr/bin/tiffdither
  /tmp/aaa/usr/bin/bmp2tiff
  [...]
Comment 6 bsam 2012-07-30 16:52:18 UTC
30.07.2012 17:42, Tijl Coosemans пиÑеÑ:
> On 30-07-2012 14:18, Boris Samorodov wrote:
>> 30.07.2012 16:00, Tijl Coosemans пиÑеÑ:
>>>    On 30-07-2012 13:39, Boris Samorodov wrote:
>>>    > While agree with DESCR part, I'm not sure about PLIST one
>>>    > since I can't reproduce it. Can you provide some more
>>>    > details?
>>>
>>>    I'll take a closer look later, but maybe it's because I have
>>>    "WRKDIRPREFIX=/usr/obj" in /etc/make.conf.
>>
>> That imho should not be the case.
>
> It's because of WRKDIRPREFIX in combination with portmaster.
>
>>> Also, in bsd.port.mk
>>>    the default value of PLIST is ${PKGDIR}/pkg-plist.
>>
>> This is really more accurate. Seems that this should be
>> done for all ports using a non-standard PLIST.
>
> Yes, here are some others:
>
> # grep -R '^PLIST=' * | grep -v -E '(WRKDIR|CURDIR|PKGDIR|MASTERDIR|FILESDIR|WRKSRC|NONEXISTENT)'
> audio/linux-esound/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> audio/linux-f10-libaudiofile/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> audio/linux-libaudiofile/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> cad/salome/Makefile.ext:PLIST=		../salome${PKGNAMESUFFIX}/pkg-plist
> devel/linux-libglade/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> devel/linux-libglade2/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> games/qix/Makefile:PLIST=		pkg-plist.x11
> graphics/linux-f10-imlib/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> graphics/linux-f10-tiff/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> graphics/linux-imlib/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> graphics/linux-tiff/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> graphics/linux-ungif/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> japanese/namazu2/Makefile:PLIST=		"@comment this plist is intentionally left empty"
> security/ossec-hids-client/Makefile:PLIST=	pkg-plist.client
> security/sinfp/Makefile:PLIST=		""
> textproc/linux-libxml/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> textproc/linux-libxml2/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> x11-toolkits/linux-f10-gtk/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> x11-toolkits/linux-f10-qt33/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> x11-toolkits/linux-gtk/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
> x11-toolkits/linux-qt33/Makefile:PLIST=		pkg-plist.${LINUX_RPM_ARCH}
>

OK, as of linux ports. Here is a patch. Any objections?

-- 
WBR, Boris Samorodov (bsam)
FreeBSD Committer, http://www.FreeBSD.org The Power To Serve
Comment 7 tijl 2012-07-30 20:35:51 UTC
On 30-07-2012 17:52, Boris Samorodov wrote:
> 30.07.2012 17:42, Tijl Coosemans пиÑеÑ:
>> On 30-07-2012 14:18, Boris Samorodov wrote:
>>> 30.07.2012 16:00, Tijl Coosemans пиÑеÑ:
>>>>    On 30-07-2012 13:39, Boris Samorodov wrote:
>>>>    > While agree with DESCR part, I'm not sure about PLIST one
>>>>    > since I can't reproduce it. Can you provide some more
>>>>    > details?
>>>>
>>>>    I'll take a closer look later, but maybe it's because I have
>>>>    "WRKDIRPREFIX=/usr/obj" in /etc/make.conf.
>>>
>>> That imho should not be the case.
>>
>> It's because of WRKDIRPREFIX in combination with portmaster.
>>
>>>> Also, in bsd.port.mk
>>>>    the default value of PLIST is ${PKGDIR}/pkg-plist.
>>>
>>> This is really more accurate. Seems that this should be
>>> done for all ports using a non-standard PLIST.
>>
>> Yes, here are some others:
>>
>> # grep -R '^PLIST=' * | grep -v -E '(WRKDIR|CURDIR|PKGDIR|MASTERDIR|FILESDIR|WRKSRC|NONEXISTENT)'
>> audio/linux-esound/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> audio/linux-f10-libaudiofile/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> audio/linux-libaudiofile/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> cad/salome/Makefile.ext:PLIST=        ../salome${PKGNAMESUFFIX}/pkg-plist
>> devel/linux-libglade/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> devel/linux-libglade2/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> games/qix/Makefile:PLIST=        pkg-plist.x11
>> graphics/linux-f10-imlib/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> graphics/linux-f10-tiff/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> graphics/linux-imlib/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> graphics/linux-tiff/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> graphics/linux-ungif/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> japanese/namazu2/Makefile:PLIST=        "@comment this plist is intentionally left empty"
>> security/ossec-hids-client/Makefile:PLIST=    pkg-plist.client
>> security/sinfp/Makefile:PLIST=        ""
>> textproc/linux-libxml/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> textproc/linux-libxml2/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> x11-toolkits/linux-f10-gtk/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> x11-toolkits/linux-f10-qt33/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> x11-toolkits/linux-gtk/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>> x11-toolkits/linux-qt33/Makefile:PLIST=        pkg-plist.${LINUX_RPM_ARCH}
>>
> 
> OK, as of linux ports. Here is a patch. Any objections?

Looks good to me.
Comment 8 dfilter freebsd_committer 2012-07-31 15:03:30 UTC
Author: bsam
Date: Tue Jul 31 14:03:15 2012
New Revision: 301791
URL: http://svn.freebsd.org/changeset/ports/301791

Log:
  Remove extra pkg-descr file (DESCR is defined at the Makefile).
  
  PR:		ports/169702
  Submitted by:	Tijl Coosemans <tijl@coosemans.org>

Deleted:
  head/graphics/linux-f10-tiff/pkg-descr
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 9 Boris Samorodov freebsd_committer 2012-07-31 15:03:39 UTC
State Changed
From-To: open->closed

Ports are fixed, thanks!