Bug 169998 - /ports/editors/libreoffice v.3.5.5 don't compile
Summary: /ports/editors/libreoffice v.3.5.5 don't compile
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-19 12:40 UTC by Belansky Stanislav
Modified: 2012-08-29 18:14 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Belansky Stanislav 2012-07-19 12:40:06 UTC
I'm sorry, bat new version libreoffice v.3.5.5 from ports collection don'n compile. On console I see errors:

clang++: warning: argument unused during compilation: '-rpath=/usr/lib:/usr/local/lib'
[ build CMP ] avmedia/util/avmedia
[ build CXX ] avmedia/source/gstreamer/gstmanager
[ build CXX ] avmedia/source/gstreamer/gstplayer
[ build CXX ] avmedia/source/gstreamer/gstuno
[ build CXX ] avmedia/source/gstreamer/gstwindow
[ build LNK ] Library/libavmediagst.so
clang++: warning: argument unused during compilation: '-rpath=/usr/lib:/usr/local/lib'
[ build CMP ] avmedia/source/gstreamer/avmediagstreamer
[ build MOD ] avmedia
[ build ALL ] top level modules: bootstrap src.downloaded avmedia
[ build ALL ] loaded modules: avmedia

[ build CHK ] avmedia
[ build CHK ] loaded modules: avmedia

avmedia deliver
Module 'avmedia' delivered successfully. 0 files copied, 0 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/canvas/prj

 it seems that the error is inside 'canvas', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3
source ./Env.Host.sh
cd canvas
gmake clean # optional
gmake -r

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Выход из каталога `/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3'
gmake: *** [source-env-and-recurse] Error 2
*** [do-build] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [install] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [run-depends] Error code 1

Stop in /usr/ports/russian/libreoffice.
*** [/usr/ports/russian/libreoffice/work/.install_done.libreoffice._usr_local] Error code 1

Stop in /usr/ports/russian/libreoffice.
Comment 1 Edwin Groothuis freebsd_committer 2012-07-19 12:40:22 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 vsjcfm 2012-07-19 13:20:54 UTC
Confirmed on FreeBSD 8.3-RELEASE-p3 amd64

[ build CMP ] sd/util/sdfilt
[ build MOD ] writerfilter
[ build CUT ] writerfilter_doctok
[ build MOD ] sd
[ build MOD ] tail_end
[ build ALL ] top level modules: bootstrap src.downloaded tail_end
[ build ALL ] loaded modules: MathMLDTD Mesa animations basctl bean
chart2 cui dbaccess desktop eventattacher fileaccess filter forms
formula hwpfilter lotuswordpro oox package padmin reportdesign sc
sccomp scripting sd slideshow starmath sw swext tail_end unoxml uui
vbahelper wizards writerfilter writerperfect xmerge xmlsecurity

[ build CUT ] writerfilter_rtftok
[ build CHK ] writerfilter
[ build CHK ] tail_end
[ build CHK ] loaded modules: MathMLDTD Mesa animations basctl bean
chart2 cui dbaccess desktop eventattacher fileaccess filter forms
formula hwpfilter lotuswordpro oox package padmin reportdesign sc
sccomp scripting sd slideshow starmath sw swext tail_end unoxml uui
vbahelper wizards writerfilter writerperfect xmerge xmlsecurity

tail_build deliver
Module 'tail_build' delivered successfully. 0 files copied, 0 files unchang=
ed

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making
/tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-co=
re-3.5.5.3/testtools/source/bridgetest

 it seems that the error is inside 'testtools', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice=
-core-3.5.5.3
source ./Env.Host.sh
cd testtools
rm -Rf /tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreof=
fice-core-3.5.5.3/testtools/unxfbsd.pro
# optional module 'clean'
build

when the problem is isolated and fixed exit and re-run 'make' from the top-=
level
gmake[1]: *** [build] =EF=DB=C9=C2=CB=C1 1
gmake[1]: =F7=D9=C8=CF=C4 =C9=DA =CB=C1=D4=C1=CC=CF=C7=C1
`/tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-c=
ore-3.5.5.3'
gmake: *** [source-env-and-recurse] =EF=DB=C9=C2=CB=C1 2
*** Error code 1

Stop in /media/dvlfiles/build/ports/editors/libreoffice.
*** Error code 1

Stop in /media/dvlfiles/build/ports/editors/libreoffice.

Full build log is here -
http://rghost.ru/download/private/39295692/1e5ac59c013ea107af55b74953f8ef73=
/ea5f576a5cfba07bbbd9f848bcf2e6891758da09/build.log.xz
Comment 3 vsjcfm 2012-07-19 13:24:23 UTC
Compiling: testtools/source/bridgetest/multi.cxx
Making:    cppobj.lib
Making:    bridgetest.lib
Making:    cppobj.uno.so
Making:    bridgetest.uno.so
Compiling: testtools/source/bridgetest/constructors.cxx
Making:    constructors.uno.so
echo ../../unxfbsd.pro/lib
../../unxfbsd.pro/lib
cp /tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solver/unxfbsd.pro/bin/udkapi.rdb
../../unxfbsd.pro/lib/uno_types.rdb
: &&     LD_LIBRARY_PATH=/tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solver/unxfbsd.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
 /tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solver/unxfbsd.pro/bin/regmerge
../../unxfbsd.pro/lib/uno_types.rdb /
../../unxfbsd.pro/bin/bridgetest.rdb
echo \
        '<list><filename>bridgetest.component</filename>
<filename>constructors.component</filename>
<filename>cppobj.component</filename></list>' \
        > ../../unxfbsd.pro/misc/uno_services.input
/usr/local/bin/xsltproc --nonet --stringparam uri
'./bridgetest.uno.so' -o ../../unxfbsd.pro/misc/bridgetest.component \
        /tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solenv/bin/createcomponent.xslt
bridgetest.component
/usr/local/bin/xsltproc --nonet --stringparam uri
'./constructors.uno.so' -o
../../unxfbsd.pro/misc/constructors.component \
        /tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solenv/bin/createcomponent.xslt
constructors.component
/usr/local/bin/xsltproc --nonet --stringparam uri './cppobj.uno.so' -o
../../unxfbsd.pro/misc/cppobj.component \
        /tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solenv/bin/createcomponent.xslt
cppobj.component
/usr/local/bin/xsltproc --nonet --stringparam prefix
/tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/testtools/source/bridgetest/../../unxfbsd.pro/misc/
-o ../../unxfbsd.pro/lib/uno_services.rdb \
        /tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solenv/bin/packcomponents.xslt
../../unxfbsd.pro/misc/uno_services.input
cd ../../unxfbsd.pro/lib && : &&
LD_LIBRARY_PATH=/tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solver/unxfbsd.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
/tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solver/unxfbsd.pro/bin/uno
\
        -ro uno_services.rdb -ro uno_types.rdb \
        -s com.sun.star.test.bridge.BridgeTest -- \
        com.sun.star.test.bridge.CppTestObject
/usr/local/bin/bash: line 1: 76980 Segmentation fault: 11  (core
dumped) LD_LIBRARY_PATH=/tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solver/unxfbsd.pro/lib${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
/tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/solver/unxfbsd.pro/bin/uno
-ro uno_services.rdb -ro uno_types.rdb -s
com.sun.star.test.bridge.BridgeTest --
com.sun.star.test.bridge.CppTestObject
dmake:  Error code 139, while making 'runtest'

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making
/usr/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/testtools/source/bridgetest

 it seems that the error is inside 'testtools', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3
source ./Env.Host.sh
cd testtools
rm -Rf /tmp/obj/media/dvlfiles/build/ports/editors/libreoffice/work/libreoffice-core-3.5.5.3/testtools/unxfbsd.pro
# optional module 'clean'
build

when the problem is isolated and fixed exit and re-run 'make' from the top-leve
Comment 4 Jung-uk Kim freebsd_committer 2012-07-23 21:31:50 UTC
State Changed
From-To: open->feedback

It seems you have old stable/9.  Please let us know if it still 
happens with the latest stable/9.
Comment 5 Belansky Stanislav 2012-07-24 15:00:32 UTC
24.07.2012 00:34, jkim@FreeBSD.org ÐÉÛÅÔ:
> Synopsis: /ports/editors/libreoffice v.3.5.5 don't compile
>
> State-Changed-From-To: open->feedback
> State-Changed-By: jkim
> State-Changed-When: Mon Jul 23 20:31:50 UTC 2012
> State-Changed-Why:
> It seems you have old stable/9.  Please let us know if it still
> happens with the latest stable/9.
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=169998
>
>
Good day!
You are right: after updating FreeBSD 9.0-STABLE as of today 24.07, 
build libreoffice finished successfully.
Thanks.

-- 
Stanislav Belansky
Comment 6 Alex Dupre freebsd_committer 2012-08-08 14:37:26 UTC
It's still an issue for FreeBSD 8.x

-- 
Alex Dupre
Comment 7 Jung-uk Kim freebsd_committer 2012-08-08 18:34:51 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 2012-08-08 09:37:26 -0400, Alex Dupre wrote:
> It's still an issue for FreeBSD 8.x

Yes, it is still broken.  Unfortunately, it is a lot more complicated
than I originally hoped.  First of all, there are various issues with
Boost 1.48 depending on the environments, especially C++11 compiler
(i.e., Clang) with C++03 userland (i.e., libstdc++).  If we force it
to use GNU++03 mode, then we hit different problems, e.g.,

https://svn.boost.org/trac/boost/ticket/6167
https://svn.boost.org/trac/boost/ticket/6311

Actually, Boost 1.50 (and upcoming 1.51*) has fixed most of these
problems but I think it's too late because port freeze is imminent.

Second, USE_OPENSSL is badly broken.  It adds bogus -rpath to LDFLAGS
and it causes various issues because ${LOCALBASE}/lib is always added
to it and bundled libraries are never picked up.  We should consider
dropping USE_OPENSSL, IMHO.  Also, adding -I${LOCALBASE}/include to
CFLAGS causes similar problem.

I was able to build it with base GCC with some ugly hacks from *clean*
build environment (i.e., only installed build dependencies).  However,
I have no environment to perform run-time tests.

http://lists.freebsd.org/pipermail/freebsd-office/2012-July/001242.html

BTW, LibreOffice 3.6.0 was released today.  Bad news is it has more
serious build issues and more dependencies (e.g., ICU 49 and later).
I was secretly working on it but I am about to giving up. :-(

Jung-uk Kim

* http://www.boost.org/development/index.html
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAlAiozsACgkQmlay1b9qnVM4xQCgyn/7hBBd0vBlQzU5VfdUjNja
SGcAoKq7pncyJ8Apif6+twDnW/X1NFpy
=ZVqz
-----END PGP SIGNATURE-----
Comment 8 Jung-uk Kim freebsd_committer 2012-08-23 17:23:01 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

LibreOffice was just updated to 3.5.6.  Can you please test it and let
us know?

Thanks!

Jung-uk Kim
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAlA2WOUACgkQmlay1b9qnVN3GQCffG0kIWZA46JH09FO7hSWjzdz
G9YAnjBQnuj5X9w9uCYJAoRlL+MYIMg1
=OVuX
-----END PGP SIGNATURE-----
Comment 9 admin 2012-08-27 13:43:29 UTC
 >LibreOffice was just updated to 3.5.6. Can you please test it and let
 >us know?
Good day!
Version 3.5.6 Libreoffice build successfully.
Thanks.

-- 

Stanislav Belansky
Comment 10 Juergen Lock freebsd_committer 2012-08-29 18:14:14 UTC
State Changed
From-To: feedback->closed

Submitter notes issue no longer exists with 3.5.6 .