Bug 170207 - audio/ctronome does not produce sound on amd64 platform.
Summary: audio/ctronome does not produce sound on amd64 platform.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-27 08:30 UTC by d.y.kazarov
Modified: 2012-08-12 10:23 UTC (History)
0 users

See Also:


Attachments
file.diff (639 bytes, patch)
2012-07-27 08:30 UTC, d.y.kazarov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description d.y.kazarov 2012-07-27 08:30:06 UTC
Due to incorrect width of integers used in bitwise operations ctronome produce no sound on amd64 platform.

Fix: Patch attached with submission follows:
How-To-Repeat: Compile port on 64-bit FreeBSD and start it.
Comment 1 Edwin Groothuis freebsd_committer 2012-07-27 08:30:14 UTC
Maintainer of audio/ctronome,

Please note that PR ports/170207 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/170207

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2012-07-27 08:30:19 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Michael Scheidell freebsd_committer 2012-07-27 08:40:23 UTC
State Changed
From-To: feedback->open

Back to open to kick
Comment 4 Michael Scheidell freebsd_committer 2012-07-27 08:41:18 UTC
State Changed
From-To: open->feedback

GNATS didn't kick. will do by hand.
Comment 5 Michael Scheidell freebsd_committer 2012-07-27 08:43:04 UTC
Responsible Changed
From-To: freebsd-ports-bugs->scheidell

I'll take it.
Comment 6 Michael Scheidell freebsd_committer 2012-07-27 08:54:28 UTC
Responsible Changed
From-To: scheidell->freebsd-ports-bugs

Back to the pool. 
This message was created automatically by mail delivery software (TMDA). 

Your message attached below is being held because the address 
<scheidell@FreeBSD.org> has not been verified. 

To release your message for delivery, please send an empty message 
to the following address, or use your mailer's "Reply" feature. 

mercadal-confirm-1343375048.16462.f885ad@diablonet.net 

This confirmation verifies that your message is legitimate and not 
junk-mail. You should only have to confirm your address once.
Comment 7 Ruslan Makhmatkhanov freebsd_committer 2012-07-28 18:52:00 UTC
Responsible Changed
From-To: freebsd-ports-bugs->rm

I will take it. Confirmed. Sent upstream bug-report
Comment 8 dfilter service freebsd_committer 2012-08-12 09:53:41 UTC
Author: rm
Date: Sun Aug 12 08:53:27 2012
New Revision: 302428
URL: http://svn.freebsd.org/changeset/ports/302428

Log:
  - add patch to fix runtime on amd64
  
  I also got an response from upstream maintainer that this change
  will be included into the next release.
  
  PR:		170207
  Submitted by:	Dmitry Kazarov <d.y.kazarov at mail dot ru>
  Approved by:	maintainer timeout (>2 weeks)

Added:
  head/audio/ctronome/files/patch-ctronome.h   (contents, props changed)
Modified:
  head/audio/ctronome/Makefile
  head/audio/ctronome/pkg-descr

Modified: head/audio/ctronome/Makefile
==============================================================================
--- head/audio/ctronome/Makefile	Sun Aug 12 08:33:10 2012	(r302427)
+++ head/audio/ctronome/Makefile	Sun Aug 12 08:53:27 2012	(r302428)
@@ -7,6 +7,7 @@
 
 PORTNAME=	ctronome
 PORTVERSION=	0.5.3
+PORTREVISION=	1
 CATEGORIES=	audio
 MASTER_SITES=	http://ctronome.kign.org/source/
 

Added: head/audio/ctronome/files/patch-ctronome.h
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/audio/ctronome/files/patch-ctronome.h	Sun Aug 12 08:53:27 2012	(r302428)
@@ -0,0 +1,22 @@
+--- ctronome.h.orig	2012-07-22 15:14:52.000000000 +0400
++++ ctronome.h	2012-07-22 15:15:31.000000000 +0400
+@@ -1,4 +1,6 @@
+ #include <sys/soundcard.h>
++#include <stdint.h>
++
+ #define MYNAME "ctronome"
+ #define VERSION "0.5.3"
+ #define CREDITS "homepage: http://ctronome.kign.org/\n"
+@@ -28,9 +30,9 @@
+            for defaults/limits and required WAV format see README\n"
+ 
+ /* my lazy type definitions */
+-typedef unsigned long int DWORD;
+-typedef unsigned short int WORD;
+-typedef unsigned char BYTE;
++typedef uint32_t DWORD;
++typedef uint16_t WORD;
++typedef uint8_t BYTE;
+ typedef DWORD dword;
+ typedef WORD word;
+ typedef BYTE byte;

Modified: head/audio/ctronome/pkg-descr
==============================================================================
--- head/audio/ctronome/pkg-descr	Sun Aug 12 08:33:10 2012	(r302427)
+++ head/audio/ctronome/pkg-descr	Sun Aug 12 08:53:27 2012	(r302428)
@@ -1,3 +1,3 @@
 A very simple yet powerful programmable console metronome.
 
-WWW:  http://ctronome.kign.org/
+WWW: http://ctronome.kign.org/
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 9 Ruslan Makhmatkhanov freebsd_committer 2012-08-12 10:22:58 UTC
State Changed
From-To: feedback->closed

Committed, thank you!