Bug 170243 - ping(8): useless/uninformative error message
Summary: ping(8): useless/uninformative error message
Status: Closed DUPLICATE of bug 170244
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 9.1-PRERELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-29 06:30 UTC by kes-kes
Modified: 2019-02-20 09:57 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kes-kes 2012-07-29 06:30:01 UTC
# ping 10.11.6.1
PING 10.11.6.1 (10.11.6.1): 56 data bytes
ping: sendto: Invalid argument
ping: sendto: Invalid argument
ping: sendto: Invalid argument
ping: sendto: Invalid argument
^C
--- 10.11.6.1 ping statistics ---
4 packets transmitted, 0 packets received, 100.0% packet loss
# ping 10.11.19.54
PING 10.11.19.54 (10.11.19.54): 56 data bytes
64 bytes from 10.11.19.54: icmp_seq=0 ttl=64 time=0.107 ms
^C
--- 10.11.19.54 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.107/0.107/0.107/0.000 ms
# ping ya.ru
PING ya.ru (213.180.204.3): 56 data bytes
64 bytes from 213.180.204.3: icmp_seq=0 ttl=56 time=29.896 ms
64 bytes from 213.180.204.3: icmp_seq=1 ttl=56 time=29.689 ms
64 bytes from 213.180.204.3: icmp_seq=2 ttl=56 time=29.530 ms
^C
--- ya.ru ping statistics ---
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 29.530/29.705/29.896/0.150 ms
# ping ya.ru
PING ya.ru (213.180.193.3): 56 data bytes
64 bytes from 213.180.193.3: icmp_seq=0 ttl=55 time=31.971 ms
64 bytes from 213.180.193.3: icmp_seq=1 ttl=55 time=32.150 ms
^C
--- ya.ru ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 31.971/32.060/32.150/0.090 ms
root@newflux:/etc # ping 10.11.6.1
PING 10.11.6.1 (10.11.6.1): 56 data bytes
ping: sendto: Invalid argument
^C
--- 10.11.6.1 ping statistics ---
1 packets transmitted, 0 packets received, 100.0% packet loss
# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: icmp_seq=0 ttl=49 time=41.073 ms
64 bytes from 8.8.8.8: icmp_seq=1 ttl=49 time=41.024 ms
^C
--- 8.8.8.8 ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 41.024/41.049/41.073/0.024 ms
# ping 10.5.0.33
PING 10.5.0.33 (10.5.0.33): 56 data bytes
64 bytes from 10.5.0.33: icmp_seq=0 ttl=64 time=0.152 ms
64 bytes from 10.5.0.33: icmp_seq=1 ttl=64 time=0.114 ms
^C
--- 10.5.0.33 ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.114/0.133/0.152/0.019 ms
# ping 10.10.1.40
PING 10.10.1.40 (10.10.1.40): 56 data bytes
ping: sendto: Invalid argument
ping: sendto: Invalid argument
^C
--- 10.10.1.40 ping statistics ---
2 packets transmitted, 0 packets received, 100.0% packet loss
#

# netstat -nr
default            X.X.X.X            UG1         0       93 vlan40
10.0.0.0/8         10.5.0.33          UGS         0       13 vlan40
10.5.0.0/24        10.7.26.2          UGS         0        0 vlan74
10.5.0.17          link#10            UH          0        6    lo0
10.5.0.18          link#10            UH          0        0    lo0 =>
10.5.0.18/32       10.11.19.54        UGS         0        0 vlan40
10.5.0.32/27       link#54            U           0     4608 vlan40
10.5.0.37          link#54            UHS         1       89    lo0
10.10.0.0/16       10.11.19.50        UGS         0       16 vlan40
10.10.15.0/24      10.11.19.52        UGS         0        0 vlan40
10.11.6.0/23       10.11.19.52        UGS         0        5 vlan40
10.11.16.0/24      10.11.19.50        UGS         0        0 vlan40
10.11.19.248/29    10.11.19.52        UGS         0        0 vlan40
10.11.21.0/24      10.11.19.52        UGS         0        0 vlan40
Comment 1 dwmalone 2012-07-29 07:32:14 UTC
> # ping 10.11.19.54

> # netstat -nr
> default            X.X.X.X            UG1         0       93 vlan40
> 10.0.0.0/8         10.5.0.33          UGS         0       13 vlan40
> 10.5.0.0/24        10.7.26.2          UGS         0        0 vlan74
> 10.5.0.17          link#10            UH          0        6    lo0
> 10.5.0.18          link#10            UH          0        0    lo0 =>
> 10.5.0.18/32       10.11.19.54        UGS         0        0 vlan40
> 10.5.0.32/27       link#54            U           0     4608 vlan40
> 10.5.0.37          link#54            UHS         1       89    lo0
> 10.10.0.0/16       10.11.19.50        UGS         0       16 vlan40
> 10.10.15.0/24      10.11.19.52        UGS         0        0 vlan40
> 10.11.6.0/23       10.11.19.52        UGS         0        5 vlan40
> 10.11.16.0/24      10.11.19.50        UGS         0        0 vlan40
> 10.11.19.248/29    10.11.19.52        UGS         0        0 vlan40
> 10.11.21.0/24      10.11.19.52        UGS         0        0 vlan40

I might have read this wrong, but, it looks like the GW for 10.11.19.54
is 10.11.19.52, because of the second last route. However, 10.11.19.52
doesn't look to be a local network (because there is no "link#..."
route), so the GW is invalid. Hence, when ping calls the sendto()
system call, it returns "Invalid argument", because the GW is
invalid.

	David.
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:16 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 3 Andriy Voskoboinyk freebsd_committer 2019-02-20 09:57:57 UTC

*** This bug has been marked as a duplicate of bug 170244 ***