Bug 170352 - java/icedtea-web update to 1.2.1 makes firefox die with SIGBUS
java/icedtea-web update to 1.2.1 makes firefox die with SIGBUS
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Jung-uk Kim
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 17:10 UTC by Dmitry Marakasov
Modified: 2012-08-15 22:04 UTC (History)
0 users

See Also:


Attachments
gecko_sync.diff (4.71 KB, patch)
2012-08-03 21:40 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2012-08-03 17:10:14 UTC
After updating java/icedtea-web to 1.2.1, java applets no longer work: running an applet makes firefox die with SIGBUS moments after an applet was started (can see it's window for a moment, then it dies). Downgrading icedtea-webz to 1.2_2 solved the problem.

How-To-Repeat: Run java applet with icedtea 1.2.1
Comment 1 Edwin Groothuis freebsd_committer 2012-08-03 17:10:24 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-java

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Jan Beich freebsd_committer 2012-08-03 21:40:38 UTC
Dmitry Marakasov <amdmi3@FreeBSD.org> writes:

> After updating java/icedtea-web to 1.2.1, java applets no longer work:
> running an applet makes firefox die with SIGBUS moments after an

Try libxul-10.0.6 from gecko@ repo. If it doesn't help also try the
attached patch.
Comment 3 amdmi3 2012-08-10 01:47:57 UTC
* Jan Beich (jbeich@tormail.org) wrote:

> > After updating java/icedtea-web to 1.2.1, java applets no longer work:
> > running an applet makes firefox die with SIGBUS moments after an
> 
> Try libxul-10.0.6 from gecko@ repo.

It doesn't build:

http://people.freebsd.org/~amdmi3/xul10.log

Same in tinderbox.

-- 
Dmitry Marakasov   .   55B5 0596 FF1E 8D84 5F56  9510 D35A 80DD F9D2 F77D
amdmi3@amdmi3.ru  ..:  jabber: amdmi3@jabber.ru    http://www.amdmi3.ru
Comment 4 dfilter freebsd_committer 2012-08-13 22:28:04 UTC
Author: jkim
Date: Mon Aug 13 21:27:49 2012
New Revision: 302483
URL: http://svn.freebsd.org/changeset/ports/302483

Log:
  Fix web plugin crash with Firefox 14.
  
  PR:		ports/170352
  Obtained from:	IcedTea Project (PR1106)

Added:
  head/java/icedtea-web/files/patch-plugin-icedteanp-IcedTeaNPPlugin.cc   (contents, props changed)
Modified:
  head/java/icedtea-web/Makefile

Modified: head/java/icedtea-web/Makefile
==============================================================================
--- head/java/icedtea-web/Makefile	Mon Aug 13 19:56:30 2012	(r302482)
+++ head/java/icedtea-web/Makefile	Mon Aug 13 21:27:49 2012	(r302483)
@@ -7,6 +7,7 @@
 
 PORTNAME=	icedtea-web
 PORTVERSION=	1.2.1
+PORTREVISION=	1
 CATEGORIES=	java www
 MASTER_SITES=	http://icedtea.classpath.org/download/source/
 

Added: head/java/icedtea-web/files/patch-plugin-icedteanp-IcedTeaNPPlugin.cc
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/java/icedtea-web/files/patch-plugin-icedteanp-IcedTeaNPPlugin.cc	Mon Aug 13 21:27:49 2012	(r302483)
@@ -0,0 +1,17 @@
+--- plugin/icedteanp/IcedTeaNPPlugin.cc	Thu Aug 02 09:11:37 2012 -0400
++++ plugin/icedteanp/IcedTeaNPPlugin.cc	Tue Aug 07 10:59:11 2012 -0400
+@@ -2053,8 +2053,13 @@
+ 
+   //Ensure any unused fields are NULL
+   memset(&browser_functions, 0, sizeof(NPNetscapeFuncs));
++
++  //browserTable->size can be larger than sizeof(NPNetscapeFuncs) (PR1106)
++  size_t copySize = browserTable->size < sizeof(NPNetscapeFuncs) ?
++                    browserTable->size : sizeof(NPNetscapeFuncs);
++
+   //Copy fields according to given size
+-  memcpy(&browser_functions, browserTable, browserTable->size);
++  memcpy(&browser_functions, browserTable, copySize);
+ 
+   return true;
+ }
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 5 Jung-uk Kim freebsd_committer 2012-08-13 22:28:43 UTC
State Changed
From-To: open->feedback

I just committed a fix.  If it doesn't work, please let me know.  Thanks! 


Comment 6 Jung-uk Kim freebsd_committer 2012-08-13 22:28:43 UTC
Responsible Changed
From-To: freebsd-java->jkim

I just committed a fix.  If it doesn't work, please let me know.  Thanks!
Comment 7 Jung-uk Kim freebsd_committer 2012-08-15 22:03:41 UTC
State Changed
From-To: feedback->closed

Several people reported the problem is indeed fixed.