Bug 170568 - New port x11-fonts/sourcesanspro-ttf
Summary: New port x11-fonts/sourcesanspro-ttf
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-12 21:40 UTC by Pedro F. Giffuni
Modified: 2012-08-20 16:40 UTC (History)
0 users

See Also:


Attachments
file.shar (4.21 KB, text/plain)
2012-08-12 21:40 UTC, Pedro F. Giffuni
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro F. Giffuni 2012-08-12 21:40:01 UTC
Adobe has made available an Open source font that is specifically designed for UI and is also very useful for Office suites like Apache OpenOffice.

http://blogs.adobe.com/typblography/2012/08/source-sans-pro.html

I have created an initial port of the TTF versions based on the Chrome cross-core fonts port.

Fix: shar file attached

Patch attached with submission follows:
Comment 1 Pedro F. Giffuni freebsd_committer 2012-08-13 05:31:44 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office@FreeBSD.org

Assign to maintainer
Comment 2 dfilter service freebsd_committer 2012-08-20 16:38:29 UTC
Author: bapt
Date: Mon Aug 20 15:38:18 2012
New Revision: 302806
URL: http://svn.freebsd.org/changeset/ports/302806

Log:
  Source Sans Pro: Adobeâs first open source type family
  
  Source Sans Pro was designed by Paul D. Hunt as Adobe's first open source
  typeface family, conceived primarily as a typeface for user interfaces.
  Source Sans Pro draws inspiration from the clarity and legibility of
  twentieth-century American gothic typeface designs.
  
  Source Sans Pro currently supports a wide range of languages using Latin
  script, and includes all the characters in the Adobe Latin 4 glyph set. As
  an open source project, it is expected that incremental updates will be
  made over time to extend glyph set coverage and functionality.
  
  WWW: http://sourceforge.net/projects/sourcesans.adobe/
  
  PR:		ports/170568
  Submitted by:	pfg@

Added:
  head/x11-fonts/sourcesanspro-ttf/
  head/x11-fonts/sourcesanspro-ttf/Makefile   (contents, props changed)
  head/x11-fonts/sourcesanspro-ttf/distinfo   (contents, props changed)
  head/x11-fonts/sourcesanspro-ttf/files/
  head/x11-fonts/sourcesanspro-ttf/files/pkg-message.in   (contents, props changed)
  head/x11-fonts/sourcesanspro-ttf/pkg-descr   (contents, props changed)
  head/x11-fonts/sourcesanspro-ttf/pkg-plist   (contents, props changed)
Modified:
  head/x11-fonts/Makefile

Modified: head/x11-fonts/Makefile
==============================================================================
--- head/x11-fonts/Makefile	Mon Aug 20 15:36:42 2012	(r302805)
+++ head/x11-fonts/Makefile	Mon Aug 20 15:38:18 2012	(r302806)
@@ -137,6 +137,7 @@
     SUBDIR += sgifonts
     SUBDIR += sharefonts
     SUBDIR += showfont
+    SUBDIR += sourcesanspro-ttf
     SUBDIR += stix-fonts
     SUBDIR += suxus
     SUBDIR += terminus-font

Added: head/x11-fonts/sourcesanspro-ttf/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-fonts/sourcesanspro-ttf/Makefile	Mon Aug 20 15:38:18 2012	(r302806)
@@ -0,0 +1,55 @@
+# New ports collection makefile for:	SourceSansPro-ttf
+# Date created:		11 Aug 2012
+# Whom:			Pedro Giffuni
+#
+# $FreeBSD$
+#
+
+PORTNAME=	sourcesanspro-ttf
+PORTVERSION=	1.033
+CATEGORIES=	x11-fonts
+MASTER_SITES=	SF/sourcesans.adobe
+DISTNAME=	SourceSansPro_FontsOnly-${PORTVERSION}
+
+MAINTAINER=	office@FreeBSD.org
+COMMENT=	A set of fonts by Adobe designed for user interfaces
+
+LICENSE=	OFL
+LICENSE_NAME=	SIL OPEN FONT LICENSE Version 1.1
+LICENSE_FILE=	${WRKSRC}/LICENSE.txt
+LICENSE_PERMS=	auto-accept
+
+BUILD_DEPENDS=	mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale	\
+		mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+
+USE_ZIP=	yes
+USE_XORG=	x11
+
+PLIST_SUB=	FONTDIR="${FONTDIR:S|${PREFIX}/||}"
+
+SUB_FILES=	pkg-message
+PKGMESSAGE=	${WRKDIR}/pkg-message
+SUB_LIST=	FONTDIR=${FONTDIR}
+
+FONTNAME=	SourceSansPro
+FONTDIR=	${PREFIX}/lib/X11/fonts/${FONTNAME}
+INSTDAT=		fonts.dir fonts.scale
+
+MKFONTSCL_CMD=	${LOCALBASE}/bin/mkfontscale
+MKFONTDIR_CMD=	${LOCALBASE}/bin/mkfontdir
+
+do-build:
+	cd ${WRKSRC}/TTF && ${MKFONTSCL_CMD}
+	cd ${WRKSRC}/TTF && ${MKFONTDIR_CMD}
+
+do-install:
+	${MKDIR} ${FONTDIR}
+	cd ${WRKSRC}/TTF &&	\
+	${INSTALL_DATA} ${INSTDAT} *.ttf ${FONTDIR}
+
+post-install:
+	@${ECHO_MSG}
+	@${CAT} ${PKGMESSAGE}
+	@${ECHO_MSG}
+
+.include <bsd.port.mk>

Added: head/x11-fonts/sourcesanspro-ttf/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-fonts/sourcesanspro-ttf/distinfo	Mon Aug 20 15:38:18 2012	(r302806)
@@ -0,0 +1,2 @@
+SHA256 (SourceSansPro_FontsOnly-1.033.zip) = 6d47d19f9e8e0211af24cad254e6fd69af16f2dde8c902516039607c0f213c8d
+SIZE (SourceSansPro_FontsOnly-1.033.zip) = 1372793

Added: head/x11-fonts/sourcesanspro-ttf/files/pkg-message.in
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-fonts/sourcesanspro-ttf/files/pkg-message.in	Mon Aug 20 15:38:18 2012	(r302806)
@@ -0,0 +1,5 @@
+You can start using the fonts by following these instructions:
+
+Add the following line to the "Files" section of your x.org configuration file:
+
+	FontPath "%%FONTDIR%%/"

Added: head/x11-fonts/sourcesanspro-ttf/pkg-descr
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-fonts/sourcesanspro-ttf/pkg-descr	Mon Aug 20 15:38:18 2012	(r302806)
@@ -0,0 +1,13 @@
+Source Sans Pro: Adobeâs first open source type family
+
+Source Sans Pro was designed by Paul D. Hunt as Adobe's first open source 
+typeface family, conceived primarily as a typeface for user interfaces. 
+Source Sans Pro draws inspiration from the clarity and legibility of 
+twentieth-century American gothic typeface designs.
+
+Source Sans Pro currently supports a wide range of languages using Latin 
+script, and includes all the characters in the Adobe Latin 4 glyph set. As 
+an open source project, it is expected that incremental updates will be 
+made over time to extend glyph set coverage and functionality.
+
+WWW: http://sourceforge.net/projects/sourcesans.adobe/

Added: head/x11-fonts/sourcesanspro-ttf/pkg-plist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/x11-fonts/sourcesanspro-ttf/pkg-plist	Mon Aug 20 15:38:18 2012	(r302806)
@@ -0,0 +1,16 @@
+%%FONTDIR%%/SourceSansPro-Black.ttf
+%%FONTDIR%%/SourceSansPro-BlackIt.ttf
+%%FONTDIR%%/SourceSansPro-Bold.ttf
+%%FONTDIR%%/SourceSansPro-BoldIt.ttf
+%%FONTDIR%%/SourceSansPro-ExtraLight.ttf
+%%FONTDIR%%/SourceSansPro-ExtraLightIt.ttf
+%%FONTDIR%%/SourceSansPro-It.ttf
+%%FONTDIR%%/SourceSansPro-Light.ttf
+%%FONTDIR%%/SourceSansPro-LightIt.ttf
+%%FONTDIR%%/SourceSansPro-Regular.ttf
+%%FONTDIR%%/SourceSansPro-Semibold.ttf
+%%FONTDIR%%/SourceSansPro-SemiboldIt.ttf
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || /usr/bin/true
+@dirrm %%FONTDIR%%
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Baptiste Daroussin freebsd_committer 2012-08-20 16:39:17 UTC
State Changed
From-To: open->closed

Committed. Thanks!