Bug 170573 - [iwi] Intel 2200BG iwi NIC hangs with need multicast callback and firmware error
Summary: [iwi] Intel 2200BG iwi NIC hangs with need multicast callback and firmware error
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: wireless (show other bugs)
Version: 8.3-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-wireless (Nobody)
Depends on:
Reported: 2012-08-12 23:10 UTC by Yuval Prag
Modified: 2018-05-28 19:44 UTC (History)
0 users

See Also:

file.txt (8.77 KB, text/plain)
2012-08-12 23:10 UTC, Yuval Prag
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yuval Prag 2012-08-12 23:10:02 UTC
Intel PRO/Wireless 2200BG NIC hangs after initial network is associated
ifconfig show:
iwi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
	ether 00:0e:35:58:d4:23
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
	status: associated
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 00:0e:35:58:d4:23
	inet netmask 0xfffffc00 broadcast
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
	status: associated
	ssid SCUOrientation channel 6 (2437 MHz 11g) bssid e8:04:62:0b:9d:c5
	country US authmode OPEN privacy OFF txpower 0 bmiss 24 scanvalid 60
	protmode CTS wme bintval 102

ping to the router works with intermittent failures
in the form of "sento: Network is down" and than it hangs usually after the
15th packet send... 
a restart the NIC device with "/etc/rc.d/netif restart"
will cause the system to reboot!

the the NIC firmware and driver version driver 1.72 firmware 3.1(from the installation ISO dvd.

dmesg output :
opyright (c) 1992-2012 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 8.3-RELEASE #3: Sun Jul 29 12:09:04 PDT 2012
    yprag1@.scu.edu:/usr/src/sys/i386/compile/GENERIC i386
can't re-use a leaf (ipw)! // from /boot/loader.conf reloaders...
can't re-use a leaf (iwi)!
module_register: module pci/ipw already exists!
Module pci/ipw failed to register: 17
module_register: module pci/iwi already exists!
Module pci/iwi failed to register: 17
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) M processor 1.50GHz (600.02-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x6d6  Family = 6  Model = d  Stepping = 6
real memory  = 1073741824 (1024 MB)
avail memory = 998502400 (952 MB)
ioapic0: Changing APIC ID to 1
ioapic0 <Version 2.0> irqs 0-23 on motherboard
ipw_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
ipw_bss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/load
module_register_init: MOD_LOAD (ipw_bss_fw, 0xc0687190, 0) error 1
ipw_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
ipw_ibss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loa
module_register_init: MOD_LOAD (ipw_ibss_fw, 0xc0687250, 0) error 1
ipw_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
ipw_monitor: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/
module_register_init: MOD_LOAD (ipw_monitor_fw, 0xc0687310, 0) error 1
ispfw: registered firmware <isp_1040>
ispfw: registered firmware <isp_1040_it>
ispfw: registered firmware <isp_1080>
ispfw: registered firmware <isp_1080_it>
ispfw: registered firmware <isp_12160>
acpi_ec0: <Embedded Controller: GPE 0x1c> port 0x62,0x66 on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <base peripheral> at device 0.1 (no driver attached)
pci0: <base peripheral> at device 0.3 (no driver attached)
vgapci0: <VGA-compatible display> port 0xdc00-0xdc07 mem 0xf0000000-0xf7ffffff,0xfeb00000-0xfeb7ffff irq 16 at device 2.0 on pci0
agp0: <Intel 82855GME (855GME GMCH) SVGA controller> on vgapci0
agp0: aperture size is 128M, detected 32636k stolen memory
vgapci1: <VGA-compatible display> mem 0xe8000000-0xefffffff,
0xfea80000-0xfeafffff at de
vice 2.1 on pci0
uhci0: <Intel 82801DB (ICH4) USB controller USB-A> port 0xd480-0xd49f irq 16 at device 29.0 on pci0
uhci0: [ITHREAD]
uhci0: LegSup = 0x2f00
usbus0: <Intel 82801DB (ICH4) USB controller USB-A> on uhci0
uhci1: <Intel 82801DB (ICH4) USB controller USB-B> port 0xd800-0xd81f irq 19 at device 29.1 on pci0
uhci1: [ITHREAD]
uhci1: LegSup = 0x2f00
usbus1: <Intel 82801DB (ICH4) USB controller USB-B> on uhci1
uhci2: <Intel 82801DB (ICH4) USB controller USB-C> port 0xd880-0xd89f irq 18 at device 29.2 on pci0
uhci2: [ITHREAD]
uhci2: LegSup = 0x2f00
usbus2: <Intel 82801DB (ICH4) USB controller USB-C> on uhci2
ehci0: <Intel 82801DB/L/M (ICH4) USB 2.0 controller> mem 0xfebff800-0xfebffbff irq 23 at device 29.7 on pci0
ehci0: [ITHREAD]
usbus3: EHCI version 1.0
usbus3: <Intel 82801DB/L/M (ICH4) USB 2.0 controller> on ehci0
pcib1: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci1: <ACPI PCI bus> on pcib1
iwi0: <Intel(R) PRO/Wireless 2200BG> mem 0xfe8fd000-0xfe8fdfff irq 18 at device 4.0 on pci1
iwi0: [ITHREAD]
cbb0: <RF5C475 PCI-CardBus Bridge> at device 5.0 on pci1
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
cbb0: [FILTER]
fwohci0: <Ricoh R5C551> mem 0xfe8ff000-0xfe8ff7ff irq 16 at device 5.1 on pci1
fwohci0: [ITHREAD]
fwohci0: OHCI version 1.0 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:e0:18:00:03:1e:09:af
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:e0:18:1e:09:af
fwe0: Ethernet address: 02:e0:18:1e:09:af
fwip0: <IP over FireWire> on firewire0
fwip0: Firewire address: 00:e0:18:00:03:1e:09:af @ 0xfffe00000000, S400, maxrec 2048
sbp0: <SBP-2/SCSI over FireWire> on firewire0
dcons_crom0: <dcons configuration ROM> on firewire0
dcons_crom0: bus_addr 0x14ac000
fwohci0: Initiate bus reset
fwohci0: fwohci_intr_core: BUS reset
fwohci0: fwohci_intr_core: node_id=0x00000000, SelfID Count=1, CYCLEMASTER mode
fxp0: <Intel 82801DB (ICH4) Pro/100 VM Ethernet> port 0xcc00-0xcc3f mem 0xfe8fe000-0xfe8fefff irq 20 at device 8.0 on pci1
miibus0: <MII bus> on fxp0
inphy0: <i82562EM 10/100 media interface> PHY 1 on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto, auto-flow
fxp0: Ethernet address: 00:11:2f:58:1d:63
fxp0: [ITHREAD]
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH4 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 31.
1 on pci0
ata0: <ATA channel> at channel 0 on atapci0
ata0: [ITHREAD]
ata1: <ATA channel> at channel 1 on atapci0
ata1: [ITHREAD]
pcm0: <Intel ICH4 (82801DB)> port 0xe000-0xe0ff,0xe100-0xe13f at device 31.5 on pci0
pcm0: [ITHREAD]
pcm0: <SigmaTel STAC9750/51 AC97 Codec>
pci0: <simple comms, generic modem> at device 31.6 (no driver attached)
acpi_button0: <Sleep Button> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
acpi_acad0: <AC Adapter> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
battery1: <ACPI Control Method Battery> on acpi0
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [ITHREAD]
psm0: model Generic PS/2 mouse, device ID 0
ppc0: <Parallel port> port 0x378-0x37f,0x778-0x77f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppc0: [ITHREAD]
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
plip0: [ITHREAD]
lpt0: [ITHREAD]
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xccfff,0xcd000-0xce7ff pnpid ORM0000 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
uart1: <16550 or compatible> at port 0x2f8-0x2ff irq 3 on isa0
uart1: [FILTER]
est0: <Enhanced SpeedStep Frequency Control> on cpu0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
Timecounter "TSC" frequency 600024231 Hz quality 800
Timecounters tick every 1.000 msec
firewire0: 1 nodes, maxhop <= 0 cable IRM irm(0)  (me)
firewire0: bus manager 0
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
usbus2: 12Mbps Full Speed USB v1.0
usbus3: 480Mbps High Speed USB v2.0
ugen0.1: <Intel> at usbus0
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <Intel> at usbus1
uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
ugen2.1: <Intel> at usbus2
uhub2: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus2
ugen3.1: <Intel> at usbus3
uhub3: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus3
ad0: 38204MB <SAMSUNG MP0402H UC100-11> at ata0-master UDMA100
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub2: 2 ports with 2 removable, self powered
acd0: DVDR <MATSHITADVD-RAM UJ-810/C100> at ata1-master UDMA33
uhub3: 6 ports with 6 removable, self powered
Trying to mount root from ufs:/dev/ad0s1a
wlan0: Ethernet address: 00:0e:35:58:d4:23
iwi0: need multicast update callback
iwi0: need multicast update callback
iwi0: need multicast update callback
iwi0: firmware error

Fix: Patch attached with submission follows:
How-To-Repeat: ping the router and or try to /etc/rc.d/netif restart"
will cause the system to reboot!
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2012-08-27 02:29:39 UTC
Responsible Changed
From-To: freebsd-i386->freebsd-wireless

Comment 2 Yuval Prag 2012-09-11 19:32:35 UTC
Hi See attached updates for the PR in the subject

I have tried to use the latest NIC driver from the repository 1.72.6 and I
still have the same error end the device file to connect reliably to the
see attached files with error messages and some instrumentation I added to
stop the printing because it polluted the /var/log/messages with the errors

if there is any other way of updating the PR please explain how
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:44:49 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
- Untouched since 2018-01-01.
- Affects Base System OR Documentation


Reset to open status.

I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.