Bug 170766 - High CPU load caused by net-p2p/libtorrent
High CPU load caused by net-p2p/libtorrent
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: flz
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 11:10 UTC by yamagi
Modified: 2012-10-15 13:54 UTC (History)
0 users

See Also:


Attachments
file.txt (506 bytes, text/plain)
2012-08-19 11:10 UTC, yamagi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description yamagi 2012-08-19 11:10:08 UTC
As noted in ports/169734 net-p2p/libtorrent ha a bug, causing it to generate a lot of CPU load on FreeBSD. The problem is easy to fix and an pull request has been send upstream: https://github.com/rakshasa/libtorrent/pull/21

Fix: As said above, a pull request has been send upstream: https://github.com/rakshasa/libtorrent/pull/21 I request to add the attached patch (exatly the same change as in the pull request) to net-p2p/libtorrent until the problem is solved upstream. 

Patch attached with submission follows:
How-To-Repeat: Use a consumer of net-p2p/libtorrent (for example net-p2p/rtorrent) on FreeBSD. After some seconds it's CPU load will rise up to several hundred percent.
Comment 1 Edwin Groothuis freebsd_committer 2012-08-19 11:10:21 UTC
Responsible Changed
From-To: freebsd-ports-bugs->flz

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 mickael.maillot 2012-10-15 13:22:52 UTC
i confirm: the patch fix the issue on FreeBSD 9.0 amd64
without it, rtorrent is unusable (200% cpu all the time).
Comment 3 Andrej Zverev freebsd_committer 2012-10-15 13:54:09 UTC
State Changed
From-To: open->closed

Committed. Thanks!