Bug 170776 - textproc/libmrss fix for php
textproc/libmrss fix for php
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: clsung
Depends on:
  Show dependency treegraph
Reported: 2012-08-20 02:50 UTC by rodrigo
Modified: 2012-12-05 17:16 UTC (History)
0 users

See Also:

libmrss.patch (1.08 KB, patch)
2012-08-20 02:50 UTC, rodrigo
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rodrigo 2012-08-20 02:50:12 UTC
	Attached to this PR a patch to fix the broken state of the port. 
	This PR only fix the PHP issue and don't resolve the other warnings reported by portlint.

	This issue seems to be caused by the use of function_entry who seems to be deprecate for
	php 5.4 and later and must be replaced by zend_function_entry. Some forums point this
	URL as an explanation : https://bugs.php.net/bug.php?id=60016
	I'll propagate the fix upstream for the future versions but, imho, the following patch must be 
	commited to unbroke the port.
Comment 1 Edwin Groothuis freebsd_committer 2012-08-20 02:50:23 UTC
Responsible Changed
From-To: freebsd-ports-bugs->clsung

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 rodrigo 2012-11-19 17:48:10 UTC

After a little discussion with bapt@ He suggest me to cut this port,
a simple libmrss port without php (less dependencies) and libmrss-php
if you plan to use it with php.

Meanwhile, this PR can be closed without action.

- rodrigo
Comment 3 Baptiste Daroussin freebsd_committer 2012-12-05 17:16:37 UTC
State Changed
From-To: open->closed

Committed. Thanks!