Bug 171291 - lang/squeak 4.4.7_2 - invalid UTF8 - UTF8TextConverter class>> errorMalFormedInput:
Summary: lang/squeak 4.4.7_2 - invalid UTF8 - UTF8TextConverter class>> errorMalForme...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-03 20:30 UTC by Patrick Dudjalija
Modified: 2012-09-29 18:53 UTC (History)
0 users

See Also:


Attachments
ports-171291.patch (2.16 KB, patch)
2012-09-10 04:55 UTC, Takeshi MUTOH
no flags Details | Diff
file.dat (149 bytes, text/plain; charset=us-ascii)
2012-09-10 04:55 UTC, Takeshi MUTOH
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Dudjalija 2012-09-03 20:30:21 UTC
Using system Browser, if you select Form class, you get following error : 
" invalid utf-8"
UTF8TextConverter class(Object) >> error:
UTF8TextConverter class>> errorMalFormedInput:

How-To-Repeat: - start the image Squeak4.3.image
- open browser
- find class : "Form"
- when you select the class Form, you get the error : " invalid utf-8"
UTF8TextConverter class(Object) >> error:
UTF8TextConverter class>> errorMalFormedInput:

NB: the problem doesn't exist with the image Pharo-1.4.image.
Comment 1 Edwin Groothuis freebsd_committer 2012-09-03 22:58:15 UTC
Maintainer of lang/squeak,

Please note that PR ports/171291 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/171291

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2012-09-03 22:58:18 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Takeshi MUTOH 2012-09-06 06:09:10 UTC
Hi!

I'm a maintainer of lang/squeak. 
Thank you for your bug report about lang/squeak.
I'm sorry for your inconvenience.

Now I check where is the problem.

I check VM below, but there is no problem.
- Version 4.3 at MacOS X 
-- http://ftp.squeak.org/4.3/Squeak-4.3-All-in-One.zip
- 4.4.7-2357 VM at Debian Linux 
- 4.4.7-2357 VM at FreeBSD http://squeakvm.org/
-- http://squeakvm.org/unix/release/Squeak-4.4.7.2375-freebsd8.2_i386.tar.gz

So I think this  occur at FreeBSD ports lang/squeak VM only.

Furthermore I check some depended library, for example libiconv.
But I can't find where the problem is.

So I need some more time to fix this problem
Please use http://squeakvm.org/ VM.

If you have some more information or patches, please send it to me.

Thanks in advance.
--
Takeshi MUTOH <mutoh@openedu.org>
Comment 4 Takeshi MUTOH 2012-09-10 04:55:28 UTC
I'm a maintainer of lang/squeak.

A corrupted SqueakV41.sources.gz causes this problem.
See also
- http://lists.squeakfoundation.org/pipermail/vm-dev/2012-September/011237.html

So, I make patch to fix related SqueakV41.sources.
Please commit patch below:
Comment 5 Ruslan Makhmatkhanov freebsd_committer 2012-09-29 18:38:43 UTC
Responsible Changed
From-To: freebsd-ports-bugs->rm

I will take it.
Comment 6 dfilter service freebsd_committer 2012-09-29 18:41:05 UTC
Author: rm
Date: Sat Sep 29 17:40:53 2012
New Revision: 305039
URL: http://svn.freebsd.org/changeset/ports/305039

Log:
  - fix runtime error by using correct SqueakV41 image
  
  PR:		171291
  Submitted by:	Takeshi MUTOH <mutoh at openedu dot org> (maintainer)
  Reported by:	Patrick Dudjalija <patrick.dudjalija at gmail dot com>

Modified:
  head/lang/squeak/Makefile
  head/lang/squeak/distinfo

Modified: head/lang/squeak/Makefile
==============================================================================
--- head/lang/squeak/Makefile	Sat Sep 29 14:37:49 2012	(r305038)
+++ head/lang/squeak/Makefile	Sat Sep 29 17:40:53 2012	(r305039)
@@ -1,21 +1,18 @@
-# New ports collection makefile for:   	squeak
-# Date created:        			12 October 2001
-# Whom:                			roland.jesse@gmx.net
-#
+# Created by: roland.jesse@gmx.net
 # $FreeBSD$
-#
 
 PORTNAME=		squeak
 PORTVERSION=		4.4.7
-PORTREVISION=		2
+PORTREVISION=		3
 CATEGORIES=		lang
 ##################################################
 MASTER_SITES=		http://www.squeakvm.org/unix/release/:vmsrc \
 			http://ftp.squeak.org/${IMAGEVERSION}/:src \
+			ftp://squeak.org/4.1/:sqsrc \
 			http://squeak.610t.org/patches/:mainsrc
 DISTFILES=		Squeak-${VM_VERSION}-src${EXTRACT_SUFX}:mainsrc \
 			Squeak${IMAGEVERSION}.zip:src \
-			SqueakV41.sources:vmsrc
+			${SQUEAK_SRC}.gz:sqsrc
 EXTRACT_ONLY=		Squeak-${VM_VERSION}-src${EXTRACT_SUFX}
 
 ##################################################
@@ -38,6 +35,7 @@ LIB_DEPENDS=		audio:${PORTSDIR}/audio/na
 VM_VERSION=		${PORTVERSION}.${SVNVERSION}
 SVNVERSION=		2383
 IMAGEVERSION=		4.3
+SQUEAK_SRC=		SqueakV41.sources
 SQUEAK_LIB_DIR=		${PORTVERSION}-${SVNVERSION}
 
 .include <bsd.port.pre.mk>
@@ -93,7 +91,7 @@ pre-configure:
 
 ##################################################
 post-install:
-	(cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} SqueakV41.sources ${PREFIX}/lib/squeak/${SQUEAK_LIB_DIR}/)
+	(cd ${DISTDIR}/${DIST_SUBDIR} && ${GUNZIP_CMD} ${SQUEAK_SRC}.gz && ${INSTALL_DATA} ${SQUEAK_SRC} ${PREFIX}/lib/squeak/${SQUEAK_LIB_DIR}/)
 	(cd ${DISTDIR}/${DIST_SUBDIR} && ${UNZIP_CMD} -u Squeak${IMAGEVERSION}.zip -d ${WRKDIR})
 .for f in ${IMAGES}
 	(cd ${WRKDIR} && ${INSTALL_DATA} ${f} ${PREFIX}/lib/squeak/)

Modified: head/lang/squeak/distinfo
==============================================================================
--- head/lang/squeak/distinfo	Sat Sep 29 14:37:49 2012	(r305038)
+++ head/lang/squeak/distinfo	Sat Sep 29 17:40:53 2012	(r305039)
@@ -2,5 +2,5 @@ SHA256 (squeak/Squeak-4.4.7.2383-src.tar
 SIZE (squeak/Squeak-4.4.7.2383-src.tar.gz) = 3585774
 SHA256 (squeak/Squeak4.3.zip) = 318ee202b10c7d0c2875dd44f121e299904d164acd3a7ff2c90d8818847b2a67
 SIZE (squeak/Squeak4.3.zip) = 8689484
-SHA256 (squeak/SqueakV41.sources) = 1e92730f6221ced584e0050844abec1bd69848b7963a6cbf3a67986b1ad6553c
-SIZE (squeak/SqueakV41.sources) = 6641435
+SHA256 (squeak/SqueakV41.sources.gz) = 1e92730f6221ced584e0050844abec1bd69848b7963a6cbf3a67986b1ad6553c
+SIZE (squeak/SqueakV41.sources.gz) = 6641435
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 7 Ruslan Makhmatkhanov freebsd_committer 2012-09-29 18:53:08 UTC
State Changed
From-To: feedback->closed

Committed, thank you!