Bug 171544 - net/openvswitch: Update to latest release 1.7.1
net/openvswitch: Update to latest release 1.7.1
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Bryan Drewery
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 16:20 UTC by Ed Maste
Modified: 2012-09-11 18:30 UTC (History)
0 users

See Also:


Attachments
openvswitch-1.7.1.diff (3.13 KB, patch)
2012-09-11 16:20 UTC, Ed Maste
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2012-09-11 16:20:02 UTC
Upstream released 1.7.1.

Also correct a mistake in the bsd port patch (a fix was in the experimental
threading patch, not the base BSD patch) that prevented building with clang.

Also add a regression-test target.
Comment 1 Edwin Groothuis freebsd_committer 2012-09-11 16:20:20 UTC
Responsible Changed
From-To: freebsd-ports-bugs->emaste

Submitter is maintainer and has GNATS access (via the GNATS Auto Assign 
Tool)
Comment 2 Bryan Drewery freebsd_committer 2012-09-11 17:42:24 UTC
Responsible Changed
From-To: emaste->bdrewery

I'll take it.
Comment 3 Bryan Drewery freebsd_committer 2012-09-11 18:25:07 UTC
State Changed
From-To: open->closed

Committed. Thanks!
Comment 4 dfilter freebsd_committer 2012-09-11 18:25:11 UTC
Author: bdrewery
Date: Tue Sep 11 17:24:59 2012
New Revision: 304110
URL: http://svn.freebsd.org/changeset/ports/304110

Log:
  - Update to 1.7.1
  - Add a regression-test target, but leave it commented
    out for now as it is failing
  - Fix build with clang
  
  PR:		ports/171544
  Submitted by:	emaste (maintainer)

Modified:
  head/net/openvswitch/Makefile
  head/net/openvswitch/distinfo
  head/net/openvswitch/files/patch-bsd-netdev.diff
  head/net/openvswitch/files/threaded.diff

Modified: head/net/openvswitch/Makefile
==============================================================================
--- head/net/openvswitch/Makefile	Tue Sep 11 16:56:45 2012	(r304109)
+++ head/net/openvswitch/Makefile	Tue Sep 11 17:24:59 2012	(r304110)
@@ -6,7 +6,7 @@
 #
 
 PORTNAME=	openvswitch
-PORTVERSION=	1.7.0
+PORTVERSION=	1.7.1
 CATEGORIES=	net
 MASTER_SITES=	http://openvswitch.org/releases/
 
@@ -46,8 +46,8 @@ CONFIGURE_ARGS+=--enable-threaded=yes
 AUTOTOOLSFILES=	aclocal.m4
 
 post-patch:
-	@${REINPLACE_CMD} -e 's|1.11.1|%%AUTOMAKE_APIVER%%|g' \
-			  -e 's|2.65|%%AUTOCONF_VERSION%%|g' \
+	@${REINPLACE_CMD} -e 's|1.11.3|%%AUTOMAKE_APIVER%%|g' \
+			  -e 's|2.68|%%AUTOCONF_VERSION%%|g' \
 			  ${WRKSRC}/aclocal.m4
 .if ${PORT_OPTIONS:MTHREADED}
 	@# We can't use EXTRA_PATCHES, since we need to apply this one
@@ -58,4 +58,7 @@ post-patch:
 post-install:
 	${INSTALL_DATA} ${WRKSRC}/vswitchd/vswitch.ovsschema ${PREFIX}/share/openvswitch/
 
+#regression-test: build
+#	@cd ${WRKSRC} && ${GMAKE} check
+
 .include <bsd.port.post.mk>

Modified: head/net/openvswitch/distinfo
==============================================================================
--- head/net/openvswitch/distinfo	Tue Sep 11 16:56:45 2012	(r304109)
+++ head/net/openvswitch/distinfo	Tue Sep 11 17:24:59 2012	(r304110)
@@ -1,2 +1,2 @@
-SHA256 (openvswitch-1.7.0.tar.gz) = 8e3942cbce80048fb2ce8077be5d35bbe50bb12a1feba33d7c1db68ce711eb53
-SIZE (openvswitch-1.7.0.tar.gz) = 2154289
+SHA256 (openvswitch-1.7.1.tar.gz) = a31fdae8400e9a1af89bd9031c83de15d4ba6dc2fb3ff92e5bf772577fa1c882
+SIZE (openvswitch-1.7.1.tar.gz) = 2153423

Modified: head/net/openvswitch/files/patch-bsd-netdev.diff
==============================================================================
--- head/net/openvswitch/files/patch-bsd-netdev.diff	Tue Sep 11 16:56:45 2012	(r304109)
+++ head/net/openvswitch/files/patch-bsd-netdev.diff	Tue Sep 11 17:24:59 2012	(r304110)
@@ -2468,7 +2468,7 @@ new file mode 100644
 index 0000000..c145091
 --- /dev/null
 +++ lib/route-table-bsd.c
-@@ -0,0 +1,129 @@
+@@ -0,0 +1,131 @@
 +/*
 + * Copyright (c) 2012 Ed Maste. All rights reserved.
 + *
@@ -2500,6 +2500,8 @@ index 0000000..c145091
 +#include <string.h>
 +#include <unistd.h>
 +
++#include "vlog.h"
++
 +VLOG_DEFINE_THIS_MODULE(route_table);
 +
 +static int pid;

Modified: head/net/openvswitch/files/threaded.diff
==============================================================================
--- head/net/openvswitch/files/threaded.diff	Tue Sep 11 16:56:45 2012	(r304109)
+++ head/net/openvswitch/files/threaded.diff	Tue Sep 11 17:24:59 2012	(r304110)
@@ -453,7 +453,7 @@ index cade79e..509e2ef 100644
 @@ -1003,7 +1209,12 @@ dp_netdev_port_input(struct dp_netdev *dp, struct dp_netdev_port *port,
          return;
      }
-     flow_extract(packet, 0, 0, port->port_no, &key);
+     flow_extract(packet, 0, 0, odp_port_to_ofp_port(port->port_no), &key);
 +#ifdef THREADED
 +    pthread_mutex_lock(&dp->table_mutex);
 +    flow = dp_netdev_lookup_flow_locked(dp, &key);
@@ -1205,19 +1205,6 @@ index 4b86c21..4fad796 100644
  int netdev_drain(struct netdev *);
  
  int netdev_send(struct netdev *, const struct ofpbuf *);
-diff --git lib/route-table-bsd.c lib/route-table-bsd.c
-index c145091..1c29071 100644
---- lib/route-table-bsd.c
-+++ lib/route-table-bsd.c
-@@ -29,6 +29,8 @@
- #include <string.h>
- #include <unistd.h>
- 
-+#include "vlog.h"
-+
- VLOG_DEFINE_THIS_MODULE(route_table);
- 
- static int pid;
 diff --git lib/vlog.c lib/vlog.c
 index 899072e..b6bd4ef 100644
 --- lib/vlog.c
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"