Bug 171588 - editors/libreoffice build error
Summary: editors/libreoffice build error
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-13 03:10 UTC by Sergey A. Osokin
Modified: 2014-08-26 06:33 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey A. Osokin freebsd_committer 2012-09-13 03:10:01 UTC
% ident Makefile
Makefile:
     $FreeBSD: ports/editors/libreoffice/Makefile,v 1.66 2012/09/12 16:41:31 jkim Exp $


editors/libreoffice build error:

..
        /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/solenv/bin/createcomponent.xslt lnth.component
/usr/local/bin/xsltproc --nonet --stringparam uri \
        'vnd.sun.star.expand:$LO_LIB_DIR/libspelllo.so' -o ../../../unxfbsd.pro/misc/spell.component \
        /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/solenv/bin/createcomponent.xslt spell.component
Compiling: lingucomponent/source/languageguessing/altstrfunc.cxx
Compiling: lingucomponent/source/languageguessing/guess.cxx
Compiling: lingucomponent/source/languageguessing/guesslang.cxx
Compiling: lingucomponent/source/languageguessing/simpleguesser.cxx
/usr/local/bin/xsltproc --nonet --stringparam uri \
        'vnd.sun.star.expand:$LO_LIB_DIR/libguesslanglo.so' -o ../../unxfbsd.pro/misc/guesslang.component \
        /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/solenv/bin/createcomponent.xslt guesslang.component
Making:    guesslang.lib
Making:    libguesslanglo.so
Making:    spell.lib
Making:    libspelllo.so
Making:    hyphen_lib.lib
Making:    libhyphenlo.so
: ERROR: /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/solver/unxfbsd.pro/lib/liblnglo.so: Undefined symbol "_ZN4cppu15WeakImplHelper6IN3com3sun4star8document7XFilterENS3_4lang12XServiceInfoENS4_9XExporterENS6_15XInitializationENS3_9container6XNamedENS6_10XUnoTunnelEE14queryInterfaceERKNS3_3uno4TypeE"
dmake:  Error code 1, while making '../../../unxfbsd.pro/lib/libspelllo.so'
: ERROR: /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/solver/unxfbsd.pro/lib/liblnglo.so: Undefined symbol "_ZN4cppu15WeakImplHelper6IN3com3sun4star8document7XFilterENS3_4lang12XServiceInfoENS4_9XExporterENS6_15XInitializationENS3_9container6XNamedENS6_10XUnoTunnelEE14queryInterfaceERKNS3_3uno4TypeE"
dmake:  Error code 1, while making '../../../../unxfbsd.pro/lib/libhyphenlo.so'
Making:    lnth.lib
Making:    liblnthlo.so
: ERROR: /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/solver/unxfbsd.pro/lib/liblnglo.so: Undefined symbol "_ZN4cppu15WeakImplHelper6IN3com3sun4star8document7XFilterENS3_4lang12XServiceInfoENS4_9XExporterENS6_15XInitializationENS3_9container6XNamedENS6_10XUnoTunnelEE14queryInterfaceERKNS3_3uno4TypeE"
dmake:  Error code 1, while making '../../../unxfbsd.pro/lib/liblnthlo.so'

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development


  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/lingucomponent/source/spellcheck/spell
ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/lingucomponent/source/hyphenator/altlinuxhyph/hyphen
ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/lingucomponent/source/thesaurus/libnth
ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/connectivity/source/drivers/odbcbase
ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/vcl/prj
ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/connectivity/source/drivers/file

 it seems you are using a threaded build, which means that the
 actual compile error is probably hidden far above, and could be
 inside any of these other modules:
     vcl lingucomponent
 please re-run build inside each one to isolate the problem.
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2
source ./Env.Host.sh
cd connectivity
rm -Rf /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/connectivity/unxfbsd.pro # optional module 'clean'
build

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Ошибка 1
gmake[1]: Выход из каталога `/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2'
gmake: *** [source-env-and-recurse] Ошибка 2
*** [do-build] Error code 1

Stop in /usr/ports/editors/libreoffice.
*** [build] Error code 1

Stop in /usr/ports/editors/libreoffice.

How-To-Repeat: cd /usr/ports/editors/libreoffice && make
Comment 1 Edwin Groothuis freebsd_committer 2012-09-13 03:10:16 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Jung-uk Kim freebsd_committer 2012-09-13 20:45:28 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

> : ERROR:
> /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/solver/unxfbsd.pro/lib/liblnglo.so:
> Undefined symbol
> "_ZN4cppu15WeakImplHelper6IN3com3sun4star8document7XFilterENS3_4lang12XServiceInfoENS4_9XExporterENS6_15XInitializationENS3_9container6XNamedENS6_10XUnoTunnelEE14queryInterfaceERKNS3_3uno4TypeE"
>
> 
dmake: Error code 1, while making '../../../unxfbsd.pro/lib/libspelllo.so'
> : ERROR:
> /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/solver/unxfbsd.pro/lib/liblnglo.so:
> Undefined symbol
> "_ZN4cppu15WeakImplHelper6IN3com3sun4star8document7XFilterENS3_4lang12XServiceInfoENS4_9XExporterENS6_15XInitializationENS3_9container6XNamedENS6_10XUnoTunnelEE14queryInterfaceERKNS3_3uno4TypeE"
>
> 
dmake: Error code 1, while making
'../../../../unxfbsd.pro/lib/libhyphenlo.so'
> Making: lnth.lib Making: liblnthlo.so : ERROR:
> /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/solver/unxfbsd.pro/lib/liblnglo.so:
> Undefined symbol
> "_ZN4cppu15WeakImplHelper6IN3com3sun4star8document7XFilterENS3_4lang12XServiceInfoENS4_9XExporterENS6_15XInitializationENS3_9container6XNamedENS6_10XUnoTunnelEE14queryInterfaceERKNS3_3uno4TypeE"
>
> 
dmake: Error code 1, while making '../../../unxfbsd.pro/lib/liblnthlo.so'

It looks like a visibility issue.  Can you please show me the following?

clang --version
sysctl kern.osreldate

Also, it'll be nice if you can put the
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.6.2/config.log
somewhere
(e.g., freefall) so that I can see it.

Thanks,

Jung-uk Kim
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAlBSN9cACgkQmlay1b9qnVNMDwCfdfzHfIgmecGgfTPVChcfd3xy
OBEAoLHCdYtrsmS7vzaOcqcoWYFmLSQg
=a0I/
-----END PGP SIGNATURE-----
Comment 3 Sergey A. Osokin freebsd_committer 2012-09-14 04:20:14 UTC
Yes, please.

% clang --version
FreeBSD clang version 3.1 (branches/release_31 156863) 20120523
Target: x86_64-unknown-freebsd9.0
Thread model: posix

% sysctl kern.osreldate
kern.osreldate: 900506

http://people.freebsd.org/~osa/config.log

-- 
Sergey A. Osokin
osa@FreeBSD.org
Comment 4 Baptiste Daroussin freebsd_committer 2014-08-26 06:33:42 UTC
This has been fixed in newer versions