Bug 171645 - [PATCH] devel/py-ice: Allow building using Clang, general overhaul
Summary: [PATCH] devel/py-ice: Allow building using Clang, general overhaul
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-14 18:50 UTC by Michael Gmelin
Modified: 2012-10-27 21:02 UTC (History)
0 users

See Also:


Attachments
py27-Ice-3.4.2_3.patch (25.48 KB, patch)
2012-09-14 18:50 UTC, Michael Gmelin
no flags Details | Diff
py27-Ice-3.4.2_3.patch (26.09 KB, patch)
2012-09-28 11:23 UTC, Michael Gmelin
no flags Details | Diff
py27-Ice-3.4.2_3.patch.gz (5.09 KB, application/x-gzip)
2012-09-28 11:50 UTC, Michael Gmelin
no flags Details
py27-Ice-3.4.2_3.patch.gz (5.09 KB, application/x-gzip)
2012-10-06 00:45 UTC, Michael Gmelin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Gmelin 2012-09-14 18:50:10 UTC
Fixes and enhancements:
- The port didn't respect CC, CXX, CXX, therefore building with Clang
  wasn't possible, use Make.rules.FreeBSD from devel/ice, so they work
  the same (also include a sed command form devel/ice). This way they
  should build using exactly the same settings on the same machine
- Make the port use new style options/option dialog. Note that the
  OPTIONSFILE directive is absolutely necessary to make this work, to
  work around a bug in the ports infrastructure
  As part of this the indentation level of Makefile increased, which
  makes the change look bigger than it actually is
- Patches to make Ice python unit tests work correctly, including a
  workaround so they also work when run in a jail
  (see also http://www.zeroc.com/forums/patches/5815-improvements-python-unit-tests-fix-encoding-freebsd-jail-support.html)
- Make the port run python unit tests by default (can be disabled
  using the TESTS option from the menu)
- Remove unnecessary -g flag when building a debug version (ports does
  this anyway, so you would end up using -g -g)
- Silence post-patch commands, as those look really scary (to the user
  they appear as part of the patch phase of the build)
- Compile and install .pyc and .pyo files (using python's compileall.py).
  That's the way most major python ports do it these days.
- Since so many parts of the port had been touched already, I also
  renamed the patches to comply to the naming conventions in the
  Porter's Handbook
  (http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/makefile-distfiles.html#PORTING-PATCHFILES)

I hope this all makes sense, please contact me in case of questions.

Added file(s):
- files/Make.rules.FreeBSD
- files/patch-config-Make.common.rules
- files/patch-py-config-Make.rules
- files/patch-py-python-Makefile
- files/patch-py-test-Ice-info-AllTests.py
- files/patch-py-test-Ice-properties-run.py

Removed file(s):
- files/patch-config+Make.common.rules
- files/patch-cpp+config+Make.rules.FreeBSD
- files/patch-py+config+Make.rules
- files/patch-py+python+Makefile

Generated with FreeBSD Port Tools 0.99_6 (mode: change, diff: suffix)

Fix: Apply patch.
How-To-Repeat: Set CXX=clang++ in make.conf. Try to build. Gcc will be used.
Comment 1 Edwin Groothuis freebsd_committer 2012-09-14 18:50:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-python

freebsd-python@ wants this port PRs (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2012-09-14 18:50:31 UTC
Maintainer of devel/py-ice,

Please note that PR ports/171645 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/171645

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Edwin Groothuis freebsd_committer 2012-09-14 18:50:35 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 4 tonymaher 2012-09-28 09:44:28 UTC
Hello,

the patch file files/patch-py-test-Ice-properties-run.py appears to have weird characters
in the ConfigPath setting so cannot test.

cheers
-- 
Tony Maher                    email: tonymaher@optusnet.com.au
Comment 5 Michael Gmelin 2012-09-28 11:23:06 UTC
On Fri, 28 Sep 2012 18:44:28 +1000
Tony Maher <tonymaher@optusnet.com.au> wrote:

> Hello,
> the patch file files/patch-py-test-Ice-properties-run.py appears to
> have weird characters in the ConfigPath setting so cannot test.
> cheers


Hi Tony,

These weird characters are UTF-8 and part of the source code (it comes
from upstream). Since the unit test is about verifying that UTF-8 works
okay, they can't be removed (and shouldn't).

It seems like that the patch got mangled in submission (porttools or
one of the editors involved)

Please find attached the patch again, I made sure that utf-8 characters
are preserved), let hope that works ok. If there are further issues, I
could also send the patch directly to you in gzipped format.

Sorry for any inconvenience caused by this.

Michael


-- 
Michael Gmelin
Comment 6 Michael Gmelin 2012-09-28 11:50:14 UTC
On Fri, 28 Sep 2012 18:44:28 +1000
Tony Maher <tonymaher@optusnet.com.au> wrote:

> Hello,
> the patch file files/patch-py-test-Ice-properties-run.py appears to
> have weird characters in the ConfigPath setting so cannot test.
> cheers


Since it seems like the patch got mangled again, please find attach a
gzipped version that should work ok.

Michael



-- 
Michael Gmelin
Comment 7 Michael Gmelin 2012-09-28 12:18:57 UTC
On Fri, 28 Sep 2012 18:44:28 +1000
Tony Maher <tonymaher@optusnet.com.au> wrote:

> Hello,
> the patch file files/patch-py-test-Ice-properties-run.py appears to
> have weird characters in the ConfigPath setting so cannot test.
> cheers

And yet another followup (hopefully the last one): Downloading the gz
from the PR gives me something garbled (not a valid gz). The way I
extracted the patch from the page is by copy and pasting the base r64
block into a file and pipe that into:

openssl enc -d -a | gunzip >py27-Ice-3.4.2_3.patch

To me it seems like there is something broken with the way patches are
handled in the PR system - and that it worked ok in the past.

So here for convenience, this is how to get a working patch:

openssl enc -d -a >py27-Ice-3.4.2_3.patch.gz << "EOF"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EOF

gunzip py27-Ice-3.4.2_3.patch.gz

Again, sorry for the inconvenience, I'm not really sure why this is
happening :(

Cheer,
Michael


-- 
Michael Gmelin
Comment 8 Michael Gmelin 2012-10-05 23:56:52 UTC
On Fri, 28 Sep 2012 18:44:28 +1000
Tony Maher <tonymaher@optusnet.com.au> wrote:

> Hello,
> the patch file files/patch-py-test-Ice-properties-run.py appears to
> have weird characters in the ConfigPath setting so cannot test.
> cheers

Hi Tony,

Can you work with this patch now or is there anything else you need me
to do, so you can move forward testing this? I did some systematic
testing in the PR system and as it turns out, it's impossible to upload
a patch containing UTF-8 characters that will download cleanly. So
please either use one of the options I provided (base64 etc.) or just
take the gz I mailed you (you were CCed directly). I could mail the
patch once more forcing an UTF-8 character set onto it, but this would
still break the download (so you would have to copy and paste and what
would be the point in that).

Please see here for reference on the issues found in the PR system:

http://www.freebsd.org/cgi/query-pr.cgi?pr=www/172195

It would be good to have this done in a timely manner, since it works
hand in hand with:

http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/171643

Again, if there is anything else I could do to make this easier for you
please let me know.

Thanks,
Michael

-- 
Michael Gmelin
Comment 9 tonymaher 2012-10-06 00:06:56 UTC
Hello Michael,

On 10/06/12 08:56, Michael Gmelin wrote:
> On Fri, 28 Sep 2012 18:44:28 +1000
> Tony Maher <tonymaher@optusnet.com.au> wrote:
>
>> Hello,
>> the patch file files/patch-py-test-Ice-properties-run.py appears to
>> have weird characters in the ConfigPath setting so cannot test.
>> cheers
>
> Hi Tony,
>
> Can you work with this patch now or is there anything else you need me
> to do, so you can move forward testing this? I did some systematic
> testing in the PR system and as it turns out, it's impossible to upload
> a patch containing UTF-8 characters that will download cleanly. So
> please either use one of the options I provided (base64 etc.) or just
> take the gz I mailed you (you were CCed directly). I could mail the
> patch once more forcing an UTF-8 character set onto it, but this would
> still break the download (so you would have to copy and paste and what
> would be the point in that).
>
> Please see here for reference on the issues found in the PR system:
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=www/172195
>
> It would be good to have this done in a timely manner, since it works
> hand in hand with:
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/171643
>
> Again, if there is anything else I could do to make this easier for you
> please let me know.
>
> Thanks,
> Michael


I did not get email from your update to the patch from the PR system
but I scanned the PR last night and downloaded.
I do not know if I did something wrong but the patches all showed up in the
package directory and not the files directory and I had to manually move.
After doing that it appeared to build ok but I was not sure if I had got all the new
stuff or not.

About to go out for the day so cannot investigate more until tonite.

However I ma happy if you go ahead and commit.  You can also remove me as maintainer as
I do not work with Ice now and have less time.

Sorry for the delaying your work.

cheers
-- 
Tony Maher                    email: tonymaher@optusnet.com.au
Comment 10 Michael Gmelin 2012-10-06 00:45:13 UTC
On Sat, 06 Oct 2012 09:06:56 +1000
Tony Maher <tonymaher@optusnet.com.au> wrote:

> Hello Michael,
> On 10/06/12 08:56, Michael Gmelin wrote:
> > On Fri, 28 Sep 2012 18:44:28 +1000
> > Tony Maher <tonymaher@optusnet.com.au> wrote:
> >
> >> Hello,
> >> the patch file files/patch-py-test-Ice-properties-run.py appears to
> >> have weird characters in the ConfigPath setting so cannot test.
> >> cheers
> >
> > Hi Tony,
> >
> > Can you work with this patch now or is there anything else you need
> > me to do, so you can move forward testing this? I did some
> > systematic testing in the PR system and as it turns out, it's
> > impossible to upload a patch containing UTF-8 characters that will
> > download cleanly. So please either use one of the options I
> > provided (base64 etc.) or just take the gz I mailed you (you were
> > CCed directly). I could mail the patch once more forcing an UTF-8
> > character set onto it, but this would still break the download (so
> > you would have to copy and paste and what would be the point in
> > that).
> >
> > Please see here for reference on the issues found in the PR system:
> >
> > http://www.freebsd.org/cgi/query-pr.cgi?pr=www/172195
> >
> > It would be good to have this done in a timely manner, since it
> > works hand in hand with:
> >
> > http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/171643
> >
> > Again, if there is anything else I could do to make this easier for
> > you please let me know.
> >
> > Thanks,
> > Michael
> I did not get email from your update to the patch from the PR system
> but I scanned the PR last night and downloaded.
> I do not know if I did something wrong but the patches all showed up
> in the package directory and not the files directory and I had to
> manually move. After doing that it appeared to build ok but I was not
> sure if I had got all the new stuff or not.
> About to go out for the day so cannot investigate more until tonite.
> However I ma happy if you go ahead and commit.  You can also remove
> me as maintainer as I do not work with Ice now and have less time.
> Sorry for the delaying your work.
> cheers

Hi Tony,

Thanks for you quick response. If you don't have the resources to
maintain the port right now and if you're ok with it I would like to
take over maintainership for the devl/py-ice port. It would make sense
since I'm also maintaining devel/ice and updates usually affect both
ports anyway. In that case it might make sense to close the current
ticket and I would submit a new one, which includes my email address as
the new maintainer (afaik this should work, if not, maybe it would be
better if you could submit it yourself - not entirely sure, since I
only did this once before).

If you prefer to keep maintainership or if you want to push out that
update before initiating a takeover, I attached the patch again
in gzip format to this email once more (knowing that it will not show
up correctly in the PR system right now). I also double checked it
applies cleanly, this is the way I applied it to a freshly checked out
ports tree:

cd /usr/ports/devel/py-ice
zcat /tmp/py27-Ice-3.4.2_3.patch.gz | patch -p0 -E
find . -name \*.orig -delete

This results in:

[root@bsd /usr/ports/devel/py-ice]# find .
.
./distinfo
./pkg-plist
./Makefile
./files
./files/Make.rules.FreeBSD
./files/patch-py-python-Makefile
./files/patch-py-test-Ice-info-AllTests.py
./files/patch-config-Make.common.rules
./files/patch-py-test-Ice-properties-run.py
./files/patch-py-config-Make.rules
./pkg-descr

Please double check if this worked ok, since the patch removed files. 
If you had to manually move things into place, emptying/removing files
might also have failed (and manual intervention shouldn't be necessary
if applied using patch -p0 -E). I probably should have put that in the
original post, sorry.

Cheers,
Michael


-- 
Michael Gmelin
Comment 11 tonymaher 2012-10-06 08:06:11 UTC
Ok this all worked fine so can commit and make yourself maintainer.

thanks!
-- 
Tony Maher                    email: tonymaher@optusnet.com.au
Comment 12 Mark Linimon freebsd_committer freebsd_triage 2012-10-06 12:40:25 UTC
State Changed
From-To: feedback->open

approved by previous maintainer.
Comment 13 Ruslan Makhmatkhanov freebsd_committer 2012-10-17 21:02:42 UTC
Responsible Changed
From-To: freebsd-python->rm

I will take it. Hi Michael. Would you please put your patch somewhere 
and post the link there. I always got 'not in gzip format' using your 
latest submission. Thank you
Comment 14 Ruslan Makhmatkhanov freebsd_committer 2012-10-27 21:02:30 UTC
State Changed
From-To: open->closed

Committed with some modifications, thank you!