Bug 171799 - astro/py-metar: OptionsNG issue: config options not saved
Summary: astro/py-metar: OptionsNG issue: config options not saved
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-20 03:00 UTC by Craig Leres
Modified: 2012-11-14 10:56 UTC (History)
1 user (show)

See Also:


Attachments
py-metar.diff.txt (533 bytes, text/plain; charset=UTF-8)
2012-11-02 16:13 UTC, cvs-src
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Leres freebsd_committer 2012-09-20 03:00:22 UTC
	The py-metar package always fires up the "make config" dialog.

How-To-Repeat: 	This sequence shows the problem:

	    make config
	    make
	    rm -rf work
	    make

	Notice that dialog starts up again and that any options
	changed earlier have reverted to their port defaults.

	I used ktrace/kdump and found that make is looking in two
	different directories for the options file:

	    ktrace -di make
	    kdump | fgrep NAMI | fgrep /var/db/ports
	     11049 make     NAMI  "/var/db/ports/metar/options"
	     11049 make     NAMI  "/var/db/ports/metar/options.local"
	     11049 make     NAMI  "/var/db/ports/metar/options"
	     11049 make     NAMI  "/var/db/ports/metar/options.local"
	     11049 make     NAMI  "/var/db/ports/py27-metar/options"
	     11069 make     NAMI  "/var/db/ports/metar/options"
	     11069 make     NAMI  "/var/db/ports/metar/options.local"
	     11069 make     NAMI  "/var/db/ports/metar/options"
	     11069 make     NAMI  "/var/db/ports/metar/options.local"
	     11069 make     NAMI  "/var/db/ports/py27-metar/options"
	     11085 mkdir    NAMI  "/var/db/ports"
	     11085 mkdir    NAMI  "/var/db/ports"
	     11085 mkdir    NAMI  "/var/db/ports/py27-metar"
	     11085 mkdir    NAMI  "/var/db/ports/py27-metar"

	I see other ports that set OPTIONSFILE but I'm not sure if
	the problem is with the OptionsNG in py-metar's Makefile
	or with OptionsNG itself.
Comment 1 Edwin Groothuis freebsd_committer 2012-09-20 03:00:33 UTC
Responsible Changed
From-To: freebsd-ports-bugs->sunpoet

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 cvs-src 2012-11-02 16:13:34 UTC
Hi Po-Chuan,

would you commit/approve patch attached? It resolves the issue by adding 
OPTIONSFILE as original submitter suggests. Thanks.

-- 
Regards,
Ruslan

Tinderboxing kills... the drives.
Comment 3 Ruslan Makhmatkhanov freebsd_committer 2012-11-14 10:56:47 UTC
State Changed
From-To: open->closed

Committed, thank you!